Bug 247540

Summary: www/py-requests-oauthlib: Update to 1.3.0
Product: Ports & Packages Reporter: John Hay <john>
Component: Individual Port(s)Assignee: Kubilay Kocak <koobs>
Status: Open ---    
Severity: Affects Only Me CC: lwhsu, skreuzer
Priority: --- Keywords: needs-qa
Version: LatestFlags: koobs: maintainer-feedback+
Hardware: Any   
OS: Any   
URL: https://github.com/requests/requests-oauthlib/blob/v1.3.0/HISTORY.rst
Bug Depends on: 247539    
Bug Blocks:    
Attachments:
Description Flags
update of www/py-requests-oauthlib to 1.3.0 none

Description John Hay 2020-06-25 16:09:06 UTC
Created attachment 215938 [details]
update of www/py-requests-oauthlib to 1.3.0

Here is a patch to upgrade www/py-requests-oauthlib to 1.3.0

https://github.com/requests/requests-oauthlib/releases

It will need the update of security/py-oauthlib in

https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=247539
Comment 1 Li-Wen Hsu freebsd_committer 2020-08-13 08:51:24 UTC
Final ping before marking this maintainer timeout.
Comment 2 Kubilay Kocak freebsd_committer freebsd_triage 2020-08-13 09:40:22 UTC
Noted from changelog:

  This project now depends on OAuthlib 3.0.0 and above. It does not support versions of OAuthlib before 3.0.0.

All other security/py-oauthlib dependends need similar QA confirmation, see bug 247539