Bug 248911

Summary: [exp-run] devel/bison: Update to 3.7.4
Product: Ports & Packages Reporter: Sunpoet Po-Chuan Hsieh <sunpoet>
Component: Individual Port(s)Assignee: Port Management Team <portmgr>
Status: Closed FIXED    
Severity: Affects Only Me CC: daniel.engberg.lists
Priority: --- Flags: sunpoet: exp-run?
Version: Latest   
Hardware: Any   
OS: Any   
URL: https://people.FreeBSD.org/~sunpoet/patch/devel-bison-v3.txt

Description Sunpoet Po-Chuan Hsieh freebsd_committer 2020-08-25 20:24:04 UTC
Request exp-run.
Comment 1 Antoine Brodin freebsd_committer 2020-08-28 12:40:24 UTC
Some new failure logs:

http://package18.nyi.freebsd.org/data/121amd64-default-PR244494/2020-08-26_22h05m56s/logs/errors/verilator-4.040.log
http://package18.nyi.freebsd.org/data/121amd64-default-PR244494/2020-08-26_22h05m56s/logs/errors/iverilog-10.3.log
http://package18.nyi.freebsd.org/data/121amd64-default-PR244494/2020-08-26_22h05m56s/logs/errors/electron4-4.2.12_4.log
http://package18.nyi.freebsd.org/data/121amd64-default-PR244494/2020-08-26_22h05m56s/logs/errors/electron5-5.0.13.log
http://package18.nyi.freebsd.org/data/121amd64-default-PR244494/2020-08-26_22h05m56s/logs/errors/electron6-6.1.12_1.log
http://package18.nyi.freebsd.org/data/121amd64-default-PR244494/2020-08-26_22h05m56s/logs/errors/electron7-7.3.1_1.log
http://package18.nyi.freebsd.org/data/121amd64-default-PR244494/2020-08-26_22h05m56s/logs/errors/xcoral-3.47_4.log
http://package18.nyi.freebsd.org/data/121amd64-default-PR244494/2020-08-26_22h05m56s/logs/errors/vultures-eye-2.3.67_3.log
http://package18.nyi.freebsd.org/data/121amd64-default-PR244494/2020-08-26_22h05m56s/logs/errors/ptoc-3.58_1.log
http://package18.nyi.freebsd.org/data/121amd64-default-PR244494/2020-08-26_22h05m56s/logs/errors/cvc3-2.4.1_7.log
http://package18.nyi.freebsd.org/data/121amd64-default-PR244494/2020-08-26_22h05m56s/logs/errors/olsrd-0.9.8.log
http://package18.nyi.freebsd.org/data/121amd64-default-PR244494/2020-08-26_22h05m56s/logs/errors/qt5-webengine-5.15.0_2.log
http://package18.nyi.freebsd.org/data/121amd64-default-PR244494/2020-08-26_22h05m56s/logs/errors/qt5-webkit-5.212.0.a4_3.log
http://package18.nyi.freebsd.org/data/121amd64-default-PR244494/2020-08-26_22h05m56s/logs/errors/buici-clock-0.4.9.4_1.log
Comment 2 daniel.engberg.lists 2020-10-01 22:56:05 UTC
Hi,

3.7.2 is out which seems to fix some regressions

https://lists.gnu.org/archive/html/info-gnu/2020-09/msg00003.html

Best regards,
Daniel
Comment 3 Sunpoet Po-Chuan Hsieh freebsd_committer 2020-10-02 18:46:15 UTC
I've already prepared bison 3.7.2 update and fixes for all failures except electron (because it does not build on my box). Since devel/electron* has the same failure as www/qt5-webkit, I've sent the patch to maintainer (tagattie@FreeBSD.org) for testing.

I think the new patch is ready for another exp-run.
Comment 5 Sunpoet Po-Chuan Hsieh freebsd_committer 2021-01-03 00:09:26 UTC
Update to 3.7.4.
Comment 7 commit-hook freebsd_committer 2021-01-26 13:59:34 UTC
A commit references this bug:

Author: sunpoet
Date: Tue Jan 26 13:58:55 UTC 2021
New revision: 562664
URL: https://svnweb.freebsd.org/changeset/ports/562664

Log:
  Update to 3.7.4

  Changes:	https://git.savannah.gnu.org/cgit/bison.git/tree/NEWS
  PR:		248911
  Exp-run by:	antoine

Changes:
  head/devel/bison/Makefile
  head/devel/bison/distinfo
Comment 8 commit-hook freebsd_committer 2021-01-26 13:59:35 UTC
A commit references this bug:

Author: sunpoet
Date: Tue Jan 26 13:59:29 UTC 2021
New revision: 562665
URL: https://svnweb.freebsd.org/changeset/ports/562665

Log:
  Fix build with bison 3.7.4

  PR:		248911
  Exp-run by:	antoine

Changes:
  head/cad/verilator/files/patch-src-verilog.y
  head/editors/xcoral/files/patch-Makefile
  head/games/vultures-eye/files/patch-..-vulture-GNUmakefile
  head/games/vultures-eye/files/patch-..-vulture-vulture_tileconfig.lexer.l
  head/lang/ptoc/files/patch-main.cxx
  head/lang/ptoc/files/patch-makefile.bsd
  head/lang/ptoc/files/patch-parser.y
  head/lang/ptoc/files/patch-tpexpr.cxx
  head/lang/ptoc/files/patch-trnod.cxx
  head/math/cvc3/files/patch-src-parser-Makefile
  head/net/olsrd/files/patch-src-cfgparser-local.mk
  head/www/qt5-webkit/files/patch-Source_ThirdParty_ANGLE_src_compiler_preprocessor_ExpressionParser.y
  head/www/qt5-webkit/files/patch-Source_WebCore_css_CSSGrammar.y.in
  head/www/qt5-webkit/files/patch-Source_WebCore_css_makegrammar.pl
  head/www/qt5-webkit/files/patch-Source_WebCore_xml_XPathGrammar.y
  head/x11-clocks/buici-clock/files/patch-xo_Makefile.in
  head/x11-clocks/buici-clock/files/patch-xo_res.cxx
  head/x11-clocks/buici-clock/files/patch-xo_res__l.l
Comment 9 Sunpoet Po-Chuan Hsieh freebsd_committer 2021-01-26 14:22:43 UTC
Committed. Thanks!