Bug 249186

Summary: ports-mgmt/pkg: pkg upgrade extremely slow with IPv6
Product: Ports & Packages Reporter: Simon Walton <simon>
Component: Individual Port(s)Assignee: Cluster Admin <clusteradm>
Status: Closed Unable to Reproduce    
Severity: Affects Only Me CC: doctorwhoguy, philip, zi
Priority: --- Flags: bugzilla: maintainer-feedback? (pkg)
Version: Latest   
Hardware: Any   
OS: Any   

Description Simon Walton 2020-09-08 06:08:03 UTC
Experienced on 12.1-p8, amd64. Simple pkg upgrade can take several hours when IPv6 is enabled. Switching to IPv4 (with ip6addrctl) immediately speeds up the operation.
Comment 1 Philip Paeps freebsd_committer 2021-08-18 12:21:09 UTC
Which mirror?  traceroute?
Comment 2 Ryan Steinmetz freebsd_committer freebsd_triage 2021-08-18 20:25:16 UTC
and are you going through a v6 over v4 tunnel?
Comment 3 Simon Walton 2021-08-22 08:08:28 UTC
The connection was a direct v6, not via a tunnel.
The problem no longer occurs - I don't know if this is due to upgrading to 12.2 or some other change.
Comment 4 Philip Paeps freebsd_committer 2021-09-01 05:42:00 UTC
Please let us know if this happens again, and do include a traceroute so we know which mirror you're hitting.  Thanks.