Bug 250288

Summary: www/nextcloud: nextcloud-php74-20.0.0 severely broken
Product: Ports & Packages Reporter: oz42
Component: Individual Port(s)Assignee: Bernard Spil <brnrd>
Status: Closed FIXED    
Severity: Affects Only Me Flags: bugzilla: maintainer-feedback? (brnrd)
Priority: Normal    
Version: Latest   
Hardware: Any   
OS: Any   
Attachments:
Description Flags
browser console log: errors after sucessful login none

Description oz42 2020-10-12 09:19:06 UTC
After upgrading to 20.0 NC loads very slow, and after logging in I get a blank page.


My browser's developer console shows these errors, so I selected "affects many people":


No OC found main.js:1:323308
JQMIGRATE: Migrate is installed, version 1.4.1 main.js:1:917387
jQuery is deprecated: The global jQuery is deprecated. It will be updated to v3.x in Nextcloud 21. In later versions of Nextcloud it might be removed completely. Please ship your own. main.js:1:1407020
$ is deprecated: The global jQuery is deprecated. It will be updated to v3.x in Nextcloud 21. In later versions of Nextcloud it might be removed completely. Please ship your own. 4 main.js:1:1407020
Notifications permissions not yet requested notifications-main.js:303:5999
jQuery is deprecated: The global jQuery is deprecated. It will be updated to v3.x in Nextcloud 21. In later versions of Nextcloud it might be removed completely. Please ship your own. main.js:1:1407020
$ is deprecated: The global jQuery is deprecated. It will be updated to v3.x in Nextcloud 21. In later versions of Nextcloud it might be removed completely. Please ship your own. main.js:1:1407020
OCA.Files.Sidebar initialized sidebar.js:1:603928
Handlebars is deprecated: please ship your own, this will be removed in Nextcloud 20 3 main.js:1:1407020
OCA.Sharing.ShareSearch initialized files_sharing_tab.js:1:1069212
OCA.Sharing.ExternalLinkActions initialized files_sharing_tab.js:1:1070415
OCA.Viewer initialized viewer-main.js:424:615
No OCA.Files app found, viewer is now in standalone mode viewer-main.js:403:8242
jQuery is deprecated: The global jQuery is deprecated. It will be updated to v3.x in Nextcloud 21. In later versions of Nextcloud it might be removed completely. Please ship your own. 2 main.js:1:1407020
session heartbeat polling started main.js:1:711925
$ is deprecated: The global jQuery is deprecated. It will be updated to v3.x in Nextcloud 21. In later versions of Nextcloud it might be removed completely. Please ship your own. 2 main.js:1:1407020
[DEBUG] unified-search: Unified Search initialized with the following providers 
Object { 0: {…}, 1: {…}, 2: {…}, 3: {…}, 4: {…}, 5: {…}, 6: {…}, app: "unified-search", uid: "admin" }
unified-search.js:1:271869
Source-Map-Fehler: Error: JSON.parse: unexpected character at line 1 column 1 of the JSON data
Ressourcen-Adresse: https://foo.bar.com/core/js/dist/main.js?v=a01e4c4f
Source-Map-Adresse: main.js.map
Source-Map-Fehler: Error: JSON.parse: unexpected character at line 1 column 1 of the JSON data
Ressourcen-Adresse: https://foo.bar.com/apps-pkg/notifications/js/notifications-main.js?v=a01e4c4f
Source-Map-Adresse: notifications-main.js.map?v=7e353c6fdd2e67ae30c6
Source-Map-Fehler: Error: JSON.parse: unexpected character at line 1 column 1 of the JSON data
Ressourcen-Adresse: https://foo.bar.com/apps-pkg/files/js/dist/sidebar.js?v=a01e4c4f
Source-Map-Adresse: sidebar.js.map
Source-Map-Fehler: Error: JSON.parse: unexpected character at line 1 column 1 of the JSON data
Ressourcen-Adresse: https://foo.bar.com/apps-pkg/viewer/js/viewer-main.js?v=a01e4c4f
Source-Map-Adresse: viewer-main.js.map?v=a2e8a2ac3fb44737505b
Source-Map-Fehler: Error: JSON.parse: unexpected character at line 1 column 1 of the JSON data
Ressourcen-Adresse: https://foo.bar.com/apps-pkg/comments/js/comments.js?v=a01e4c4f
Source-Map-Adresse: comments.js.map
Source-Map-Fehler: Error: JSON.parse: unexpected character at line 1 column 1 of the JSON data
Ressourcen-Adresse: https://foo.bar.com/apps-pkg/dashboard/js/dashboard.js?v=a01e4c4f
Source-Map-Adresse: dashboard.js.map
Source-Map-Fehler: Error: JSON.parse: unexpected character at line 1 column 1 of the JSON data
Ressourcen-Adresse: https://foo.bar.com/apps-pkg/files_versions/js/files_versions.js?v=a01e4c4f
Source-Map-Adresse: files_versions.js.map
Source-Map-Fehler: Error: JSON.parse: unexpected character at line 1 column 1 of the JSON data
Ressourcen-Adresse: https://foo.bar.com/apps-pkg/weather_status/js/weather-status.js?v=a01e4c4f
Source-Map-Adresse: weather-status.js.map?v=94148fc39a19f6a917dc
Source-Map-Fehler: Error: JSON.parse: unexpected character at line 1 column 1 of the JSON data
Ressourcen-Adresse: https://foo.bar.com/apps-pkg/user_status/js/dashboard.js?v=a01e4c4f
Source-Map-Adresse: dashboard.js.map?v=0fb69be22d77fd1de7cd
Source-Map-Fehler: Error: JSON.parse: unexpected character at line 1 column 1 of the JSON data
Ressourcen-Adresse: https://foo.bar.com/apps-pkg/user_status/js/user-status-menu.js?v=a01e4c4f
Source-Map-Adresse: user-status-menu.js.map?v=0a88765960dce5670a91
Source-Map-Fehler: Error: JSON.parse: unexpected character at line 1 column 1 of the JSON data
Ressourcen-Adresse: https://foo.bar.com/apps-pkg/files_sharing/js/dist/files_sharing_tab.js?v=a01e4c4f
Source-Map-Adresse: files_sharing_tab.js.map
Source-Map-Fehler: Error: JSON.parse: unexpected character at line 1 column 1 of the JSON data
Ressourcen-Adresse: https://foo.bar.com/apps-pkg/recommendations/js/dashboard.js?v=a01e4c4f
Source-Map-Adresse: dashboard.js.map
Source-Map-Fehler: Error: JSON.parse: unexpected character at line 1 column 1 of the JSON data
Ressourcen-Adresse: https://foo.bar.com/core/js/dist/unified-search.js?v=a01e4c4f
Source-Map-Adresse: unified-search.js.map
Comment 1 oz42 2020-10-12 09:21:50 UTC
Created attachment 218683 [details]
browser console log: errors after sucessful login
Comment 2 Bernard Spil freebsd_committer 2020-10-12 09:33:37 UTC
Cannot replicate and don't think this affects many users.

Guessing this is an issue with an App that you've got. Move all contents from /usr/local/www/nextcloud/apps to somewhere else and try again.

Let me know if that helps
Comment 3 oz42 2020-10-12 10:12:20 UTC
/usr/local/www/nextcloud/apps is empty.
Comment 4 oz42 2020-10-12 13:10:39 UTC
I cannot tell what went wrong with pkg upgrade, but I found another bug: pkg delete removed everything from the /apps folder.

I have installed a 2nd Nextcloud and copied all /apps files to my old system, now it works.

pkg delete should not touch files that it has not installed, just like it does with config/config.php
Comment 5 Bernard Spil freebsd_committer 2020-10-18 13:23:17 UTC
I checked this on a clean install

 1. rm -rf /usr/local/www/nextcloud
 2. pkg install nextcloud-php74
 3. mkdir /usr/local/www/nextcloud/pkg/myapp
 4. echo 'hello' > /usr/local/www/nextcloud/pkg/myapp/appinfo.xml
 5. pkg delete nextcloud-php74
 6. cat /usr/local/www/nextcloud/pkg/myapp/appinfo.xml
    hello

Can't reproduce. Let me know if you can gather additional info!