Bug 250537

Summary: graphics/sane-backends: bad image size
Product: Ports & Packages Reporter: byronc <wa4geg>
Component: Individual Port(s)Assignee: freebsd-ports-bugs (Nobody) <ports-bugs>
Status: Closed Overcome By Events    
Severity: Affects Some People CC: fernape, lwhsu, tcberner, tobik, vvd, wa4geg
Priority: ---    
Version: Latest   
Hardware: amd64   
OS: Any   
Bug Depends on: 253562    
Bug Blocks:    

Description byronc 2020-10-22 17:10:23 UTC
HP Scanjet 5370C stopped working correctly after FreeBSD 'pkg upgrade' to  
sane-backends-1.0.31_1 (FreeBSD 12.1-RELEASE p10). The image of scanned 8.5x11 inch letter size document ends up 1/4 the size of the original. The problem is nonexistent for my backup machine (FreeBSD 12.1-RELEASE p6) using sane-backends-1.0.29. Both machines are using xsane-0.999_6 for a frontend.

Just for grins I loaded up Linux (Void) on a test box and installed sane-1.0.31_1. Testing again with an HP Scanjet 5370C gave the same quirky 1/4 sized scan. No amount of setting changes in Xsane affect the image scale, in either FreeBSD or Linux.
Comment 1 Fernando ApesteguĂ­a freebsd_committer 2020-10-23 16:57:01 UTC
It looks like a problema upstream then?
Comment 2 VVD 2020-10-23 17:17:15 UTC
Try to report upstream.
Comment 3 byronc 2020-12-20 09:31:52 UTC
Upstream confirms the problem and released the fix on 12/20/2020 as version: sane-backends-1.0.31-208

regards,
Byron Campbell
Comment 4 VVD 2020-12-20 14:30:53 UTC
(In reply to byronc from comment #3)
> Upstream confirms the problem and released the fix on 12/20/2020 as version: sane-backends-1.0.31-208
I see the commit to the master: https://gitlab.com/sane-project/backends/-/commits/master
but don't see the release: https://gitlab.com/sane-project/backends/-/releases
Comment 5 VVD 2021-02-16 16:55:13 UTC
(In reply to byronc from comment #3)
Check new release: https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=253562
Comment 6 VVD 2021-02-16 22:25:04 UTC
(In reply to byronc from comment #3)
If it work fine for you then close this PR plz.
Comment 7 Fernando ApesteguĂ­a freebsd_committer 2021-02-24 07:06:38 UTC
port was updated in ports r565463