Bug 250849

Summary: ports-mgmt/portshaker: use either subversion 1.14 or LTS depending on make.conf variable
Product: Ports & Packages Reporter: Norikatsu Shigemura <nork>
Component: Individual Port(s)Assignee: Romain Tartière <romain>
Status: Closed FIXED    
Severity: Affects Some People Keywords: buildisok
Priority: --- Flags: bugzilla: maintainer-feedback? (romain)
Version: Latest   
Hardware: Any   
OS: Any   
See Also: https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=190946
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=250848
Attachments:
Description Flags
Respect WITH_SUBVERSION_VER none

Description Norikatsu Shigemura 2020-11-04 03:37:33 UTC
Created attachment 219344 [details]
Respect WITH_SUBVERSION_VER

Respect WITH_SUBVERSION_VER.
Comment 1 Automation User 2020-11-19 01:03:07 UTC
Build and package info is available at https://gitlab.com/swills/freebsd-ports/pipelines/218208041
Comment 2 commit-hook freebsd_committer 2020-12-14 02:19:17 UTC
A commit references this bug:

Author: romain
Date: Mon Dec 14 02:18:53 UTC 2020
New revision: 558072
URL: https://svnweb.freebsd.org/changeset/ports/558072

Log:
  Fix usage of WITH_SUBVERSION_VER

  devel/subversion used to be available in different versions from which the
  end-user could choose by setting WITH_SUBVERSION_VER to the expected version.
  This has been reworked at some point and broke that feature in portshaker.

  Adjust the WITH_SUBVERSION_VER handling to cope with it again.

  PR:		250849
  Submitted by:	nork@ninth-nine.com

Changes:
  head/ports-mgmt/portshaker/Makefile
Comment 3 Romain Tartière freebsd_committer 2020-12-14 02:20:09 UTC
Hello, thank you for this PR.  I am sorry to only take the time to dig in this today, thank you for the great work!