Bug 251772

Summary: devel/codeville: remove DEPRECIATED, upgrade to 0.1.18
Product: Ports & Packages Reporter: Chris Hutchinson <portmaster>
Component: Individual Port(s)Assignee: Luca Pizzamiglio <pizzamig>
Status: Closed FIXED    
Severity: Affects Some People CC: pizzamig
Priority: --- Keywords: easy, patch, patch-ready
Version: LatestFlags: pizzamig: maintainer-feedback?
Hardware: Any   
OS: Any   
Attachments:
Description Flags
svn diff for devel/codeville
portmaster: maintainer-approval+
QA build log for devel/codeville
none
svn diff for devel/codeville (version 2)
portmaster: maintainer-approval+
svn diff for devel/codeville (version 3)
portmaster: maintainer-approval+
svn diff to remove the devel/codeville from MOVED portmaster: maintainer-approval+

Description Chris Hutchinson 2020-12-12 02:02:20 UTC
Created attachment 220473 [details]
svn diff for devel/codeville

This pr reintroduces devel/codeville
The port was removed for DEPERECIATED (py27 depends)
This version of devel/codeville now supports at *least*
the py37 AST.

QA build log && svn diff attached.

Thanks!

--Chris
Comment 1 Chris Hutchinson 2020-12-12 02:03:50 UTC
Created attachment 220474 [details]
QA build log for devel/codeville

The QA build log for devel/codeville
Comment 2 Chris Hutchinson 2020-12-15 18:28:24 UTC
Created attachment 220586 [details]
svn diff for devel/codeville (version 2)

This is an update to the previous patch.
The proposed change in this pr reintroduces devel/codeville
which was removed due to py27 depends.
This version supports python 2.7 thru 3.7+

Additions to previous patch
MOVED
 - removes devel/codeville

Makefile
 - adds build/run depends shim for backward compatibility (devel/py-future)
 - adds autoplist
pkg-plist (removed)

Builds/Tests/Works as intended on 12.1/amd64/Python 3.7.9

Changes:
MOVED
devel/codeville/Makefile
devel/codeville/distinfo
devel/codeville/pkg-descr

That's it.

Thanks!

--Chris
Comment 3 Chris Hutchinson 2020-12-28 23:52:49 UTC
ping
Comment 4 Luca Pizzamiglio freebsd_committer 2021-01-31 21:09:59 UTC
The build fails because of the patch-setup.py file, that seems already applied in the original sources.

Am I correct assuming that this patch file can be removed?

In general, I would need to add the port as if it was a new port, but also removing the entry in MOVED.
Comment 5 Chris Hutchinson 2021-02-08 19:25:46 UTC
(In reply to Luca Pizzamiglio from comment #4)
Right. Let me double check. I already included the
change entry in MOVED. But I'll double check the
patch file for duplication, and report back later
today.

Thanks for taking the time. :-)

--Chris
Comment 6 Chris Hutchinson 2021-02-08 20:45:29 UTC
Created attachment 222278 [details]
svn diff for devel/codeville (version 3)

Alright. Here's a newer svn diff that only includes
devel/codeville. As before, it bumps the version
from 0.1.17 to 0.1.18. The version bump is required
to make it py-3 buildable/functionable. I can add a
modified MOVED separately, or with this patch.

Please advise.

Thanks!

--Chris
Comment 7 Luca Pizzamiglio freebsd_committer 2021-02-08 20:48:57 UTC
(In reply to Chris Hutchinson from comment #6)

Hi thanks for working on it again.
I would keep the two patches separated, for my convenience.
Comment 8 Chris Hutchinson 2021-02-08 21:23:28 UTC
Created attachment 222279 [details]
svn diff to remove the devel/codeville from MOVED

Done.
Understood.

Thanks! :-)

--Chris
Comment 9 commit-hook freebsd_committer 2021-02-09 22:01:17 UTC
A commit references this bug:

Author: pizzamig
Date: Tue Feb  9 22:00:58 UTC 2021
New revision: 564823
URL: https://svnweb.freebsd.org/changeset/ports/564823

Log:
  (Readdition of devel/codeville which was removed on 548979)

  Add codeville 0.1.18, anarchic control version system without
  unnecessary re-merges.

  Reintroduce the port, after porting it to Python 3.

  PR:		251772
  Submitted by:	Chris Hutchinson <portmaster@bsdforge.com>

Changes:
  head/MOVED
  head/devel/Makefile
  head/devel/codeville/
  head/devel/codeville/Makefile
  head/devel/codeville/distinfo
  head/devel/codeville/files/patch-MANIFEST.in
  head/devel/codeville/files/patch-setup.py
_U  head/devel/codeville/pkg-descr
Comment 10 Luca Pizzamiglio freebsd_committer 2021-02-09 22:06:46 UTC
Hi. The last patch you uploaded was based on an old revision, that still contained the codeville port.
Please, next time generate the patches using a recent/compatible tree, I had to recreate the port manually. I also rebuild the patches via make makepatch.

Now the port is committed.

For the next time, I would suggest you to use ports-mgmt/portlint, it's a nice tool that provide suggestions on how to improve the port quality.

Thanks!
Comment 11 Chris Hutchinson 2021-02-10 04:24:15 UTC
(In reply to Luca Pizzamiglio from comment #10)
Really sorry for all the work you had to put into this, Luca.
I'm afraid I've been misinformed. I was told to
svn co to the last revision available in the ports
tree and work from there. Rather than (re)introduce
it as fresh. So that's the way I've been doing t ever
since.
Sounds like I should be creating it as a new port
with mention it used to be in the tree, and add the
modified MOVED to accommodate it.

Thanks a million!

--Chris