Bug 252319

Summary: [patch] net/samba412: unbreak libsmbclient.so
Product: Ports & Packages Reporter: Eugene Grosbein <eugen>
Component: Individual Port(s)Assignee: Timur I. Bakeyev <timur>
Status: Open ---    
Severity: Affects Only Me CC: eugen, vvd
Priority: --- Keywords: easy
Version: LatestFlags: bugzilla: maintainer-feedback? (timur)
eugen: maintainer-feedback?
Hardware: Any   
OS: Any   
Attachments:
Description Flags
install libaesni-intel-samba4.so eugen: maintainer-approval?

Description Eugene Grosbein freebsd_committer 2021-01-01 06:31:33 UTC
Created attachment 221154 [details]
install libaesni-intel-samba4.so

The port samba412-4.12.9_1 installs libsmbclient.so.0 that needs libaesni-intel-samba4.so that is built also, but the port fails to install it.

Trivial patch is attached to fix this.
Comment 1 VVD 2021-01-01 18:53:34 UTC
Is it relevant for net/samba413?
Comment 2 Eugene Grosbein freebsd_committer 2021-01-05 07:02:57 UTC
(In reply to VVD from comment #1)

I had no chance to test.
Comment 3 Timur I. Bakeyev freebsd_committer 2021-05-05 01:17:08 UTC
(In reply to Eugene Grosbein from comment #0)

Hi, Eugene!

There is obviously not enough information.

In normal setup libaesni-intel-samba4.so shouldn't be built anymore, so there is something non-common with your system.

I'd suspect that you have outdated gcrypt library. Are you building in the poudriere or on a live system?

Basically, I need more info.
Comment 4 Eugene Grosbein freebsd_committer 2021-05-05 08:21:11 UTC
This is dedicated building chroot for my NanoBSD-based home router, but poudriere  not used. At the moment gcrypt version was libgcrypt-1.8.7. I'm glad to supply any additional information, if needed. I'm ready for testing, too.