Bug 254002

Summary: devel/py-oci: fails to build automatically on FreeBSD build server
Product: Ports & Packages Reporter: Alessandro Sagratini <ale_sagra>
Component: Individual Port(s)Assignee: freebsd-ports-bugs (Nobody) <ports-bugs>
Status: Closed Overcome By Events    
Severity: Affects Only Me CC: rhurlin
Priority: ---    
Version: Latest   
Hardware: Any   
OS: Any   
Attachments:
Description Flags
build failure none

Description Alessandro Sagratini 2021-03-04 05:10:39 UTC
Created attachment 222963 [details]
build failure

Hello,
I received attached message from pkg-fallout: reading through it, I understand that latest py37-oci version is failing to build automatically because the build system is unable to find latest py37-cryptography version, that should be 3.3.2.

I am wondering:
 * will latest py37_cryptography version be built automatically so the error will eventually disappear?
 * other thoughts, as I would not want to rollback that dependency to previous version?

Thank you,
Alessandro
Comment 1 Rainer Hurling freebsd_committer 2021-03-04 14:16:55 UTC
(In reply to Alessandro Sagratini from comment #0)

Hmm, seems there is something odd with the package builder, as far as I understand.


=======================<phase: run-depends    >============================
..snip..]
===>   py37-oci-2.32.0 depends on package: py37-cryptography>=3.2.1 - not found
===>   Installing existing package /packages/All/py37-cryptography-2.9.2.txz
[114i386-default-job-06] Installing py37-cryptography-2.9.2...
[114i386-default-job-06] `-- Installing py37-cffi-1.14.5...
[114i386-default-job-06] |   `-- Installing py37-pycparser-2.20...
[114i386-default-job-06] |   `-- Extracting py37-pycparser-2.20: .......... done
[114i386-default-job-06] `-- Extracting py37-cffi-1.14.5: .......... done
[114i386-default-job-06] `-- Installing py37-six-1.15.0...
[114i386-default-job-06] `-- Extracting py37-six-1.15.0: .......... done
[114i386-default-job-06] Extracting py37-cryptography-2.9.2: .......... done
===>   py37-oci-2.32.0 depends on package: py37-cryptography>=3.2.1 - not found
*** Error code 1


Version >= 3.2.1 is wanted, v2.9.2. is built. Any v3.3.2 is the version in recent ports tree.
Comment 2 Alessandro Sagratini 2021-03-04 15:43:37 UTC
Hello Rainer,
you're, right, I am aware that py37-cryptography version in the ports tree is 3.3.2, I'm not sure why previous version is still picked up, which is what confused me, as well
Comment 3 Alessandro Sagratini 2021-04-13 13:39:29 UTC
issue still seem to be there, for FreeBSD 11.4
Comment 4 Rainer Hurling freebsd_committer 2021-04-13 14:22:34 UTC
(In reply to Alessandro Sagratini from comment #3)

Hi Alessandro,

If you write that the problem _still_ exists: Did you update your (Poudriere's) ports tree before you tried again?  We are now on a git based one ports tree with devel/py-oci v2.35.0 and security/py-cryptography v3.3.2 ...
Comment 5 Alessandro Sagratini 2021-04-13 17:31:06 UTC
Reiner, the problem is on pkg-fallout, not on my local poudriere build system....
Comment 6 Alessandro Sagratini 2021-04-13 17:32:08 UTC
I am aware the ports tree is now git'based, does that mean I can ignore the pkg-fallout e-mail?
Comment 7 Rainer Hurling freebsd_committer 2021-04-13 17:36:45 UTC
(In reply to Alessandro Sagratini from comment #6)

Oops, I should have read your initial description more carefully again before answering, sorry.

I am afraid I have no knowledge why pkg builder for 11.4 is failing here :(
Comment 8 Mark Linimon freebsd_committer freebsd_triage 2021-04-13 18:12:37 UTC
(In reply to Alessandro Sagratini from comment #6)
> I am aware the ports tree is now git-based, does that mean I can ignore the pkg-fallout e-mail?

No.  git (and svn before it) were only used to populate the tree.  The technology of building from the tree once it is populated remains the same.
Comment 9 Alessandro Sagratini 2021-04-14 10:01:16 UTC
(In reply to Mark Linimon from comment #8)
that's perfect, thank you Mark: I am aware the issue seems to be with FreeBSD 11.4 only, that should be phased out later this year, but is there anything that can be done, as I feel this port isn't the only affected one? 

Thank you