Bug 254211

Summary: editors/libreoffice fails to compile
Product: Ports & Packages Reporter: Rolf Halme <misantroposof>
Component: Individual Port(s)Assignee: FreeBSD Office Team <office>
Status: Closed FIXED    
Severity: Affects Only Me CC: lwhsu, misantroposof, mishin
Priority: --- Flags: bugzilla: maintainer-feedback? (office)
Version: Latest   
Hardware: amd64   
OS: Any   
See Also: https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=253738
Description Flags
Patch that fixes the problem none

Description Rolf Halme 2021-03-10 23:57:43 UTC
Created attachment 223177 [details]
Patch that fixes the problem

Very early in the build, almost immediately after configure, a warning appears, saying that %pure-parser is deprecated, and that %define api.pure should be used instead. After this warning it just hangs, and nothing else happens. I tried to edit the file named (unoidl/source/sourceprovider-parser.y), making the suggested change. After this, compilation runs fine. I stated "Affects only me" in the Severity field above, because I honestly don't know, but since it's a deprecation warning, it may well affect more. I'm running 13.0-RC1, built from source with custom kernel and several "WITHOUT_" lines in src.conf. I'm building ports in a clean chroot, with only the base and what the port currently being built requires, but I'm not using poudriere.
Comment 1 Rolf Halme 2021-03-11 00:12:45 UTC
Additional information:
MAKE_JOBS_UNSAFE=yes made no difference before I made the edit, but after editing it's needed.
Comment 2 Rolf Halme 2021-03-11 12:18:06 UTC
I did think it a bit strange that it would hang on a parser warning. I did not find the other report, but after reading it I also found the core dump, which I previously missed. I don't have the skills to analyze a core dump, but looking at it in lldb only reveals two frames, which to seem empty, only having an address. Anyway, my bet right now is that this is due to either my kernel configuration or to the fact that I have CPUTYPE set. I'm rebuilding everything, including world, without CPUTYPE set, and slight changes to kernel configuration. I'll get back when I know the results from that. I'll likely close this once in done with that, regardless of the outcome, since this hardly can be called a bug in libreoffice.
Comment 3 Alexander Mishin 2021-03-12 05:43:16 UTC
It seems to me that a warning itself is a source of the problem (the warning message is ends with a '[' as if there should be a some other text in square brackets).
Could it have something to do with the /lib/libncursesw.so.9 library?
Comment 4 Rolf Halme 2021-03-12 18:27:10 UTC
Still no luck, and I'm giving up on this.
Comment 5 Alexander Mishin 2021-03-12 19:46:45 UTC
I found a solution.
First I noticed that no bug when I run the bison with --color=never.
By next step I rebuilt the bison port without NLS option... and voila - a libreoffice port is still making, but both known as bugged steps have already been passed.
Comment 6 Rolf Halme 2021-03-12 19:49:57 UTC
(In reply to Alexander Mishin from comment #5)
Thanks. I shall try that asap.
Comment 7 Rolf Halme 2021-03-15 14:45:58 UTC
(In reply to Alexander Mishin from comment #5)
It took me a while, but I finally got the time to try your solution, and it works. Thanks a million.
Comment 8 Rolf Halme 2021-03-15 14:48:52 UTC
Changing the close reason to FIXED. This is not a bug in editors/libreoffice, and Not A Bug might have been appropriate, but it was a problem, and that problem has been fixed.