Bug 254250

Summary: x11/sddm - Selecting a Plasma desktop after having selected a Cinnamon desktop, sddm just puts me back in a Cinnamon desktop.
Product: Ports & Packages Reporter: Steven Friedrich <Steven.E.Friedrich>
Component: Individual Port(s)Assignee: freebsd-kde (Team) <kde>
Status: Closed Unable to Reproduce    
Severity: Affects Many People CC: adridg, grahamperrin
Priority: --- Flags: bugzilla: maintainer-feedback? (kde)
Version: Latest   
Hardware: Any   
OS: Any   

Description Steven Friedrich 2021-03-13 01:09:04 UTC
I installed sddm, and kde5(PLasma) KDE (Cinnamon), and xfce.
I launched sddm via service sddm onestart, and entered a KDE Plasma session, then logged out and entered a Cinnamon session. then logged out.
Every subsequent login to Plasma takes me into A Cinnamon session.
Comment 1 Steven Friedrich 2021-03-13 01:13:28 UTC
Donald Knuth - I've proven it's correct, but I haven't actually tried it.

HP-Slimline 290-p0014 Desktop using integrated UHD Graphics 630

Running KDE Neon 5.21.2, Kubuntu 20.10, Linux Mint 20.1 Cinnamon, and

FreeBSD FreeBSD 12.2-RELEASE-p4 FreeBSD 12.2-RELEASE-p4 r369434 Special  amd64

Path: /usr/ports
Working Copy Root Path: /usr/ports
URL: https://svn.freebsd.org/ports/head
Relative URL: ^/head
Repository Root: https://svn.freebsd.org/ports
Repository UUID: 35697150-7ecd-e111-bb59-0022644237b5
Revision: 568212
Node Kind: directory
Schedule: normal
Last Changed Author: yuri
Last Changed Rev: 568212
Last Changed Date: 2021-03-12 18:12:16 -0500 (Fri, 12 Mar 2021)
Comment 2 Graham Perrin 2021-03-13 13:59:10 UTC
Ignore my <https://lists.freebsd.org/pipermail/freebsd-questions/2021-March/293323.html>

I'll attempt to reproduce this bug with FreeBSD 14.0-CURRENT and latest …
Comment 3 Graham Perrin 2021-03-13 14:49:42 UTC
Not reproducible with FreeBSD 14.0-CURRENT. 

Menu options such as Plasma appear dimmed, which is cosmetically wrong, however selection of Plasma (after ending a Cinnamon session) does allow reuse of Plasma. 

For the wrongness in the menu, which appeared (to me) only after installation of x11/cinnamon, I wonder whether an upstream issue at https://github.com/linuxmint/cinnamon/issues is appropriate. Check the list of FreeBSD bugs via <https://www.freshports.org/x11/cinnamon/> first. (True: sddm appears wrong, however it seemed to be triggered by the presence of Cinnamon.)

Steven: if you have more than one display, maybe check that the display where you use the menu is the same as the display where you enter your password. 

Also, please update the title here to show something more distinctive than 'x11/sddm'. Thanks.
Comment 4 Steven Friedrich 2021-03-13 16:32:41 UTC
I only have a single display.
Comment 5 Steven Friedrich 2021-03-13 16:34:53 UTC
I'll try deinstalling cinnamon, and see what sddm does.  Then I'll re-install cinnamon, and test again.
Comment 6 Adriaan de Groot freebsd_committer 2021-05-22 20:41:24 UTC
Can't reproduce here -- 13-STABLE, ports home-built from main -- either. I have:

sddm-0.19.0_1 (not enabled; started through `onestart`)
cinnamon-4.8.6 (I **only** installed x11/cinnamon, and what deps that pulled in; this gets me a rather incomplete Cinnamon desktop I think)
plasma5-plasma-5.21.5 (which is what I run every day)

SDDM, login to Plasma X11: ok; logout
SDDM, login to Cinnamon: doesn't respond to mouse or keyboard; might be an openGL problem? killed all the processes and got back to SDDM
SDDM, login to Cinnamon (software rendering): ok; logout
SDDM, login to Plasma X11: ok

Something like `grep HELPER /var/log/sddm.log | grep Starting` might be helpful to Steven (OP) to see what exactly SDDM is doing; you might be able to trace what, for instance, is happening when you select Plasma and login (and then get Cinnamon, unexpectedly)