Bug 254464

Summary: emulators/virtualbox-ose-additions version 6.1.18 cannot start Xorg
Product: Ports & Packages Reporter: Emrion <kmachine>
Component: Individual Port(s)Assignee: Virtualbox Team (Nobody) <vbox>
Status: New ---    
Severity: Affects Some People CC: cyclaero, grahamperrin
Priority: --- Flags: bugzilla: maintainer-feedback? (vbox)
Version: Latest   
Hardware: Any   
OS: Any   
Attachments:
Description Flags
Xorg log for VBoxVGA as graphic adapter none

Description Emrion 2021-03-21 14:58:10 UTC
Created attachment 223477 [details]
Xorg log for VBoxVGA as graphic adapter

Hi,

I have a virtualbox VM with FreeBSD 12.2-RELEASE-p4 as guest on a Windows machine (VirtualBox  6.1.18 r142142). After updating to virtualbox-ose-additions-6.1.18 (latest repo, all packages are up to date), I got a blank screen instead of Lxde. I normally use the VBoxVGA as graphic adapter but tried VMSVGA as well (with the proper driver installed): same result.

See the provided log.

Reference: https://forums.freebsd.org/threads/update-to-virtualbox-ose-additions-6-1-18-killed-xorg.79451
Comment 1 cyclaero 2021-03-23 17:36:36 UTC
Initially, I experienced the same problem. and I took also part on said Forums thread (user obsigna).

After some trials & errors, I got it to work. I vaguely remembered that some weeks ago I read somewhere, that it is important to orderly finish the desktop session before deleting the old and installing the new virtualbox-ose-additions. I cannot find this anymore, but I am sure that I did not dream reading it. Anyway this worked out. I started with an almost identical snapshot, which had still the old additions installed. In order to be really on the narrow road of said hint, I did the following:

1. deactivate the vbox entries in /etc/rc.conf
2. restart into the GNOME desktop
3. delete the old additions
4. restart into the GNOME desktop again
5. install the new addions and activate the vbox entries in /etc/rc.conf
6. restart into the GNOME desktop again, now with new additions

Now everything is working fine. Most probably, step 4 was not necessary. But so what, its done and everything is working now.
Comment 2 Emrion 2021-03-24 20:28:29 UTC
This trick doesn't work for me.

Looking at /var/log/messages, I found: "console-kit-daemon[729]: WARNING: Error waiting for native console 9 activation: Inappropriate ioctl for device"

If it can help...
Comment 3 Graham Perrin 2021-04-21 16:41:24 UTC
From <https://forums.freebsd.org/threads/79451/#post-507672>: 

>> … killed Xorg​
> 
> The problem is not so broad.
> 
> Please:
> 
> * what do LXDE and Plasma have in common?
> 
> …

The KDE Quick start at <https://community.kde.org/FreeBSD/Setup#Quick_start> is updated with reference to this bug.
Comment 4 Emrion 2021-06-12 14:16:02 UTC
I just found that the problem is related to full screen mode. If I exit from full screen and reboot, LXDE works.

Then, I can reenter in full screen mode without problems. I can even reboot, it still works (although the resolution is 1920x1020 instead of 1920x1080). But, if I power off the VM and start it, I get again a black screen.
Comment 5 Graham Perrin 2021-06-12 15:38:18 UTC
(In reply to Emrion from comment #4)

> … black screen …

Today's <https://forums.freebsd.org/threads/80860/> is: 

> Spun off from posts by other users under 
> <https://forums.FreeBSD.org/threads/79825/post-512542> 
> (after the original issue was solved).

Emrion, please join me in the new topic. Thanks.