Bug 255211

Summary: www/mitmproxy: Mark broken, fails to build
Product: Ports & Packages Reporter: Daniel Engberg <diizzy>
Component: Individual Port(s)Assignee: freebsd-ports-bugs (Nobody) <ports-bugs>
Status: Closed Overcome By Events    
Severity: Affects Many People CC: danfe, gaod, lwhsu, python, shaun
Priority: --- Flags: bugzilla: maintainer-feedback? (gaod)
koobs: maintainer-feedback? (shaun)
koobs: merge-quarterly?
Version: Latest   
Hardware: Any   
OS: Any   
See Also: https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=250799
Attachments:
Description Flags
Patch for mitmproxy none

Description Daniel Engberg freebsd_committer 2021-04-19 08:07:00 UTC
Created attachment 224241 [details]
Patch for mitmproxy

Fails with "Broken, depends on package: py37-hyperframe>=5.1.0<6 - not found"

Reference:
https://portsfallout.com/fallout?port=www%2Fmitmproxy$
Comment 1 Kubilay Kocak freebsd_committer freebsd_triage 2021-04-19 08:20:24 UTC
shaun@ landed the hyperframe 6.0.0 update in December 2020, submitted by maintainer of this port.
Comment 2 Alexey Dokuchaev freebsd_committer 2021-07-21 09:57:44 UTC
Port had been updated and fixed (independently) in https://cgit.freebsd.org/ports/commit/?id=c7bab0df6c8, closing.