Bug 255649

Summary: gitup: connect_server: socket failure: Address family not supported by protocol family
Product: Ports & Packages Reporter: bagas <bagas1983>
Component: Individual Port(s)Assignee: Nuno Teixeira <eduardo>
Status: Closed FIXED    
Severity: Affects Only Me CC: eduardo, herbert
Priority: ---    
Version: Latest   
Hardware: amd64   
OS: Any   

Description bagas 2021-05-06 07:18:36 UTC
Hello.
My system FreeBSD 11.4-RELEASE-p9 amd64.
gitup-0.91.
An error occurred while updating ports.
Previously, there were no problems with updating ports using gitup.

gitup ports.
gitup: connect_server: socket failure: Address family not supported by protocol family

cat /usr/local/etc/gitup.conf
# $FreeBSD$
#
# Default configuration options for gitup.conf.
{
	"defaults" : {
		"host"           : "git.freebsd.org",
		"port"           : 443,
		"verbosity"      : 1,
		"work_directory" : "/var/db/gitup",
	},

	"ports" : {
		"host"       : "git.freebsd.org",
		"repository" : "/ports.git",
		"branch"     : "main",
		"target"     : "/usr/ports",
		"ignores"    : [
			"distfiles",
			"packages",
			"INDEX-11",
		],
	},
	
	"quarterly" : {
		"repository_path"  : "/ports.git",
		"branch"           : "quarterly",
		"target_directory" : "/usr/ports",
		"ignores"          : [
			"distfiles",
			"packages",
			"INDEX-11",
		],
	},
}

# host git.freebsd.org
git.freebsd.org is an alias for gitmir.geo.freebsd.org.
gitmir.geo.freebsd.org has address 139.178.72.204
gitmir.geo.freebsd.org has IPv6 address 2604:1380:2000:9501::e6a:1
gitmir.geo.freebsd.org mail is handled by 0 .

# telnet 139.178.72.204 443
Trying 139.178.72.204...
Connected to gitmir.pkt.freebsd.org.
Escape character is '^]'.

q
HTTP/1.1 400 Bad Request
Server: nginx/1.18.0
Date: Thu, 06 May 2021 07:14:28 GMT
Content-Type: text/html
Content-Length: 157
Connection: close

<html>
<head><title>400 Bad Request</title></head>
<body>
<center><h1>400 Bad Request</h1></center>
<hr><center>nginx/1.18.0</center>
</body>
</html>
Connection closed by foreign host.


I assume that the problem is in the IPv4 address (139.178.72.204).
IPv6 in my system is completely removed, I do not need IPv6.
I will not build the system with ipv6!
Comment 1 Herbert J. Skuhra 2021-05-06 07:26:35 UTC
Can you try the latest version (0.92) from:

https://github.com/johnmehr/gitup/archive/refs/tags/0.92.tar.gz

The port was updated today.

https://github.com/johnmehr/gitup/issues/65
Comment 2 bagas 2021-05-06 07:30:55 UTC
If you specify the ipv4 address in place of the domain, the ports will be updated.
Strange, then the address selection priority (gitmir.geo) stands firmly ipv6?

/usr/local/etc/gitup.conf
"ports" : {
# "host" : "git.freebsd.org",
"host" : "139.178.72.204",
Comment 3 bagas 2021-05-06 07:56:30 UTC
gitup-0.92
There is no problem.
Updates normally.

/usr/local/etc/gitup.conf                                                                    
# $FreeBSD$
#
# Default configuration options for gitup.conf.
{
        "defaults" : {
                "host"           : "git.freebsd.org",
                "port"           : 443,
                "verbosity"      : 1,
                "work_directory" : "/var/db/gitup",
        },

        "ports" : {
                "host"       : "git.freebsd.org",
                "repository" : "/ports.git",
                "branch"     : "main",
                "target"     : "/usr/ports",
                "ignores"    : [
                        "distfiles",
                        "packages",
                        "INDEX-11",
                ],
        },
        
        "quarterly" : {
                "repository_path"  : "/ports.git",
                "branch"           : "quarterly",
                "target_directory" : "/usr/ports",
                "ignores"          : [
                        "distfiles",
                        "packages",
                        "INDEX-11",
                ],
        },
}
Comment 4 Nuno Teixeira freebsd_committer 2021-05-07 06:53:47 UTC
Hello!

This problem is being discussed in
https://github.com/johnmehr/gitup/issues/65

Thanks