Bug 256282

Summary: emulators/open-vm-tools: Update to 11.3.0 (Adds aarch64 support)
Product: Ports & Packages Reporter: Vincent Milum Jr <freebsd>
Component: Individual Port(s)Assignee: Renato Botelho <garga>
Status: Closed FIXED    
Severity: Affects Some People CC: emaste, jwolfe, mikael
Priority: --- Keywords: needs-patch
Version: LatestFlags: bugzilla: maintainer-feedback? (garga)
koobs: merge-quarterly?
Hardware: Any   
OS: Any   
URL: https://github.com/vmware/open-vm-tools/releases/tag/stable-11.3.0
Bug Depends on: 256183    
Bug Blocks:    
Attachments:
Description Flags
open-vm-tools-11.3.0.diff none

Description Vincent Milum Jr 2021-05-31 06:41:00 UTC
https://github.com/darkain/ports/tree/master/emulators/open-vm-tools

I've updated my personal Ports tree to now be based on the official FreeBSD ports tree, with the additions needed for Aarch64 support. These changes also exist upstream in their devel branch, but no idea when they'll make another reason, so I thought to make those changes available now for FreeBSD Ports.


Files changed:
patch-hgfsclient_hgfsclient.c
patch-lib_hgfsServer_hgfsServerLinux.c
patch-lib_include_sigPosixRegs.h
patch-lib_misc_hostinfoPosix.c
patch-modules_freebsd_vmmemctl_Makefile 
patch-modules_freebsd_vmmemctl_os.c 
patch-vmblockmounter_vmblockmounter.c


This has been tested against FreeBSD 13.0-RELEASE Aarch64 running under VMware ESXi ARM-Fling 1.3 (17839012) on a Raspberry Pi 4 8GB
Comment 1 Vincent Milum Jr 2021-06-19 16:55:54 UTC
open-vm-tools upstream just released 11.3.0 yesterday. Their upstream update contains my patch set for Aarch64 support.

I've now tested open-vm-tools on AMD64 and Aarch64. These compile, install, and run cleanly by bumping the version in the Makefile plus adding Aarch64 to ONLY_FOR_ARCHS
Comment 2 Renato Botelho freebsd_committer 2021-06-22 20:00:53 UTC
*** Bug 256761 has been marked as a duplicate of this bug. ***
Comment 3 Kubilay Kocak freebsd_committer freebsd_triage 2021-08-14 04:24:33 UTC
Note in Changelog:

  A number of issues detected by Coverity, internally or by third parties, have been addressed.
Comment 4 Vincent Milum Jr 2021-08-16 01:25:20 UTC
Created attachment 227239 [details]
open-vm-tools-11.3.0.diff

Update port to open-vm-tools 11.3.0

This removes two patch files as those changes have been applied upstream in 11.3.0

Otherwise, this is just a version bump and adding Aarch64 (officially supported upstream as of 11.3.0)

This compiles and runs cleanly on Aarch64 and AMD64
Comment 5 Mikael Urankar freebsd_committer 2021-08-17 17:03:34 UTC
@garga: do you plan to update the port?
Comment 6 Renato Botelho freebsd_committer 2021-08-17 20:51:32 UTC
(In reply to Mikael Urankar from comment #5)
Yes, I do.  I was waiting for some arm64 test results but they never came so I will go ahead and get it committed tomorrow.
Comment 7 John Wolfe 2021-08-17 21:32:33 UTC
(In reply to Renato Botelho from comment #6)

The unofficial testing by VMware engineers reports that the basic (expected) functionality is working.

ESXi on ARM and ARM Fusion - Establishes a backdoor channel with the host, provides guestInfo (IPs etc).   toolsbox-cmd checks out.
Comment 8 Vincent Milum Jr 2021-08-17 21:46:57 UTC
(In reply to Renato Botelho from comment #6)

Is there a particular test you're waiting on?

I'm the one who wrote the Aarch64 support upstream and specifically targeted FreeBSD first with those changes.

I have screen shots available on Twitter and elsewhere of what ESXi ARM Fling sees with this package running, detecting the guest OS correctly, along with listing guest file systems (all ZFS datasets), and guest networking information.

If there are any more specific testing you'd like done, please feel free to ask, and I'll post the results. :)
Comment 9 John Wolfe 2021-08-17 22:02:41 UTC
(In reply to Vincent Milum Jr from comment #8)

I believe Renato was waiting feedback from VMware QE.

Our desktop testing on ARM is being held up because the mouse is not usable.
Comment 10 Vincent Milum Jr 2021-08-17 22:12:13 UTC
(In reply to John Wolfe from comment #9)

That's a FreeBSD problem, not a VMware problem. FreeBSD on ARM isn't auto-loading the ums driver for some reason. Just add ums_load="YES" into /boot/loader.conf, and mouse should work under ESXi ARM Fling.
Comment 11 commit-hook freebsd_committer 2021-08-18 14:05:33 UTC
A commit in branch main references this bug:

URL: https://cgit.FreeBSD.org/ports/commit/?id=7c87a2355ec82b20c3aa4d7105a6b65435ddea05

commit 7c87a2355ec82b20c3aa4d7105a6b65435ddea05
Author:     Vincent Milum Jr <freebsd@darkain.com>
AuthorDate: 2021-08-18 14:03:23 +0000
Commit:     Renato Botelho <garga@FreeBSD.org>
CommitDate: 2021-08-18 14:04:28 +0000

    emulators/open-vm-tools: Update to 11.3.0

    This version introduces aarch64 support

    PR:             256282
    Sponsored by:   Rubicon Communications, LLC ("Netgate")

 emulators/open-vm-tools/Makefile | 8 ++++----
 emulators/open-vm-tools/distinfo | 6 +++---
 2 files changed, 7 insertions(+), 7 deletions(-)
Comment 12 Vincent Milum Jr 2021-08-18 16:23:03 UTC
(In reply to commit-hook from comment #11)

Is there a particular reason why my patch set that I wrote wasn't used, and instead a new patch was created independently and untested?

That patch now breaks open-vm-tools. I had already done all the work to fix what was broken, make it compile, and test it.

But now it doesn't compile at all.
Comment 13 Renato Botelho freebsd_committer 2021-08-18 18:57:51 UTC
(In reply to Vincent Milum Jr from comment #12)
All tests happened a while ago and I submitted a binary package to John Wolfe to be tested.  In this meantime the commit 42dfc139f65 was applied to fix build with new glib and I didn't notice that so I pushed this change and it broke the build.

I've removed 2 patches that are already applied upstream on 11.3.0 and was able to build it again.

Let me know if you still see problems on current version and I'll take care of it.

Thanks!
Comment 14 Renato Botelho freebsd_committer 2021-08-18 18:59:56 UTC
(In reply to Renato Botelho from comment #13)
an yes, you are right to notice I misused your name as author.  For that, I apoligize.