Bug 256499

Summary: multimedia/plexmediaserver: Update to 1.23.2.4656
Product: Ports & Packages Reporter: Michiel van Baak <michiel>
Component: Individual Port(s)Assignee: Mark Felder <feld>
Status: Closed FIXED    
Severity: Affects Some People Flags: bugzilla: maintainer-feedback? (feld)
Priority: ---    
Version: Latest   
Hardware: Any   
OS: Any   
Attachments:
Description Flags
0001-multimedia-plexmediaserver-Update-to-1.23.2.4656.patch
none
Updated 0001-multimedia-plexmediaserver-Update-to-1.23.2.4656.patch michiel: maintainer-approval?

Description Michiel van Baak 2021-06-09 10:53:00 UTC
Created attachment 225657 [details]
0001-multimedia-plexmediaserver-Update-to-1.23.2.4656.patch

Plex has pulled 1.23.2.4625 since it has a lot of problems in the configuration area of the mediaserver.

See:
- https://forums.plex.tv/t/why-did-plex-downgrade-the-beta-version/720479
- https://forums.plex.tv/t/plex-media-server/30447/435
Comment 1 Michiel van Baak 2021-06-09 22:59:19 UTC
Created attachment 225679 [details]
Updated 0001-multimedia-plexmediaserver-Update-to-1.23.2.4656.patch

re-add LD_LIBRARY_PATH to startup env as plugins and
settings pages dont work without it.
This reverts commits:
- 5ab9d1d779ddb604cc4726f061f6ac94ace2d8aa (multimedia/plexmediaserver)
- 5742f2c5c0eb6c5871f99760fa62d63e061f16c1
  (multimedia/plexmediaserver-plexpass)

For more info about the LD_LIBRARY_PATH issue, see:
- https://forums.plex.tv/t/freenas-freebsd-1-23-0-4438-plugins-failing/712846/10
- https://forums.plex.tv/t/server-settings-are-unavailable-after-update-to-v1-23-1-4571/718302
Comment 2 Mark Felder freebsd_committer 2021-06-10 21:10:08 UTC
(In reply to Michiel van Baak from comment #1)

I'm reaching out to the Plex team to find out what's going on with their build here. They contacted me directly to request I remove LD_LIBRARY_PATH back in November. It seems like they messed up their build process causing this subtle breakage.
Comment 3 Mark Felder freebsd_committer 2021-06-10 21:40:14 UTC
Are you sure the LD_LIBRARY_PATH change fixes it? I can't seem to reproduce that... stays broken here.
Comment 4 Mark Felder freebsd_committer 2021-06-10 22:14:40 UTC
(In reply to Mark Felder from comment #3)

My mistake, error in my testing. That does seem to do the trick.
Comment 5 Michiel van Baak 2021-06-10 22:20:39 UTC
(In reply to Mark Felder from comment #2)

I read the commit message yes. But since more people started complaining about it starting with version 1.23 ... I tested it and it 'fixed' it for me. Hence the inclusion in the patch.

Let's wait what the plex team has to say about it.
Comment 6 Mark Felder freebsd_committer 2021-06-10 22:28:33 UTC
(In reply to Michiel van Baak from comment #5)

I'm waiting on an invite to their internal comms which will speed things up as well. Would like to get some more direct communication and possibly help them to setup their own pkg repo so they can roll out packages directly. This tarball to pkg game is not a good experience for end users, really.
Comment 7 Mark Felder freebsd_committer 2021-06-11 20:11:46 UTC
I've heard nothing back yet and I can't find anything broken right now with the LD_LIBRARY_PATH added back in, so we should ship this now.