Bug 256729

Summary: www/apache24: Segmentation fault when accessing server on recent CURRENT
Product: Ports & Packages Reporter: O. Hartmann <ohartmann>
Component: Individual Port(s)Assignee: freebsd-apache (Nobody) <apache>
Status: New ---    
Severity: Affects Many People Flags: bugzilla: maintainer-feedback? (apache)
Priority: ---    
Version: Latest   
Hardware: Any   
OS: Any   

Description O. Hartmann 2021-06-20 10:11:45 UTC
Running a recent www/apache24 server with either a customised configuration (which triggers the reported Segmentation fault error) or as a vanilla out of the box configuration for checking (which also triggers the same Segmentation fault):

FreeBSD 14.0-CURRENT #13 main-n247423-7bd295750b1: Fri Jun 18 17:32:58 CEST 2021 amd64 (KTLS enabled)

Ports a compiled the traditional way (portmaster -dfR www/apach24 has been performed recently).

Problem: all services, no matter which one the Apache 2.4 server serves the server quits with a Segmentation fault. For instance, webalizer or even the "It works" page delivered shows an initial Segmentation fault in the log, but it gets displayed. More frustrationg is every service with a more complex setup, like a moodle or a nextcloud instance - they do now show up anything. webalizer is offering its content after the second time of access, Firefox first reports failure of a secure connection and then the page shows up.

The log entry looks like this:

[...]
[Sun Jun 20 10:07:00.446324 2021] [core:notice] [pid 99252:tid 34374492160] AH00052: child pid 83799 exit signal Segmentation fault (11)

I suspected php and therefore, I tried to use any vanilla config, but the problem still remains.  This problem doesn't show up on FreeBSD 12.2-RELENG and/or 13-STABLE.