Bug 256815

Summary: panic in pfi_kkif_update() when setting interface name same as group
Product: Base System Reporter: jcaplan
Component: kernAssignee: freebsd-bugs (Nobody) <bugs>
Status: Closed DUPLICATE    
Severity: Affects Only Me    
Priority: ---    
Version: 13.0-STABLE   
Hardware: Any   
OS: Any   

Description jcaplan 2021-06-24 17:50:41 UTC
Overview
--------

pfi_kkif_update() is recursive. It can be made to get stuck in a loop.

Steps to reproduce
------------------

ifconfig vmx1 name testing group testing


Actual Results
--------------

panic

Expected Results
----------------

Don't allow the name and group to be the same and return error


Build Date & Hardware
---------------------

FreeBSD freebsd 13.0-RELEASE FreeBSD 13.0-RELEASE #6 releng/13.0-n244733-ea31abc261f: Sat Jun 19 06:23:53 UTC 2021
Comment 1 jcaplan 2021-06-24 17:56:18 UTC

*** This bug has been marked as a duplicate of bug 218895 ***