Bug 256985

Summary: dbus-1.12.20_3 header files are unusable: missing dbus/dbus-arch-deps.h
Product: Ports & Packages Reporter: Damjan Jovanovic <damjan.jov>
Component: Individual Port(s)Assignee: freebsd-ports-bugs (Nobody) <ports-bugs>
Status: Closed Not A Bug    
Severity: Affects Some People CC: linimon
Priority: ---    
Version: Latest   
Hardware: i386   
OS: Any   

Description Damjan Jovanovic 2021-07-05 03:30:04 UTC
While trying to compile Wine outside Ports in an i386 chroot:

configure:13426: gcc9 -c -I/usr/local/include -I/usr/local/include/dbus-1.0 -I/usr/local/include/gstreamer-1.0 -O0 -g3 -finline-limit=0 -fno-inline -fno-default-inline   conftest.c >&5
In file included from conftest.c:190:
/usr/local/include/dbus-1.0/dbus/dbus.h:29:10: fatal error: dbus/dbus-arch-deps.h: No such file or directory
   29 | #include <dbus/dbus-arch-deps.h>
      |          ^~~~~~~~~~~~~~~~~~~~~~~
compilation terminated.
Comment 1 Mark Linimon freebsd_committer freebsd_triage 2021-07-09 12:04:58 UTC
^Triage: to submitter: tell us exactly which port you are trying to compile, please?
Comment 2 Damjan Jovanovic 2021-07-09 14:30:51 UTC
It's not a port, I am trying to build Wine myself, but anything that tries to include dbus headers will fail.
Comment 3 Damjan Jovanovic 2021-07-09 14:42:11 UTC
My bad. The file is there, just in an unusual path. The reason Wine wasn't finding it is that the "pkgconf" package wasn't installed, so the path to that header wasn't in CFLAGS.