Bug 257280

Summary: net/tightvnc scroll bar scrollers to not respond to click-and-drag
Product: Ports & Packages Reporter: Graham Perrin <grahamperrin>
Component: Individual Port(s)Assignee: Koichiro Iwao <meta>
Status: Closed Not A Bug    
Severity: Affects Only Me CC: grahamperrin
Priority: --- Flags: bugzilla: maintainer-feedback? (meta)
Version: Latest   
Hardware: Any   
OS: Any   
URL: https://forums.freebsd.org/attachments/2021-07-19-15-24-00-png.10674/

Description Graham Perrin 2021-07-19 18:10:05 UTC
With remote control of macOS 10.15.7 (Catalina): it's possible to scroll with a scroll wheel. 

However, as far as I can tell, it's impossible to make traditional (left click-and-drag) use of scrollers. 

Then when (for example) the macOS menu bar is out of sight, it's impossible to scroll up to regain sight. 

% pkg query '%o %v %R' tightvnc
net/tightvnc 1.3.10_6 FreeBSD
% date ; uname -KUv
Mon 19 Jul 2021 19:09:37 BST
FreeBSD 14.0-CURRENT #100 main-n247798-f39dd6a9784: Thu Jul  8 07:38:23 BST 2021     root@mowa219-gjp4-8570p:/usr/obj/usr/src/amd64.amd64/sys/GENERIC-NODEBUG  1400025 1400025
%
Comment 1 Graham Perrin 2021-07-20 01:42:38 UTC
Not a bug? 

<https://forums.FreeBSD.org/threads/81227/post-523464>

> … I believe the scrollbars are standard UNIX/X11 style. 
> So you can click and drag with middle mouse button. …

I had no idea (middle click seems non-standard to me) …
Comment 2 Koichiro Iwao freebsd_committer 2021-07-20 02:04:12 UTC
BTW, if you have no reasons to stick on TightVNC, can you try net/tigervnc-client instead?

It looks not a bug and TightVNC is no longer developed. The last release was more than 10 years ago.
Comment 3 Graham Perrin 2021-07-20 02:21:21 UTC
Thanks, I'll try that.