Bug 258434

Summary: graphics/egl-wayland: 1.1.8 fails to build: ../include/wayland-eglhandle.h:112:9: error: unknown type name 'PFNEGLSTREAMIMAGECONSUMERCONNECTNVPROC'
Product: Ports & Packages Reporter: VVD <vvd>
Component: Individual Port(s)Assignee: Jan Beich <jbeich>
Status: Closed DUPLICATE    
Severity: Affects Some People Flags: jbeich: maintainer-feedback+
Priority: ---    
Version: Latest   
Hardware: amd64   
OS: Any   

Description VVD 2021-09-11 15:26:32 UTC
12.2 amd64.
1.1.8 build error:

[ 52% 11/21] cc -Isrc/libnvidia-egl-wayland.so.1.1.8.p -Isrc -I../src -I../include -I../wayland-egl -Iwayland-eglstream -I/usr/local/include/EGL -I/usr/local/include -I/usr/local/include/libepoll-shim -fno-color-diagnostics -D_FILE_OFFSET_BITS=64 -Wall -Winvalid-pch -std=gnu99 -O3 -Wall -Werror -fvisibility=hidden -DWL_HIDE_DEPRECATED -Wno-pedantic -O2 -pipe -march=core2 -fstack-protector-strong -fno-strict-aliasing -fPIC -pthread -MD -MQ src/libnvidia-egl-wayland.so.1.1.8.p/wayland-thread.c.o -MF src/libnvidia-egl-wayland.so.1.1.8.p/wayland-thread.c.o.d -o src/libnvidia-egl-wayland.so.1.1.8.p/wayland-thread.c.o -c ../src/wayland-thread.c
FAILED: src/libnvidia-egl-wayland.so.1.1.8.p/wayland-thread.c.o
cc -Isrc/libnvidia-egl-wayland.so.1.1.8.p -Isrc -I../src -I../include -I../wayland-egl -Iwayland-eglstream -I/usr/local/include/EGL -I/usr/local/include -I/usr/local/include/libepoll-shim -fno-color-diagnostics -D_FILE_OFFSET_BITS=64 -Wall -Winvalid-pch -std=gnu99 -O3 -Wall -Werror -fvisibility=hidden -DWL_HIDE_DEPRECATED -Wno-pedantic -O2 -pipe -march=core2 -fstack-protector-strong -fno-strict-aliasing -fPIC -pthread -MD -MQ src/libnvidia-egl-wayland.so.1.1.8.p/wayland-thread.c.o -MF src/libnvidia-egl-wayland.so.1.1.8.p/wayland-thread.c.o.d -o src/libnvidia-egl-wayland.so.1.1.8.p/wayland-thread.c.o -c ../src/wayland-thread.c
In file included from ../src/wayland-thread.c:29:
In file included from ../include/wayland-egldisplay.h:31:
../include/wayland-eglhandle.h:112:9: error: unknown type name 'PFNEGLSTREAMIMAGECONSUMERCONNECTNVPROC'
        PFNEGLSTREAMIMAGECONSUMERCONNECTNVPROC      streamImageConsumerConnect;
        ^
../include/wayland-eglhandle.h:113:9: error: unknown type name 'PFNEGLSTREAMACQUIREIMAGENVPROC'
        PFNEGLSTREAMACQUIREIMAGENVPROC              streamAcquireImage;
        ^
../include/wayland-eglhandle.h:114:9: error: unknown type name 'PFNEGLSTREAMRELEASEIMAGENVPROC'; did you mean 'PFNEGLSTREAMFLUSHNVPROC'?
        PFNEGLSTREAMRELEASEIMAGENVPROC              streamReleaseImage;
        ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
        PFNEGLSTREAMFLUSHNVPROC
/usr/local/include/EGL/eglext.h:1207:34: note: 'PFNEGLSTREAMFLUSHNVPROC' declared here
typedef EGLBoolean (EGLAPIENTRYP PFNEGLSTREAMFLUSHNVPROC) (EGLDisplay dpy, EGLStreamKHR stream);
                                 ^
In file included from ../src/wayland-thread.c:29:
In file included from ../include/wayland-egldisplay.h:31:
../include/wayland-eglhandle.h:115:9: error: unknown type name 'PFNEGLQUERYSTREAMCONSUMEREVENTNVPROC'; did you mean 'PFNEGLQUERYSTREAMMETADATANVPROC'?
        PFNEGLQUERYSTREAMCONSUMEREVENTNVPROC        queryStreamConsumerEvent;
        ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
        PFNEGLQUERYSTREAMMETADATANVPROC
/usr/local/include/EGL/eglext.h:1237:34: note: 'PFNEGLQUERYSTREAMMETADATANVPROC' declared here
typedef EGLBoolean (EGLAPIENTRYP PFNEGLQUERYSTREAMMETADATANVPROC) (EGLDisplay dpy, EGLStreamKHR stream, EGLenum name, EGLint n, EGLint offset, EGLint size, void *data);
                                 ^
4 errors generated.
ninja: build stopped: subcommand failed.
*** Error code 1


Tried to remove version 1.1.7 - same build error.
Comment 1 Jan Beich freebsd_committer 2021-09-11 17:21:23 UTC
(In reply to VVD from comment #0)
> error: unknown type name 'PFNEGLSTREAMIMAGECONSUMERCONNECTNVPROC'

Requires libglvnd >= 1.3.4 i.e.,
https://github.com/NVIDIA/egl-wayland/commit/20fe75281fab depends on https://github.com/KhronosGroup/EGL-Registry/commit/8871e77a0f3c added by https://gitlab.freedesktop.org/glvnd/libglvnd/-/commit/418cbb6be33b

*** This bug has been marked as a duplicate of bug 258269 ***