Bug 258723

Summary: x11-wm/qtile black screen
Product: Ports & Packages Reporter: b1ru
Component: Individual Port(s)Assignee: Eric Turgeon <ericbsd>
Status: Open ---    
Severity: Affects Only Me Flags: bugzilla: maintainer-feedback? (ericbsd)
Priority: ---    
Version: Latest   
Hardware: amd64   
OS: Any   

Description b1ru 2021-09-25 18:36:20 UTC
I get a black screen when I try to use qtile.
No cursor and no default bindings working.

My .xinitrc is like this:

    exec qtile start

I also tried this, this did not work either:

    exec qtile 

The weird thing is when I tried this, it actually worked!

   qtile start&
   exec xterm

Of course, this isn't an ideal solution because If I close xterm, X closes too.

My FreeBSD version is:  13.0-RELEASE

No errors are generated in ~/.local/share/qtile/qtile.log when I try to start qtile with "exec qtile start" in my .xinitrc.

I used the default make configuration of the port and its dependencies.

Any help appreciated :)
Comment 1 b1ru 2021-09-25 19:08:50 UTC
Qtile version: 0.18.1
Also tried with version 0.17 (used pkg)
Comment 2 Eric Turgeon freebsd_committer 2021-09-29 14:33:15 UTC
Starting it with lightdm works for me.