Bug 259976

Summary: emulators/wine-devel: Regression from i386-wine-devel
Product: Ports & Packages Reporter: Dwayne MacKinnon <dmk>
Component: Individual Port(s)Assignee: freebsd-ports-bugs (Nobody) <ports-bugs>
Status: Closed Overcome By Events    
Severity: Affects Only Me CC: Alexander88207, damjan.jov, gerald, grahamperrin, iwtcex
Priority: --- Flags: bugzilla: maintainer-feedback? (damjan.jov)
Version: Latest   
Hardware: Any   
OS: Any   
Attachments:
Description Flags
Error output from wine none

Description Dwayne MacKinnon 2021-11-21 19:17:39 UTC
Created attachment 229643 [details]
Error output from wine

I am on FreeBSD-13.0-RELEASE-p4, running wine-devel-6.21_1,1 . I run Kobo's desktop software under wine. (https://www.kobo.com/us/en/p/desktop)

The software works fine under i386-wine-devel (I kept a package of it for safety's sake after the recent ports removal.) When I try it under wine-devel (with 32 bit wine-devel & mesa-dri installed in ~/.i386-wine-pkg as directed) I get a bunch of error messages. The relevant one appears to be this:

wineserver: file_set_error() can't map error: Cannot allocate memory
Comment 1 Alexander Vereeken 2021-11-24 15:08:42 UTC
Please be aware that wine-devel is not always guaranteed to run well here, the old i386 wine-devel version you still have is much older than the current one so its could be a regression for example.

Unfortunately I couldn't test it myself because the latest wine-devel version on i386 failed to build.

I was successful in getting the program to run without tweaks with emulators/wine.
Comment 2 Alex S 2021-11-25 14:45:58 UTC
Does `env WINE_NO_WOW64=1 ...` help?
Comment 3 Gerald Pfeifer freebsd_committer 2021-12-08 16:11:17 UTC
(In reply to Alexander Vereeken from comment #1)
> Unfortunately I couldn't test it myself because the latest
> wine-devel version on i386 failed to build.

I hope the update I pushed two days ago resolves the build issue on
i386, Alexander?
Comment 4 Gerald Pfeifer freebsd_committer 2021-12-13 14:05:38 UTC
Based on

(Alexander Vereeken from comment #1)
> Please be aware that wine-devel is not always guaranteed to run well
> here, the old i386 wine-devel version you still have is much older than
> the current one so its could be a regression for example.

and

(Alex S from comment #2)
> Does `env WINE_NO_WOW64=1 ...` help?

and the fact that i386-wine-devel won't return and things have progressed
quite a bit for wine-devel both in terms of upstream work and the
Wine-on-Wine case I'm closing this report.

If you want to focus on a specific regression or case where FreeBSD fails
and other operating systems (Linux presumably work), let's focus on that
in a specific report (or reopen this one and adjust the summary if that's
about Kobo).
Comment 5 Alexander Vereeken 2021-12-18 14:57:52 UTC
(In reply to Gerald Pfeifer from comment #3)

Hello,

sorry for the late answer.

Yes this issue is fixed, thanks!
Comment 6 Alex S 2021-12-18 15:05:31 UTC
Fixed? In what way?
Comment 7 Alexander Vereeken 2021-12-18 15:22:46 UTC
(In reply to Alex S from comment #6)

with "wine-devel version on i386 failed to build." I mean that it was not present in the i386 repository at that time i wanted to test something with wine-devel.

Now the i386 build is available again so i assume its fixed (when it comes to gerald's question).