Bug 260018

Summary: sysutils/loganalyzer: update options uses
Product: Ports & Packages Reporter: Krzysztof <ports>
Component: Individual Port(s)Assignee: Dirk Meyer <dinoex>
Status: Closed FIXED    
Severity: Affects Some People Keywords: patch, regression
Priority: --- Flags: bugzilla: maintainer-feedback? (dinoex)
Version: Latest   
Hardware: Any   
OS: Any   
Attachments:
Description Flags
loganalyzer patch
none
poudriere testport log none

Description Krzysztof 2021-11-24 14:52:32 UTC
Created attachment 229696 [details]
loganalyzer patch

I've found that sysutils/loganalyzer is using old fashioned style RUN_DEPENDS instead of PHP=<module>. Also there is php5 dependency instead of currect php versions.

I've made a patch which updates port options USES to current dependency checking.

Also I've tested this update with poudriere, so log file is also attached.

I hope this patch will be applied quickly.
Comment 1 Krzysztof 2021-11-24 14:53:17 UTC
Created attachment 229697 [details]
poudriere testport log

poudriere testport log attached
Comment 2 Dirk Meyer freebsd_committer 2021-11-24 15:41:35 UTC
Thanks for reporting. Testing in progress.
Comment 3 commit-hook freebsd_committer 2021-11-24 17:55:43 UTC
A commit in branch main references this bug:

URL: https://cgit.FreeBSD.org/ports/commit/?id=fb9a6a45cdf17398794e26f602b7fcb497500bd9

commit fb9a6a45cdf17398794e26f602b7fcb497500bd9
Author:     Dirk Meyer <dinoex@FreeBSD.org>
AuthorDate: 2021-11-24 17:53:37 +0000
Commit:     Dirk Meyer <dinoex@FreeBSD.org>
CommitDate: 2021-11-24 17:54:28 +0000

    sysutils/loganalyzer: fix php OPTIONS

    PR: 260018
    Submitted by: Krzysztof

 sysutils/loganalyzer/Makefile | 14 +++++++-------
 1 file changed, 7 insertions(+), 7 deletions(-)