Bug 260038

Summary: mail/roundcube: version 1.5.0 not generated min.css files, "include_path" has no path "for program/inclusion"
Product: Ports & Packages Reporter: lexxai <lexxai>
Component: Individual Port(s)Assignee: Alex Dupre <ale>
Status: Closed Works As Intended    
Severity: Affects Only Me CC: brnrd
Priority: --- Flags: bugzilla: maintainer-feedback? (ale)
Version: Latest   
Hardware: Any   
OS: Any   

Description lexxai 2021-11-25 01:43:47 UTC
By announce: 
https://github.com/roundcube/roundcubemail/releases/tag/1.5.0

"In case you're running Roundcube directly from source or if you're not using the complete package, you need to install 3rd party javascript modules using the bin/install-jsdeps.sh script. In the 1.5.x series the toolchain required to build a functional package has changed a bit:

    bin/jsshrink.sh: replaced google-closure-compiler with UglifyJS
    bin/cssshrink.sh: replaced yuicompressor with csso
    Elastic theme: require lessc >= 2.5.2 (and add support for v4) with less-plugin-clean-css

This release is considered stable and we encourage you to update your productive installations after carefully testing the upgrade scenario."

As a result of the current installation of the port in the package mail/roundcube-php74-1.5.0_1,1
the content of the e-mail is not displayed when you click on the list of emails.

As a result, some min.css files were not created because the "csso" package was skipped and env "include_path" has no path "for program/inclusion".

So for a quick solution I configure php-fpm.conf:
php_value[include_path] = ":/usr/local/www/roundcube/program/include"

And copy missed files min.css from .css.
Comment 1 Bernard Spil freebsd_committer 2021-12-31 09:58:44 UTC
Hi lexxai,

Is this still an issue with the port? Sounds like you were trying to run roundcube from source, not from FreeBSD package.
Comment 2 Alex Dupre freebsd_committer 2022-01-14 11:01:21 UTC
The port is based on the "complete" package, so there is no need to build anything. If you are having issues it means your installation is screwed in some way.