Bug 41810

Summary: /usr/ports/german/openoffice: configure on mozilla subprojekt fails
Product: Ports & Packages Reporter: Danijel Tasov <danielt>
Component: Individual Port(s)Assignee: freebsd-openoffice (Nobody) <openoffice>
Status: Closed FIXED    
Severity: Affects Only Me    
Priority: Normal    
Version: Latest   
Hardware: Any   
OS: Any   

Description Danijel Tasov 2002-08-20 09:30:02 UTC
configure skript of the mozilla sub projekt fails:

===>  Building for de-openoffice-1.0.1_3
===>  Extracting mozilla sub project
===>  Building mozilla sub project
===>  Configuring for mozilla-1.0_2,1
Adding configure options from /home/danielt/.mozconfig:
  --enable-toolkit-qt
  --disable-mailnews
  --disable-ldap
  --disable-jsd
  --enable-plaintext-editor-only
  --disable-installer
  --enable-boehm
  --prefix=/home/danielt/src/mozilla/built
loading cache ./config.cache
checking host system type... i386-portbld-freebsd4.6.2
[...]
checking for png_get_valid in -lpng... yes
checking for mng_initialize in -lmng... yes
checking for gtk-config... /usr/X11R6/bin/gtk12-config
checking for GTK - version >= 1.2.0... yes
checking for moc... moc
checking Qt - version >= 2.2.0... no
configure: error: Qt Mozilla requires at least version 2.2.0 of Qt
===>  Script "configure" failed unexpectedly.
      Please report the problem to gnome@FreeBSD.org [maintainer] and attach
      the
      "/home/portswork/home/portswork/home/ports/german/openoffice/work/mozilla/work/mozilla/config.log"
      including the output of the failure of your make command. Also, it might
      be a good idea to provide an overview of all packages installed on your
      system (e.g. an `ls /var/db/pkg`).
*** Error code 1

Stop in /home/portswork/home/ports/german/openoffice/work/mozilla.
*** Error code 1

Stop in /home/ports/german/openoffice.
*** Error code 1

Stop in /home/ports/german/openoffice.
*** Error code 1

Stop in /home/ports/german/openoffice.
zsh: exit 1     SU make
zsh: exit 1

Last view lines of
/home/portswork/home/portswork/home/ports/german/openoffice/work/mozilla/work/mozilla/config.log

configure:9338: gcc31 -o conftest -I/usr/local/include  -O -pipe -march=pentium -fshort-wchar   -I/usr/X11R6/include  -I/usr/X11R6/include -L/usr/local/lib  -lz  conftest.c -lmng  -lm  1>&5
cc1: warning: changing search order for system directory "/usr/local/include"
cc1: warning:   as it has already been specified as a non-system directory
configure:9380: gcc31 -o conftest -I/usr/local/include  -O -pipe -march=pentium -fshort-wchar   -I/usr/X11R6/include  -I/usr/X11R6/include -L/usr/local/lib  -lz  conftest.c -lmng  -lm  1>&5
cc1: warning: changing search order for system directory "/usr/local/include"
cc1: warning:   as it has already been specified as a non-system directory
configure: failed program was:
#line 9366 "configure"
#include "confdefs.h"
#include <stdio.h>
	#include <sys/types.h>
	#include <libmng.h>
	int main () {
	    #if (((MNG_VERSION_MAJOR)<<16)|((MNG_VERSION_MINOR)<<8)|(MNG_VERSION_RELEASE)) >= ((1<<16)|(0<<8)|(4))
		exit(0);
	    #else
		exit(1);
	    #endif
	}
	
configure:9597: checking for gtk-config
configure:9632: checking for GTK - version >= 1.2.0
configure:9733: gcc31 -o conftest -O -pipe -march=pentium -fshort-wchar -I/usr/X11R6/include/gtk12 -I/usr/local/include/glib12 -I/usr/local/include -I/usr/X11R6/include   -I/usr/X11R6/include  -I/usr/X11R6/include  conftest.c -lm  -L/usr/X11R6/lib -L/usr/X11R6/lib -lgtk12 -lgdk12 -L/usr/local/lib -Wl,-E -lgmodule12 -lglib12 -lintl -lXext -lX11 -lm 1>&5
cc1: warning: changing search order for system directory "/usr/local/include"
cc1: warning:   as it has already been specified as a non-system directory
/usr/libexec/elf/ld: warning: libintl.so.2, needed by /usr/X11R6/lib/libgtk12.so, may conflict with libintl.so.4
configure:10015: checking for moc
configure:10101: checking Qt - version >= 2.2.0
configure:10114: g++31 -c  -O -pipe -march=pentium -fshort-wchar -I/usr/include/X11/qt -DQT_GENUINE_STR   -I/usr/X11R6/include  -I/usr/X11R6/include conftest.C 1>&5
configure:10104:21: qglobal.h: No such file or directory
[
  qglobal.h is located in /usr/X11R6/include/qt2/qglobal.
  but there is no -I/usr/X11R6/include/qt2 resp. no #include <qt2/qglobal.h>
]
configure:10108:14: #error "QT_VERSION too old"
configure: failed program was:
#line 10103 "configure"
#include "confdefs.h"
#include <qglobal.h>
int main() {

        #if (QT_VERSION < 220)
            #error  "QT_VERSION too old"
        #endif
    
; return 0; }

Fix: 

I don't have a patch, but see description.
How-To-Repeat: 	cd /usr/ports/german/openoffice; make
Comment 1 Mario Sergio Fujikawa Ferreira freebsd_committer 2002-08-20 13:38:35 UTC
Responsible Changed
From-To: freebsd-ports->openoffice

Over to maintainer(s)
Comment 2 Martin Blapp freebsd_committer 2002-08-21 11:52:58 UTC
State Changed
From-To: open->closed

Please read your log carefully and then you'll 
see these lines: 

Adding configure options from /home/danielt/.mozconfig: 
--enable-toolkit-qt 

Which means that you just have to delete this file to 
make it working again. Don't enable qt if you don't have 
it installed.