Bug 55483

Summary: database/p5-DBD-Pg 1.22_1 warnings
Product: Ports & Packages Reporter: Bryan Fullerton <bryanf>
Component: Individual Port(s)Assignee: Max Khon <fjoe>
Status: Closed FIXED    
Severity: Affects Only Me    
Priority: Normal    
Version: Latest   
Hardware: Any   
OS: Any   

Description Bryan Fullerton 2003-08-12 04:10:11 UTC
After upgrading to databases/p5-DBD-Pg 1.22_1 from 1.22, I see many
warnings from perl scripts using perl -w, ie:

\1 better written as $1 at /usr/local/lib/perl5/site_perl/5.6.1/mach/DBD/Pg.pm line 73.
\1 better written as $1 at /usr/local/lib/perl5/site_perl/5.6.1/mach/DBD/Pg.pm line 203.                      
\1 better written as $1 at /usr/local/lib/perl5/site_perl/5.6.1/mach/DBD/Pg.pm line 262.
\1 better written as $1 at /usr/local/lib/perl5/site_perl/5.6.1/mach/DBD/Pg.pm line 604.                      
\1 better written as $1 at /usr/local/lib/perl5/site_perl/5.6.1/mach/DBD/Pg.pm line 809.                      
\1 better written as $1 at /usr/local/lib/perl5/site_perl/5.6.1/mach/DBD/Pg.pm line 915.

How-To-Repeat: Upgrade port. Run with perl -w. See warnings.
Comment 1 Sergey A. Osokin freebsd_committer 2003-08-12 12:02:56 UTC
Responsible Changed
From-To: freebsd-ports-bugs->fjoe

Over to maintainer.
Comment 2 Max Khon freebsd_committer 2003-08-12 13:37:27 UTC
State Changed
From-To: open->closed

Patch for Pg.pm updated to silence warnings.