Bug 61760

Summary: OpenOffice-1.1 still stalls in install on RELENG_4
Product: Ports & Packages Reporter: areilly
Component: Individual Port(s)Assignee: freebsd-openoffice (Nobody) <openoffice>
Status: Closed FIXED    
Severity: Affects Only Me    
Priority: Normal    
Version: Latest   
Hardware: Any   
OS: Any   
Attachments:
Description Flags
oo_inst_fail.gif none

Description areilly 2004-01-23 02:40:00 UTC
After a couple of days' building, including a seemingly
successful build of the java jdk-1.4.2, the OpenOffice-1.1 port
seems to have frozen in the installation phase again.  This is
what happened when I tried to install it about six months ago
too, but I'd hoped that increased stability of Java and other
system pieces might have sorted whatever the problem was out.
I'm running 4.9-STABLE (actually RELENG_4) of about Sat Jan 17
vintage, on a P-III/500.
                                                                                
The last few lines of the build, say:
                                                                                
zip -j -5 "../unxfbsd.pro/01/normal/f_0408"
+"/usr/ports/editors/openoffice-1.1/work/oo_1.1_src/solver/645/unxfbsd.pro/bin/p+ython.sh"
  adding: python.sh (deflated 60%)
zip -j -5 "../unxfbsd.pro/01/normal/f_0409"
+"/usr/ports/editors/openoffice-1.1/work/oo_1.1_src/solver/645/unxfbsd.pro/lib/l+ibpython.so.2.2.2"
  adding: libpython.so.2.2.2 (deflated 71%)
zip -j -5 "../unxfbsd.pro/01/normal/f_0410"
+"/usr/ports/editors/openoffice-1.1/work/oo_1.1_src/solver/645/unxfbsd.pro/bin/f+romtemplate"
  adding: fromtemplate (deflated 15%)
zip -j -5 "../unxfbsd.pro/01/normal/f_0417"
+"/usr/ports/editors/openoffice-1.1/work/oo_1.1_src/solver/645/unxfbsd.pro/bin/g+nomeint"
  adding: gnomeint (deflated 63%)
zip -j -5 "../unxfbsd.pro/01/normal/f_0419"
+"/usr/ports/editors/openoffice-1.1/work/oo_1.1_src/solver/645/unxfbsd.pro/bin/d+tint"
  adding: dtint (deflated 69%)
zip -j -5 "../unxfbsd.pro/01/normal/f_0420"
+"/usr/ports/editors/openoffice-1.1/work/oo_1.1_src/solver/645/unxfbsd.pro/bin/d+tappintegrate"
  adding: dtappintegrate (deflated 80%)
optimize summary: 0 kb
Replacing ${EVAL} with
Replacing ${LONG_PRODUCTEXTENSION} with
Replacing ${PRODUCTEXTENSION} with
Replacing ${PRODUCTNAME} with OpenOffice.org
Replacing ${PRODUCTVERSION} with 1.1.0
                                                                                
time needed: 0:2:23
                                                                                
                                                                                
WARNING! Project(s):
gtk
                                                                                
not found and couldn't be built. Correct build.lsts.
                                                                                
-------------
===>  Installing for openoffice-1.1.0_1
===>   openoffice-1.1.0_1 depends on executable: pkg-config - found
===>   Generating temporary packing list
===>  Checking if editors/openoffice-1.1 already installed
                                                                                
Initializing installation program....................
                                                                                
                                                                                
                                                                                
.
.
.
and that's all it says.
It's been spinning in setup.bin for hours.

I've just pointed gdb521 at the process, and discovered that
it is hung in symlook_obj() of /usr/libexec/ld-elf.so.1, which
seems to be repeatedly calling sigprocmask() for ever, and not
liking what it finds.  The output of "where" is:

[Switching to Process 49402, Thread 1]
0x28080eb4 in sigprocmask () from /usr/libexec/ld-elf.so.1
(gdb) where
#0  0x28080eb4 in sigprocmask () from /usr/libexec/ld-elf.so.1
#1  0x2807f7d1 in symlook_obj () from /usr/libexec/ld-elf.so.1
#2  0x2807e332 in dlopen () from /usr/libexec/ld-elf.so.1
#3  0x28c7baa6 in osl_psz_loadModule ()
   from /usr/ports/editors/openoffice-1.1/work/sv001.tmp/libsal.so.3
#4  0x28c7ba3f in osl_loadModule ()
   from /usr/ports/editors/openoffice-1.1/work/sv001.tmp/libsal.so.3
#5  0x2dbec273 in com::sun::star::i18n::LocaleData::getFunctionSymbolByName(rtl::OUString const&, char const*) ()
   from /usr/ports/editors/openoffice-1.1/work/sv001.tmp/libi18npool645fi.so
#6  0x2dbebc8b in com::sun::star::i18n::LocaleData::getFunctionSymbol(com::sun::star::lang::Locale const&, char const*) ()
   from /usr/ports/editors/openoffice-1.1/work/sv001.tmp/libi18npool645fi.so
#7  0x2dbe3df5 in com::sun::star::i18n::LocaleData::getLocaleItem(com::sun::star::lang::Locale const&) ()
   from /usr/ports/editors/openoffice-1.1/work/sv001.tmp/libi18npool645fi.so
#8  0x28c0ecae in LocaleDataWrapper::getLocaleItem() const ()
   from /usr/ports/editors/openoffice-1.1/work/sv001.tmp/libutl645fi.so
#9  0x28c0fe25 in LocaleDataWrapper::getOneLocaleItemImpl(short) ()
   from /usr/ports/editors/openoffice-1.1/work/sv001.tmp/libutl645fi.so
#10 0x28c0fdaa in LocaleDataWrapper::getOneLocaleItem(short) const ()
   from /usr/ports/editors/openoffice-1.1/work/sv001.tmp/libutl645fi.so
#11 0x2844ea43 in ImpGetIntntlSep(unsigned short&, unsigned short&) ()
   from /usr/ports/editors/openoffice-1.1/work/sv001.tmp/libsvt645fi.so
#12 0x2844f594 in ImpCvtNum(double, short, String&, unsigned char) ()
   from /usr/ports/editors/openoffice-1.1/work/sv001.tmp/libsvt645fi.so
#13 0x28444d8b in ImpPutInteger(SbxValues*, short) ()
   from /usr/ports/editors/openoffice-1.1/work/sv001.tmp/libsvt645fi.so
#14 0x2844a448 in ImpGetString(SbxValues const*) ()
   from /usr/ports/editors/openoffice-1.1/work/sv001.tmp/libsvt645fi.so
#15 0x28437c79 in SbxValue::Get(SbxValues&) const ()
   from /usr/ports/editors/openoffice-1.1/work/sv001.tmp/libsvt645fi.so
#16 0x28439119 in SbxValue::Compute(SbxOperator, SbxValue const&) ()
   from /usr/ports/editors/openoffice-1.1/work/sv001.tmp/libsvt645fi.so
#17 0x2811ea6a in SbiRuntime::StepArith(SbxOperator) ()
   from /usr/ports/editors/openoffice-1.1/work/sv001.tmp/libsb645fi.so
#18 0x2811ee2b in SbiRuntime::StepCAT() ()
   from /usr/ports/editors/openoffice-1.1/work/sv001.tmp/libsb645fi.so
#19 0x2811dbb9 in SbiRuntime::Step() ()
   from /usr/ports/editors/openoffice-1.1/work/sv001.tmp/libsb645fi.so
#20 0x280ef0a4 in SbModule::Run(SbMethod*) ()
   from /usr/ports/editors/openoffice-1.1/work/sv001.tmp/libsb645fi.so
#21 0x280ee81b in SbModule::Notify(SfxBroadcaster&, SfxHint const&) ()
   from /usr/ports/editors/openoffice-1.1/work/sv001.tmp/libsb645fi.so
#22 0x28b9762e in SfxBroadcaster::Broadcast(SfxHint const&) ()
   from /usr/ports/editors/openoffice-1.1/work/sv001.tmp/libsvl645fi.so
#23 0x280f268c in SbMethod::Broadcast(unsigned long) ()
   from /usr/ports/editors/openoffice-1.1/work/sv001.tmp/libsb645fi.so
#24 0x2843ffab in SbxObject::Call(String const&, SbxArray*) ()
   from /usr/ports/editors/openoffice-1.1/work/sv001.tmp/libsvt645fi.so
#25 0x280ebac1 in StarBASIC::Call(String const&, SbxArray*) ()
   from /usr/ports/editors/openoffice-1.1/work/sv001.tmp/libsb645fi.so
#26 0x28edd610 in SiBasic::Call(ByteString const&, ByteString const&) ()
   from /usr/ports/editors/openoffice-1.1/work/sv001.tmp/libset645fi.so
#27 0x28eaaf50 in SiRunProcedureAction::Execute(SiEnvironment&) ()

and on and on, 

I just killed the process, and the resulting error was ignored,
and the port registration continued.

Of course, the result doesn't work: when I run openoffice-1.1
as myself, from my home directory, I get a dialog box
(image attached) complaining that it could not complete the
installation.

Fix: Dunno.  Looks like something tricky involving threads and signal masks.
How-To-Repeat: 
        cd /usr/ports/editors/openoffice-1.1
        sudo make install
Comment 1 Kirill Ponomarev freebsd_committer 2004-01-23 08:34:14 UTC
Responsible Changed
From-To: freebsd-ports-bugs->openoffice

Over to maintainers.
Comment 2 Lev A. Serebryakov freebsd_committer 2004-01-23 17:44:11 UTC
Hello, freebsd-gnats-submit! How are you?

  Confirm for 4.9-RELEASE (clean release with custom kernel). UP
  system. jdk-1.4.2p6_1.

  Exactly same behavior: build without problems, HDD rush for about 5
  minutes for `make install', and freeze. setup.bin eats CPU as fast
  as possible, no disk activities... It is in case of Xvfb server
  (make install was run from console without real X).

  BUT!
  
  When I kill process (^C to break whole installation), run X (real X,
  with display, etc -- really, KDE session) and repeat `make install'
  it finished in about 10 minutes without problem & OpenOffice started
  without problems!

  So, it is Xvfb<->setup.bin interaction problem!

--
               Lev Serebryakov
Comment 3 areilly 2004-01-27 23:00:16 UTC
Hi all,

Well, that's weird.  Just re-trying the installation, at the several
stages where it stopped, seems to have brought me to the state of having
a working OOo-1.1.0.1:

removing the .installed-foo file from the work directory, and
pkg_deleting the failed install allowed me to re-do the make install
operation, and that ran to completion.

So then I ran the workstation install as myself, and that hung after a
while, so I killed that too.  However it seemed to have put a lot of
files in ~/OpenOffice.org1.1.0, and the setup.log file therein didn't
actually mention any errors, so I've just tried again (by running
~/OpenOffice.org1.1.0/setup), and that all seems to have worked.  Well,
it's running now...

Not particularly confidence-inspiring, but if it works, it'll do.

Cheers,

On Fri, 2004-01-23 at 13:40, FreeBSD-gnats-submit@FreeBSD.org wrote:
> Thank you very much for your problem report.
> It has the internal identification `ports/61760'.
> The individual assigned to look at your
> report is: freebsd-ports-bugs. 
> 
> You can access the state of your problem report at any time
> via this link:
> 
> http://www.freebsd.org/cgi/query-pr.cgi?pr=61760
> 
> >Category:       ports
> >Responsible:    freebsd-ports-bugs
> >Synopsis:       OpenOffice-1.1 still stalls in install on RELENG_4
> >Arrival-Date:   Thu Jan 22 18:40:00 PST 2004
-- 
Andrew Reilly <areilly@bigpond.net.au>
Comment 4 Maho Nakata freebsd_committer 2005-06-19 04:57:08 UTC
State Changed
From-To: open->closed

It seems to be fixed. We don't recieve no such kind of report now 
for both 4,5 branch. 
Thank you very much for your report.