Bug 75473

Summary: graphics/dri: port is broken after update to 6.2_1
Product: Ports & Packages Reporter: Yasuhiro KIMURA <yasu>
Component: Individual Port(s)Assignee: freebsd-x11 (Nobody) <x11>
Status: Closed FIXED    
Severity: Affects Only Me    
Priority: Normal    
Version: Latest   
Hardware: Any   
OS: Any   
Attachments:
Description Flags
dri-make.log none

Description Yasuhiro KIMURA 2004-12-24 19:30:28 UTC
	

	When PORTREVISION was 0 this port worked fine. but it is broken
	after PORTREVISON is bumped. Output log of make is appended.

How-To-Repeat: 	

	Just cd to /usr/ports/graphics/dri and type "make".
Comment 1 Mark Linimon freebsd_committer freebsd_triage 2004-12-24 20:32:25 UTC
Responsible Changed
From-To: freebsd-ports-bugs->freebsd-x11

Over to maintainer(s), although it sounds like this may have already 
been addressed?
Comment 2 Thierry Thomas freebsd_committer 2004-12-26 18:30:52 UTC
State Changed
From-To: open->analyzed


Could you please test the following patch? 
It works for me... 

--- dri.diff begins here --- 
diff -urN graphics/dri.orig/Makefile graphics/dri/Makefile 
--- graphics/dri.orig/Makefile	Sun Dec 26 17:28:19 2004 
+++ graphics/dri/Makefile	Sun Dec 26 18:53:29 2004 
@@ -26,7 +26,7 @@ 
USE_X_PREFIX=	yes 
USE_BZIP2=	yes 
USE_GMAKE=	yes 
-MAKE_ENV+=	FBSDCC="${CC}" FBSDCXX="${CXX}"  
+MAKE_ENV+=	FBSDCC="${CC}" FBSDCXX="${CXX}" PTHREAD_LIBS=${PTHREAD_LIBS}  
FBSDCFLAGS="${CFLAGS}" FBSDCXXFLAGS="${CXXFLAGS}" 

ONLY_FOR_ARCHS=	i386 alpha amd64 
diff -urN graphics/dri.orig/files/patch-freebsd-dri graphics/dri/files/patch-freebsd-dri 
--- graphics/dri.orig/files/patch-freebsd-dri	Fri Dec 24 10:05:40 2004 
+++ graphics/dri/files/patch-freebsd-dri	Sun Dec 26 19:09:08 2004 
@@ -1,5 +1,5 @@ 
---- configs/freebsd-dri.orig	Tue Nov 23 22:59:05 2004 
-+++ configs/freebsd-dri	Fri Dec 24 00:29:13 2004 
+--- ./configs/freebsd-dri.orig	Wed Nov 24 07:59:05 2004 
++++ ./configs/freebsd-dri	Sun Dec 26 19:08:40 2004 
@@ -6,19 +6,22 @@ 
CONFIG_NAME = freebsd-dri 

@@ -25,8 +25,8 @@ 
# Library/program dependencies 
-DRI_LIB_DEPS = -lm -lpthread -lexpat 
-GL_LIB_DEPS = -L/usr/X11R6/lib -lX11 -lXext -lm -pthread 
-+DRI_LIB_DEPS = -L$(LOCALBASE)/lib -lm -lpthread -lexpat 
-+GL_LIB_DEPS = -L$(X11BASE) -lX11 -lXext -lm -pthread 
++DRI_LIB_DEPS = -L$(LOCALBASE)/lib -lm $(PTHREAD_LIBS) -lexpat 
++GL_LIB_DEPS = -L$(X11BASE) -lX11 -lXext -lm $(PTHREAD_LIBS) 

GLUT_LIB_DEPS = -L$(LIB_DIR) -L/usr/X11R6/lib -lGLU -lGL -lX11 -lXmu -lXt -lXi -lm 
GLW_LIB_DEPS = -L$(LIB_DIR) -L/usr/X11R6/lib -lGL -lXt -lXm -lX11 
diff -urN graphics/dri.orig/files/patch-src::mesa::drivers::dri::x11::Makefile graphics/dri/files/patch-src::mesa::drivers::dri::x11::Makefile 
--- graphics/dri.orig/files/patch-src::mesa::drivers::dri::x11::Makefile	Thu Jan  1 01:00:00 1970 
+++ graphics/dri/files/patch-src::mesa::drivers::dri::x11::Makefile	Sun Dec 26 19:11:46 2004 
@@ -0,0 +1,11 @@ 
+--- ./src/mesa/drivers/dri/x11/Makefile.orig	Sat Jun 26 00:51:39 2004 
++++ ./src/mesa/drivers/dri/x11/Makefile	Sun Dec 26 19:10:59 2004 
+@@ -42,7 +42,7 @@ 
+ MESA_MODULES = $(TOP)/src/mesa/mesa.a 
+  
+ # Libraries that the driver shared lib depends on 
+-LIB_DEPS = -lm -lpthread -lc 
++LIB_DEPS = -lm $(PTHREAD_LIBS) -lc 
+ # LIB_DEPS = -lGL -lm -lpthread -lc 
+  
+  
--- dri.diff ends here ---
Comment 3 Hilko Meyer 2004-12-29 01:51:44 UTC
Hi,

I can confirm, that the patch solves the Problem. I can compile
graphics/dri 6.2_1. But I had to apply the patch manual, because it is
somehow shredderd in the PR.

bye,
Hilko
Comment 4 Eric Anholt freebsd_committer 2004-12-29 22:47:03 UTC
State Changed
From-To: analyzed->closed

Should be fixed in CVS.  The dri/x11 bit was unnecessary afaict because we 
don't include that (incomplete) driver.