Bug 100358 - editors/openoffice.org-2: OpenOffice.org 2.0 Requires Conflicting Ports (Bison 1.75 and Bison 2.1)
Summary: editors/openoffice.org-2: OpenOffice.org 2.0 Requires Conflicting Ports (Biso...
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: freebsd-openoffice (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-07-15 23:50 UTC by Billy Barnes
Modified: 2008-02-02 23:08 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Billy Barnes 2006-07-15 23:50:13 UTC
Using portmanager to install OpenOffice 2.0.3:

------------------------------------------------------------------------
 Port Status Report
------------------------------------------------------------------------

00010 have:bison-2.1_2                         /devel/bison2                       CURRENT
00040 ----:bison-1.75_2,1                      /devel/bison                        MISSING

And then:

------------------------------------------------------------------------
checking for conflicts before building bison-1.75_2,1
MGPMrUpdate 0.4.1_6 command: #3 of 14  cd /usr/ports/devel/bison && make check-conflicts
------------------------------------------------------------------------

===>  bison-1.75_2,1 conflicts with installed package(s):
      bison-2.1_2

      They install files into the same place.
      Please remove them first with pkg_delete(1).
*** Error code 1

How-To-Repeat: Run: portmanager editors/OpenOffice.org-2.0
Comment 1 Mark Linimon freebsd_committer freebsd_triage 2006-07-16 06:08:13 UTC
Responsible Changed
From-To: freebsd-bugs->openoffice

Reclassify and assign.
Comment 2 Maho Nakata freebsd_committer 2006-07-18 07:24:46 UTC
State Changed
From-To: open->closed

please remove bison package first and install bison2 
then build openoffice.org
Comment 3 Maho Nakata freebsd_committer 2006-07-18 07:44:29 UTC
State Changed
From-To: closed->open

Hi linimon, assignment of the problem to openoffice is wrong, 
this is an issue of portmanager. Please reassign to appropreate 
cathegory. thanks 


Comment 4 Maho Nakata freebsd_committer 2006-07-18 07:44:29 UTC
Responsible Changed
From-To: openoffice->linimon

Hi linimon, assignment of the problem to openoffice is wrong, 
this is an issue of portmanager. Please reassign to appropreate 
cathegory. thanks
Comment 5 Mark Linimon freebsd_committer freebsd_triage 2006-07-29 00:01:14 UTC
Responsible Changed
From-To: linimon->freebsd-ports-bugs

Apparently this is a bug in sysutils/portmanager.
Comment 6 Michael C.Shultz 2006-11-21 02:45:54 UTC
Somewhere in open office dependencies is both versions of bison, you
all should look at them carefully before blaming portmanager, just my
two cents worth of opinion.  This problem existed when I wrote
portmanager so remember it vaguely.

Likely one of the open office dependencies is looking for one bison and another
dependency is looking for the other version, portmanager is going to
recurse down the list of dependecies and simply update or add what
ever is missing or out of date....

-- 
-Mike
Comment 7 Robert Noland 2006-12-13 03:31:06 UTC
This PR should be closed.  As Michael stated the issue is related to the
depends entries and is not an issue with portmanager.  When a port
defines USE_BISON it gets the port system default which is 1.75.
openoffice.org-2 depends on bison2 which will produce the conflict.

robert.
Comment 8 Gabor Kovesdan freebsd_committer 2006-12-26 17:50:27 UTC
Responsible Changed
From-To: freebsd-ports-bugs->openoffice

Dear Maintainers, 

could you please check if Roberts explanation is still true with the 
current OpenOffice version in the ports tree and if so, work out 
a solution? 

Thanks in advance, 
Gabor Kovesdan
Comment 9 Mark Linimon freebsd_committer freebsd_triage 2007-04-01 12:32:28 UTC
State Changed
From-To: open->feedback

Does this problem still recur with the latest openoffice?
Comment 10 james 2007-06-01 13:37:59 UTC
Hi,

The problem still occurs. I encountered it this morning trying to
build Openoffice 2.2 from /usr/ports/editors/openoffice.org-2.


jm
-- 
James Raftery.
Comment 11 Hans Lambermont 2007-06-02 14:38:17 UTC
Hi all,

A 'portmaster /usr/ports/editors/openoffice.org-2' (portmaster 1.17)
shows the same 'bison-2.3_1/bison-1.75_2,1' problem :

===>  bison-2.3_1 conflicts with installed package(s):
      bison-1.75_2,1
      They install files into the same place.
      Please remove them first with pkg_delete(1).
*** Error code 1

Is there still anything left in the ports tree that can only use bison1
instead of bison2 ? If not we should just change the USE_BISON in
/usr/ports/Mk/bsd.port.mk to bison2 :

    .if defined(USE_BISON)
    BUILD_DEPENDS+= bison:${PORTSDIR}/devel/bison2
    .endif

And perhaps change the remaining ports that require bison1 to use a new
USE_BISON1 ?

regards,
   Hans Lambermont
-- 
http://hans.dse.nl/   () ASCII-ribbon campaign against vCards,
                      /\ HTML-mail and proprietary formats.
Comment 12 dirk.meyer 2007-06-19 12:40:08 UTC
This is caused by implicit dependecies of dependecies got sucked in:
you can test this by:

$ cd /usr/ports/editors/openoffice.org-2 && make make all-depends-list

The output will give both:
/usr/ports/devel/bison2
/usr/ports/devel/bison

Assuming you have the direct dependecies installed:

Workaround:
cat << EOF > /usr/ports/editors/openoffice.org-2/Makefile.local

all-depends-list:
        @${TRUE}

EOF

If you add to /etc/make.conf
DEPENDS_TARGET=package
USE_PACKAGE_DEPENDS=yes

This swill create packages for all depedencies and
you can build openoffice from the dependecies installed as package.
This works, cause lots of build dependecies of your dependecies are not sucked it.


kind regards Dirk

- Dirk Meyer, Im Grund 4, 34317 Habichtswald, Germany
- [dirk.meyer@dinoex.sub.org],[dirk.meyer@guug.de],[dinoex@FreeBSD.org]
http://people.freebsd.org/~dinoex/errorlogs/
Comment 13 Maho Nakata freebsd_committer 2008-02-02 23:06:15 UTC
State Changed
From-To: feedback->closed

Thanks for your report. 
Per http://www.freebsd.org/cgi/query-pr.cgi?pr=117086 ,  
no BISON exist on FreeBSD ports tree; migrated to bison2. 
Therefore we can consider no such problems here. 
also: 
% cd /usr/ports/editors/openoffice.org-2 && make all-depends-list | grep bison 
/usr/ports/devel/bison 

Thanks.