Bug 100741 - [PATCH] databases/p5-DBIx-Class: update to 0.07000
Summary: [PATCH] databases/p5-DBIx-Class: update to 0.07000
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Lars Balker Rasmussen
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-07-23 09:10 UTC by gslin
Modified: 2006-07-23 11:40 UTC (History)
1 user (show)

See Also:


Attachments
p5-DBIx-Class-0.07000.patch (8.99 KB, patch)
2006-07-23 09:10 UTC, gslin
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description gslin 2006-07-23 09:10:14 UTC
- Update to 0.07000
- BUILD_DEPENDS is unnesessary.
- Remove p5-Scalar-List-Utils and p5-Storable because they are already
  in Perl 5.8.x base.

Port maintainer (lbr@FreeBSD.org) is cc'd.

Generated with FreeBSD Port Tools 0.77
Comment 1 Edwin Groothuis freebsd_committer 2006-07-23 09:10:22 UTC
Responsible Changed
From-To: freebsd-ports-bugs->lbr

Over to maintainer
Comment 2 Lars Balker Rasmussen freebsd_committer 2006-07-23 10:40:05 UTC
State Changed
From-To: open->closed

Thanks, commited (with changes/additions). 
Please note that I definitely disagree with your statement 
'BUILD_DEPENDS is unnesessary'.
Comment 3 gslin 2006-07-23 11:37:17 UTC
Hello,

On Sun, Jul 23, 2006 at 09:43:19AM +0000, Lars Balker Rasmussen wrote:
> Synopsis: [PATCH] databases/p5-DBIx-Class: update to 0.07000
> 
> State-Changed-From-To: open->closed
> State-Changed-By: lbr
> State-Changed-When: Sun Jul 23 09:40:05 UTC 2006
> State-Changed-Why: 
> Thanks, commited (with changes/additions).
> Please note that I definitely disagree with your statement
> 'BUILD_DEPENDS is unnesessary'.

Okay, it's maintainer's right :)

Another thing,

http://www.freebsd.org/cgi/cvsweb.cgi/ports/databases/p5-DBIx-Class/Makefile.diff?r1=1.15&r2=1.16&f=h

When you use PERL_MODBUILD=yes, you may not use RUN_DEPENDS=${BUILD_DEPENDS}
because it will cause the package depend unrelated modules like p5-YAML.

A better way is to reverse the order to:

RUN_DEPENDS=	blah1 \
		blah2
BUILD_DEPENDS=	${RUN_DEPENDS}

-- 
* Gea-Suan Lin  (public key: Using https://keyserver.pgp.com/ to search)
* If you cannot convince them, confuse them.           -- Harry S Truman