Bug 100854 - [MAINTAINER] security/libprelude: update to 0.9.10.1
Summary: [MAINTAINER] security/libprelude: update to 0.9.10.1
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Renato Botelho
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-07-26 08:30 UTC by Robin Gruyters
Modified: 2006-07-26 14:01 UTC (History)
0 users

See Also:


Attachments
libprelude-0.9.10.1.patch (1.28 KB, patch)
2006-07-26 08:30 UTC, Robin Gruyters
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Robin Gruyters 2006-07-26 08:30:15 UTC
- Update to 0.9.10.1

Changelog libprelude-0.9.10.1:
- Fix checking for swig/perl/python when full path to the
  application is specified.
- Fix OpenBSD getaddrinfo() AI_ADDRCONFIG issue (apply to
  some other system as well).
- Fix workaround for system with broken libtool,
  that prevented the use of plugin (#168).

Generated with FreeBSD Port Tools 0.77
Comment 1 Renato Botelho freebsd_committer 2006-07-26 12:11:03 UTC
Responsible Changed
From-To: freebsd-ports-bugs->garga

I'll take it.
Comment 2 Renato Botelho freebsd_committer 2006-07-26 13:12:44 UTC
Hello,

It's not building on 4.x:

/bin/sh ../libtool --tag=CC --mode=link cc  -O -pipe  -D_THREAD_SAFE
-pthread -Wall -Wstrict-prototypes -Wmissing-prototypes
-Wmissing-declarations -Wbad-function-cast -Wcast-qual -Wcast-align
-Wnested-externs -Wunused  -D_THREAD_SAFE -pthread -o
prelude-adduser  prelude-adduser.o server.o tls-register.o
../src/libprelude.la
mkdir .libs
cc -O -pipe -D_THREAD_SAFE -pthread -Wall -Wstrict-prototypes
-Wmissing-prototypes -Wmissing-declarations -Wbad-function-cast
-Wcast-qual -Wcast-align -Wnested-externs -Wunused -D_THREAD_SAFE
-pthread -o .libs/prelude-adduser prelude-adduser.o server.o
tls-register.o  ../src/.libs/libprelude.so -L/usr/local/lib
/usr/local/lib/libgnutls.so -lz -lgcrypt
/usr/local/lib/libgpg-error.so /usr/local/lib/libintl.so
/usr/local/lib/libiconv.so -Wl,--rpath -Wl,/usr/local/lib
../src/.libs/libprelude.so: undefined reference to `assert'

Could you provide a fix or let me know if you want to mark it as
BROKEN on 4.x?

Thanks
-- 
Renato Botelho <garga @ FreeBSD.org>
               <freebsd @ galle.com.br>
GnuPG Key: http://www.FreeBSD.org/~garga/pubkey.asc
Comment 3 Renato Botelho freebsd_committer 2006-07-26 13:15:32 UTC
State Changed
From-To: open->feedback

Ask for submitter fix.
Comment 4 Renato Botelho freebsd_committer 2006-07-26 14:01:35 UTC
State Changed
From-To: feedback->closed

Committed. Thanks!