Bug 101420 - acroread7-7.0.8,1 doesn't work with linuxpluginwrapper-20051113_4
Summary: acroread7-7.0.8,1 doesn't work with linuxpluginwrapper-20051113_4
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Norikatsu Shigemura
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-08-05 19:10 UTC by Xiao-Yong Jin
Modified: 2007-04-06 03:15 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Xiao-Yong Jin 2006-08-05 19:10:16 UTC
When it tries to load pdf plugin provided by acroread7-7.0.8,1, firefox (or other equivalent browser) oops with the error

LoadPlugin: failed to initialize shared library /usr/X11R6/Adobe/Acrobat7.0/ENU/Browser/intellinux/nppdf.so [/usr/X11R6/Adobe/Acrobat7.0/ENU/Browser/intellinux/nppdf.so: Undefined symbol "__ctype_b_loc"]

I think it could be caused by the lack of the symbol in the pluginwrapper/acrobat.so provided by linuxpluginwrapper-20051113_4

How-To-Repeat: Install linuxpluginwrapper and acroread7.  Run firefox/mozilla/seamonkey and try to load the pdf plugin.  Simply type about:plugins in the address line should be sufficient.  The pdf plugin doesn't load, but the error comes.
Comment 1 Edwin Groothuis freebsd_committer 2006-08-05 23:13:58 UTC
Responsible Changed
From-To: freebsd-ports-bugs->hrs

Over to maintainer
Comment 2 Hiroki Sato freebsd_committer 2006-08-06 09:43:56 UTC
Responsible Changed
From-To: hrs->nork

This is a problem of linuxpluginwrapper, not Adobe Reader itself.
Comment 3 defan 2006-09-12 13:18:05 UTC
Hi.

I made patch that solves this problem for me
on FreeBSD 6.1-stable. You can download it at
http://defan.zenon.net/freebsd/

As I see, other plugins (flash, etc) seems to
be working too.

--
Andrew N. Below
Zenon N.S.P.
Comment 4 dfilter service freebsd_committer 2006-09-13 17:11:10 UTC
nobutaka    2006-09-13 16:11:03 UTC

  FreeBSD ports repository

  Modified files:
    www/linuxpluginwrapper Makefile distinfo 
  Log:
  Fix breakage of acroread plugin.
  
  PR:             ports/101420
  Submitted by:   Andrew N. Below <defan@zenon.net>
  Approved by:    nork
  
  Revision  Changes    Path
  1.56      +4 -1      ports/www/linuxpluginwrapper/Makefile
  1.25      +3 -0      ports/www/linuxpluginwrapper/distinfo
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"
Comment 5 Stefan Walter freebsd_committer 2007-04-05 17:10:48 UTC
Hi,

it looks like a fix has been committed in September 2006 already. Can this
PR be closed, then?

Regards,
Stefan
Comment 6 Norikatsu Shigemura freebsd_committer 2007-04-06 03:13:57 UTC
State Changed
From-To: open->closed

Confirmed that this issue was fixed and close-requested by submitter.