Bug 103291 - New port: databases/rubygem-sqlite3-ruby - Gem version of ruby-sqlite3
Summary: New port: databases/rubygem-sqlite3-ruby - Gem version of ruby-sqlite3
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Cheng-Lung Sung
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-09-15 04:20 UTC by geraud
Modified: 2007-02-11 19:10 UTC (History)
0 users

See Also:


Attachments
rubygem-sqlite3-ruby.shar (19.71 KB, text/plain)
2006-09-15 04:20 UTC, geraud
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description geraud 2006-09-15 04:20:17 UTC
	Important note :
	This is not a gratuitous addition of a new port. This is the first part of
	a 3-PR fix for www/typo. To make a long story short: www/typo needs an
	extra port in order to be run (will be added later). The problem is that
	this extra port needs the gem version of the sqlite3 binding for ruby.

	As discussed with clsung@ on IRC, the commiter who will handle this PR
	should put databases/ruby-sqlite3 in CONFLICT with this new port.

	Now back to the description,

	sqlite3-ruby provides an interface for the SQLite DB engine version 3.
	This differs from the DBD::SQLite module in that it is more complete,
	and from the ruby DBI version of SQLite in that it is SQLite specific,
	so you can do things that would otherwise be more difficult via DBI.
	If you want portability between backends, use DBI.  If you want ease
	of use with SQLite, use this.
	
	Author:	Jamis Buck (minam) <jgb3@email.byu.edu>
	WWW:	http://sqlite-ruby.rubyforge.org
Comment 1 Cheng-Lung Sung freebsd_committer 2006-09-15 04:26:39 UTC
Responsible Changed
From-To: freebsd-ports-bugs->clsung

I'll take it.
Comment 2 Cheng-Lung Sung freebsd_committer 2007-01-30 02:07:34 UTC
State Changed
From-To: open->repocopy

Request this port rename to databases/rubygem-sqlite3-ruby, since 
ports/103292 depends on a rubygem-ed version of sqlite3-ruby, and 
currently none of ports depend on databases/ruby-sqlite3-ruby. 

== part of log == 
===>  Checking if www/rubygem-rails-app-installer already installed 
/usr/local/bin/gem install --no-ri --install-dir /usr/local/lib/ruby/gems/1.8 /tmp/distfiles/rubygem/rails-app-installer-0.2.0.gem 
ERROR:  Error installing gem /tmp/distfiles/rubygem/rails-app-installer-0.2.0.gem[.gem]: rails-app-installer requires sqlite3-ruby >= 1.1.0  
===>   Registering installation for rubygem-rails-app-installer-0.2.0 
== end == 


Comment 3 Cheng-Lung Sung freebsd_committer 2007-01-30 02:07:34 UTC
Responsible Changed
From-To: clsung->portmgr

Request this port rename to databases/rubygem-sqlite3-ruby, since 
ports/103292 depends on a rubygem-ed version of sqlite3-ruby, and 
currently none of ports depend on databases/ruby-sqlite3-ruby. 

== part of log == 
===>  Checking if www/rubygem-rails-app-installer already installed 
/usr/local/bin/gem install --no-ri --install-dir /usr/local/lib/ruby/gems/1.8 /tmp/distfiles/rubygem/rails-app-installer-0.2.0.gem 
ERROR:  Error installing gem /tmp/distfiles/rubygem/rails-app-installer-0.2.0.gem[.gem]: rails-app-installer requires sqlite3-ruby >= 1.1.0  
===>   Registering installation for rubygem-rails-app-installer-0.2.0 
== end ==
Comment 4 Joe Marcus Clarke freebsd_committer 2007-01-30 20:37:26 UTC
State Changed
From-To: repocopy->feedback

Exactly which port needs to be repocopied?  I do not want to make a mistake. 


Comment 5 Joe Marcus Clarke freebsd_committer 2007-01-30 20:37:26 UTC
Responsible Changed
From-To: portmgr->clsung

Exactly which port needs to be repocopied?  I do not want to make a mistake.
Comment 6 Cheng-Lung Sung freebsd_committer 2007-01-31 01:17:03 UTC
State Changed
From-To: feedback->repocopy

databases/ruby-sqlite3 -> databases/rubygem-sqlite3 


Comment 7 Cheng-Lung Sung freebsd_committer 2007-01-31 01:17:03 UTC
Responsible Changed
From-To: clsung->portmgr

databases/ruby-sqlite3 -> databases/rubygem-sqlite3
Comment 8 Joe Marcus Clarke freebsd_committer 2007-02-04 22:30:01 UTC
State Changed
From-To: repocopy->open

Repocopy completed. 


Comment 9 Joe Marcus Clarke freebsd_committer 2007-02-04 22:30:01 UTC
Responsible Changed
From-To: portmgr->clsung

Repocopy completed.
Comment 10 dfilter service freebsd_committer 2007-02-08 09:54:12 UTC
clsung      2007-02-08 09:53:43 UTC

  FreeBSD ports repository

  Modified files:
    databases/rubygem-sqlite3 Makefile distinfo pkg-plist 
  Log:
  - databases/ruby-sqlite3 -> databases/rubygem-sqlite3
  - Update to 1.2.1
  
  PR:             ports/103291
  Submitted by:   Geraud CONTINSOUZAS <geraud_AT_gcu dot info>
  
  Revision  Changes    Path
  1.11      +6 -20     ports/databases/rubygem-sqlite3/Makefile
  1.8       +3 -3      ports/databases/rubygem-sqlite3/distinfo
  1.7       +300 -115  ports/databases/rubygem-sqlite3/pkg-plist
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"
Comment 11 dfilter service freebsd_committer 2007-02-08 09:59:45 UTC
clsung      2007-02-08 09:58:49 UTC

  FreeBSD ports repository

  Modified files:
    databases            Makefile 
  Removed files:
    databases/ruby-sqlite3 Makefile distinfo pkg-descr pkg-plist 
  Log:
  - ruby-sqlite3 -> rubygem-sqlite3
  
  PR:             ports/103291
  Submitted by:   Geraud CONTINSOUZAS <geraud_AT_gcu dot info>
  
  Revision  Changes    Path
  1.584     +1 -1      ports/databases/Makefile
  1.12      +0 -44     ports/databases/ruby-sqlite3/Makefile (dead)
  1.9       +0 -3      ports/databases/ruby-sqlite3/distinfo (dead)
  1.4       +0 -9      ports/databases/ruby-sqlite3/pkg-descr (dead)
  1.8       +0 -116    ports/databases/ruby-sqlite3/pkg-plist (dead)
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"
Comment 12 Cheng-Lung Sung freebsd_committer 2007-02-08 10:03:18 UTC
State Changed
From-To: open->closed

The port is created from databases/ruby-sqlite3. Thank you.
Comment 13 dfilter service freebsd_committer 2007-02-08 10:04:00 UTC
clsung      2007-02-08 10:03:07 UTC

  FreeBSD ports repository

  Modified files:
    .                    MOVED 
  Log:
  - ruby-sqlite3 -> rubygem-sqlite3
  
  PR:             ports/103291
  Submitted by:   Geraud CONTINSOUZAS <geraud_AT_gcu dot info>
  
  Revision  Changes    Path
  1.1285    +3 -1      ports/MOVED
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"
Comment 14 eric.hall 2007-02-11 18:40:58 UTC
Hello-
	Seems 'databases/rubygem-activerecord' does depend on 'ruby- 
sqlite3' (see databases/rubygem-activerecord/Makefile line 51).   
Discovered by attempting to update the ports index.  I'm re-running  
it now after changing line 51 of said Makefile to change 'ruby- 
sqlite3' to 'rubygem-sqlite3'.... That worked, index built.

		-eric