Bug 105128 - editors/openoffice.org-2-devel build fails
Summary: editors/openoffice.org-2-devel build fails
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: freebsd-openoffice (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-11-04 04:40 UTC by Andrew Reilly
Modified: 2007-04-03 19:21 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andrew Reilly 2006-11-04 04:40:17 UTC
	make -DWITH_CUPS install stops here (pardon the line
	wrapping):
	Making: ../../unxfbsdx.pro/slo/AccessibleControlShape.obj
	g++41 -fmessage-length=0 -c -Os -fno-strict-aliasing
	-fvisibility=hidden -I.
	-I../../unxfbsdx.pro/inc/accessibility -I../inc
	-I../../inc/pch -I../../inc -I../../unx/inc
	-I../../unxfbsdx.pro/inc -I.
	-I/usr/ports/editors/openoffice.org-2.0-devel/work/SRC680_m186/solver/680/unxfbsdx.pro/inc/stl
	-I/usr/ports/editors/openoffice.org-2.0-devel/work/SRC680_m186/solver/680/unxfbsdx.pro/inc/external
	-I/usr/ports/editors/openoffice.org-2.0-devel/work/SRC680_m186/solver/680/unxfbsdx.pro/inc
	-I/usr/ports/editors/openoffice.org-2.0-devel/work/SRC680_m186/solenv/unxfbsdx/inc
	-I/usr/ports/editors/openoffice.org-2.0-devel/work/SRC680_m186/solenv/inc
	-I/usr/ports/editors/openoffice.org-2.0-devel/work/SRC680_m186/res
	-I/usr/ports/editors/openoffice.org-2.0-devel/work/SRC680_m186/solver/680/unxfbsdx.pro/inc/stl
	-I/usr/ports/editors/openoffice.org-2.0-devel/work/SRC680_m186/solenv/inc/Xp31
	-I/usr/local/jdk1.5.0/include
	-I/usr/local/jdk1.5.0/include/freebsd
	-I/usr/local/jdk1.5.0/include/bsd
	-I/usr/local/jdk1.5.0/include/linux
	-I/usr/local/jdk1.5.0/include/native_threads/include
	-I/usr/X11R6/include
	-I/usr/ports/editors/openoffice.org-2.0-devel/work/SRC680_m186/solver/680/unxfbsdx.pro/inc/offuh
	-I. -I../../res -I. -pipe  -fvisibility-inlines-hidden
	-g1 -fexceptions -fno-enforce-eh-specs -Wall -Wextra
	-Wendif-labels -Wshadow -Wno-ctor-dtor-privacy
	-Wno-non-virtual-dtor   -fpic -DFREEBSD -DUNX -DVCL
	-DGCC -DC341 -DX86_64 -DCVER=C341 -DX86_64  -D_PTHREADS
	-D_REENTRANT -DNEW_SOLAR -D_USE_NAMESPACE=1
	-DSTLPORT_VERSION=450 -DHAVE_GCC_VISIBILITY_FEATURE
	-D__DMAKE -DUNIX -DCPPU_ENV=gcc3
	-DGXX_INCLUDE_PATH=/usr/local/lib/gcc-4.1.2/include/c++
	-DSUPD=680 -DPRODUCT -DNDEBUG -DPRODUCT_FULL
	-DOSL_DEBUG_LEVEL=0 -DOPTIMIZE -DEXCEPTIONS_ON -DCUI
	-DSOLAR_JAVA -DSRC680=SRC680   -DSVX_DLLIMPLEMENTATION
	-DSHAREDLIB -D_DLL_  -DMULTITHREAD  -o
	../../unxfbsdx.pro/slo/AccessibleControlShape.o
	/usr/ports/editors/openoffice.org-2.0-devel/work/SRC680_m186/svx/source/accessibility/AccessibleControlShape.cxx 
	../../inc/svdobj.hxx:326: error: invalid pure specifier
	(only `= 0' is allowed) before ';' token
	dmake:  Error code 1, while making
	'../../unxfbsdx.pro/slo/AccessibleControlShape.obj'
	'---* tg_merge.mk *---'

	ERROR: Error 65280 occurred while making
	/usr/ports/editors/openoffice.org-2.0-devel/work/SRC680_m186/svx/source/accessibility
	dmake:  Error code 1, while making
	'build_instsetoo_native'
	'---*  *---'
	*** Error code 255

	Stop in /usr/ports/editors/openoffice.org-2.0-devel.

	My naiive suggestion is that somehow "NULL" is not 0 at
	line 326, where g++41 is whinging.

Fix: 

don't know how to fix, sorry.
	As a work-around, I'm going to try straight 2.0.
How-To-Repeat: 	cd editors/openoffice-2.0-devel
	make -DWITH_CUPS install
Comment 1 Edwin Groothuis freebsd_committer 2006-11-04 06:07:54 UTC
Responsible Changed
From-To: freebsd-ports-bugs->openoffice

Over to maintainer
Comment 2 Andrew Reilly 2006-11-04 07:04:58 UTC
Straight ports/editors/openoffice.org-2.0 fails the same way:

HREAD  -o ../../unxfbsdx.pro/slo/AccessibleControlShape.o /usr/ports/editors/openoffice.org-2.0/work/OOD680_m5/svx/source/accessibility/AccessibleControlShape.cxx 
../../inc/svdobj.hxx:326: error: invalid pure specifier (only `= 0' is allowed) before ';' token
dmake:  Error code 1, while making '../../unxfbsdx.pro/slo/AccessibleControlShape.obj'
'---* tg_merge.mk *---'

ERROR: Error 65280 occurred while making /usr/ports/editors/openoffice.org-2.0/work/OOD680_m5/svx/source/accessibility
dmake:  Error code 1, while making 'build_instsetoo_native'
'---* *---'
*** Error code 255

Stop in /usr/ports/editors/openoffice.org-2.0.


Seems unlikely that I'm the only one uncovering what looks like a
coding bug.  Is there anything about my system (installed port
versions, etc) that might be interesting?  Everything is cvsupped
and portupgrade -arR up-to-date as of yesterday.

Cheers,

-- 
Andrew
Comment 3 Scott Robbins 2006-12-09 23:05:32 UTC
This is fairly common problem.  So far, I've found that building (or
updating) with -DWITHOUT_MOZILLA and making sure that I don't have
/usr/ports/devel/epm installed have always fixed it.   
I don't use epm, however, sometimes it has gotten installed as 
a dependency.  If it is, then I will always get the same
instsettoo_native error that you mention, however if I remove it, and
rebuild, the build completes successfully.

Some googling however, indicates that this fix only works for some
people, not everyone.



-- 

Scott Robbins

PGP keyID EB3467D6
( 1B48 077D 66F6 9DB0 FDC2 A409 FA54 EB34 67D6 )
gpg --keyserver pgp.mit.edu --recv-keys EB3467D6
Comment 4 Mark Linimon freebsd_committer freebsd_triage 2007-04-01 12:28:50 UTC
State Changed
From-To: open->feedback

Does this problem still recur with the latest openoffice?
Comment 5 Mark Linimon freebsd_committer freebsd_triage 2007-04-03 19:21:04 UTC
State Changed
From-To: feedback->closed

Submitter notes that the problem is now fixed.