Bug 105581 - java/eclipse: Proper mozilla support via USE_GECKO
Summary: java/eclipse: Proper mozilla support via USE_GECKO
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Tom McLaughlin
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-11-15 18:50 UTC by Tom McLaughlin
Modified: 2007-01-03 19:12 UTC (History)
1 user (show)

See Also:


Attachments
eclipse-gecko.diff (4.78 KB, patch)
2006-11-15 18:50 UTC, Tom McLaughlin
no flags Details | Diff
eclipse.diff (5.48 KB, patch)
2006-11-27 20:14 UTC, David Sledge
no flags Details | Diff
eclipse.diff (26.24 KB, patch)
2006-11-29 21:51 UTC, David Sledge
no flags Details | Diff
eclipse.diff (34.91 KB, patch)
2006-12-14 23:12 UTC, David Sledge
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Tom McLaughlin freebsd_committer 2006-11-15 18:50:02 UTC

Attached patch properly sets mozilla dependency via USE_GECKO.  It also
corrects some issues which will cause a build to fail if mozilla is not installed.
Currently only firefox and mozilla are listed as supported.  I also corrected the
icon installation.  It will potentially fail because the directory it is installing to may
not exist in some circumstances.

Could someone please test that the build still works when WITHOUT_MOZILLA is
set?  Else I'll do it when I have a clkean jail.  Thanks.
Comment 1 Edwin Groothuis freebsd_committer 2006-11-15 18:50:25 UTC
Responsible Changed
From-To: freebsd-ports-bugs->tmclaugh

Submitter has GNATS access
Comment 2 Edwin Groothuis freebsd_committer 2006-11-15 18:50:32 UTC
State Changed
From-To: open->feedback

Awaiting maintainers feedback
Comment 3 David Sledge 2006-11-22 20:32:47 UTC
I have a few modifications to add/change on this patch. I will upload a 
new diff when I have finished testing it.


Edwin Groothuis wrote:
> Maintainer of java/eclipse,
>
> Please note that PR ports/105581 has just been submitted.
>
> If it contains a patch for an upgrade, an enhancement or a bug fix
> you agree on, reply to this email stating that you approve the patch
> and a committer will take care of it.
>
> The full text of the PR can be found at:
>     http://www.freebsd.org/cgi/query-pr.cgi?pr=ports/105581
>
>
Comment 4 David Sledge 2006-11-27 20:14:01 UTC
Here is the modified eclipse patch. Please commit it when able.
Comment 5 David Sledge 2006-11-29 21:51:07 UTC
Since this patch has not been committed yet I have updated it again. I 
set the default build to use xulrunner instead of mozilla or firefox as 
this version  of the eclipse port will now work with the internal web 
browser when compiling against xulrunner. Please commit this patch file 
instead of the previous patch files uploaded.
Comment 6 Tom McLaughlin freebsd_committer 2006-12-04 03:23:00 UTC
Hi David,

I discussed using xulrunner as the default GECKO with another committer
and we both felt that firefox should remain the default.  The reason is
users will most likely have firefox installed or will want it installed.
Setting the default to xulrunner will make that the dependency required
by the package and in more cases than not bring in an extra package for
users.  We felt that while support xulrunner is good, it shouldn't be
the default used by the package.  With that in mind what do you think?
I'll commit it which ever way you think is best.  I just wanted to bring
this issue up first.  Thanks.

tom
Comment 7 Kurt Miller 2006-12-08 21:25:52 UTC
Does the latest diff work on amd64 too?
Comment 8 David Sledge 2006-12-08 23:36:16 UTC
Tom,
    I choose xulrunner as the default because it is the only one that 
currently works completely. Compiling against firefox will not enable 
the internal browser which affects web development using eclipse and 
also affects plugins for web development like MyEclipse. When I get past 
the amd64 problem with xulrunner I plan to start looking into firefox 
again. If I can get firefox working I would be more than happy with 
setting is as the default, but right now I would assume that it would be 
best to make the default xulrunner since it is currently the only option 
that enables the full use of eclipse.

Kurt,
    Patch-3.diff will not fix the internal browser on amd64, just x86. 
With patch-3.diff applied on amd64 you will have to use "make 
WITHOUT_MOZILLA=yes" and will be forced to use the external browser. I 
have located where the problem is for amd64 in the source code but I am 
not yet sure why it is happening or how to fix it. I am still working on 
it though.
Comment 9 Kurt Miller 2006-12-11 03:47:39 UTC
I'm about to commit a similar update to OpenBSD's eclipse port.
I found the amd64 build problem. It was that the build by default
uses the prebuilt swttools.jar in the distfile so some of the
changes like XPCOM.properties were not effective. You need to
apply this patch too:

http://overlays.gentoo.org/proj/java/browser/other/eclipse-patches/3.2.1/eclipse-sdk-3.2.1-swttools.patch

Also, I'd recommend using NS_InitXPCOM2 instead of NS_InitXPCOM3.
It is the older init function. I'm not sure when NS_InitXPCOM3
was added, but its not included in the old mozilla suite.

Also the linux guys missed patching this file too:

plugins/org.eclipse.swt.tools/JNI Generation/org/eclipse/swt/tools/internal/org.eclipse.swt.internal.mozilla.XPCOM_PROFILE.properties

Hope that helps somewhat.
Comment 10 David Sledge 2006-12-13 23:52:29 UTC
Thanks Kurt for the patch. I added it to the eclipse port and tested it my
amd64 box. Seems to be working ok. I will create a new diff tomorrow and
attach it to this PR. The previous patch files might fail to apply now as a
patch has been committed for the Xbase11 issues. The new patch file I make
tomorrow will take that into account.
Comment 11 David Sledge 2006-12-14 23:12:25 UTC
<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html>
<head>
  <meta content="text/html;charset=ISO-8859-1" http-equiv="Content-Type">
  <title></title>
</head>
<body bgcolor="#ffffff" text="#000000">
<br>
<font size="2">Here is a new patch file that will fix the internal web
browser on amd64 platform when compiling against xulrunner, Thanks
Kurt. Please commit this latest patch "patch-4.diff".<br>
<br>
<br>
</font>
</body>
</html>
Comment 12 dfilter service freebsd_committer 2007-01-03 18:14:05 UTC
tmclaugh    2007-01-03 18:13:55 UTC

  FreeBSD ports repository

  Modified files:
    java/eclipse         Makefile distinfo 
    java/eclipse/files   eclipse.in 
                         post-patch-plugins-swt-gtk-build.sh 
                         post-patch-plugins-swt-gtk-make_freebsd.mak 
    java/eclipse/scripts pre-patch 
  Added files:
    java/eclipse/files   patch-plugins-swt-amd64-build.xml 
                         post-patch-plugins-swt-mozilla-Browser.java 
                         post-patch-plugins-swt-mozilla-XPCOM.java 
                         post-patch-plugins-swt-mozilla-XPCOM.properties 
                         post-patch-plugins-swt-mozilla-XPCOM_PROFILE.properties 
                         post-patch-plugins-swt-mozilla-xpcom.cpp 
                         post-patch-plugins-swt-mozilla-xpcom.h 
                         post-patch-plugins-swt-mozilla-xpcom_profile.h 
                         post-patch-plugins-swt-mozilla-xpcom_stats.cpp 
                         post-patch-plugins-swt-mozilla-xpcom_stats.h 
  Log:
  - Fixes for internal web browser [1]
  - Fixes for internal web browser on amd64 [2]
  - Convert to USE_GECKO [3]
  
  Note: Port defaults to xulrunner as the preffered gecko port because it is
  the only port which allows the internal web browser to work but eclipse will
  build using other gecko ports (ie. firefox, mozilla, seamonkey) though it
  will lack a working internal web browser.  An argument can be made that
  xulrunner should be the only available gecko but maybe 5 people have
  xulrunner installed and it's another 45 minute mozilla dependency on even my
  speedy machine.  The maintainer mentioned working on getting the internal
  web browser to work with firefox so I'm leaving well enough alone.  When
  eclipse fully works with firefox the USE_GECKO ordering should probably be
  revistited.
  
  PR:             105581
  Submitted by:   Maintainer [1], Kurt Miller <lists at intricatesoftware.com> [2], me [3]
  
  Revision  Changes    Path
  1.51      +36 -21    ports/java/eclipse/Makefile
  1.13      +0 -1      ports/java/eclipse/distinfo
  1.9       +3 -2      ports/java/eclipse/files/eclipse.in
  1.1       +45 -0     ports/java/eclipse/files/patch-plugins-swt-amd64-build.xml (new)
  1.2       +3 -3      ports/java/eclipse/files/post-patch-plugins-swt-gtk-build.sh
  1.3       +43 -5     ports/java/eclipse/files/post-patch-plugins-swt-gtk-make_freebsd.mak
  1.1       +186 -0    ports/java/eclipse/files/post-patch-plugins-swt-mozilla-Browser.java (new)
  1.1       +21 -0     ports/java/eclipse/files/post-patch-plugins-swt-mozilla-XPCOM.java (new)
  1.1       +25 -0     ports/java/eclipse/files/post-patch-plugins-swt-mozilla-XPCOM.properties (new)
  1.1       +25 -0     ports/java/eclipse/files/post-patch-plugins-swt-mozilla-XPCOM_PROFILE.properties (new)
  1.1       +143 -0    ports/java/eclipse/files/post-patch-plugins-swt-mozilla-xpcom.cpp (new)
  1.1       +12 -0     ports/java/eclipse/files/post-patch-plugins-swt-mozilla-xpcom.h (new)
  1.1       +11 -0     ports/java/eclipse/files/post-patch-plugins-swt-mozilla-xpcom_profile.h (new)
  1.1       +21 -0     ports/java/eclipse/files/post-patch-plugins-swt-mozilla-xpcom_stats.cpp (new)
  1.1       +13 -0     ports/java/eclipse/files/post-patch-plugins-swt-mozilla-xpcom_stats.h (new)
  1.4       +0 -0      ports/java/eclipse/scripts/pre-patch
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"
Comment 13 Tom McLaughlin freebsd_committer 2007-01-03 19:12:17 UTC
State Changed
From-To: feedback->closed

Thanks guys.  Patches committed.