Bug 105781 - [UPDATE] www/aolserver to 4.5 REVISED
Summary: [UPDATE] www/aolserver to 4.5 REVISED
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Gabor Kovesdan
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-11-23 11:00 UTC by Martin Matuska
Modified: 2007-02-02 15:00 UTC (History)
0 users

See Also:


Attachments
file.shar (80.27 KB, text/plain)
2006-11-23 11:00 UTC, Martin Matuska
no flags Details
file.shar (2.84 KB, text/plain)
2006-11-23 11:00 UTC, Martin Matuska
no flags Details
file.shar (2.86 KB, text/plain)
2006-11-23 11:00 UTC, Martin Matuska
no flags Details
file.shar (2.76 KB, text/plain)
2006-11-23 11:00 UTC, Martin Matuska
no flags Details
file.shar (2.97 KB, text/plain)
2006-11-23 11:00 UTC, Martin Matuska
no flags Details
file.shar (2.93 KB, text/plain)
2006-11-23 11:00 UTC, Martin Matuska
no flags Details
file.shar (2.84 KB, text/plain)
2006-11-23 11:00 UTC, Martin Matuska
no flags Details
file.shar (2.91 KB, text/plain)
2006-11-23 11:00 UTC, Martin Matuska
no flags Details
file.shar (2.98 KB, text/plain)
2006-11-23 11:00 UTC, Martin Matuska
no flags Details
file.shar (3.44 KB, text/plain)
2006-11-23 11:00 UTC, Martin Matuska
no flags Details
file.shar (2.68 KB, text/plain)
2006-11-23 11:00 UTC, Martin Matuska
no flags Details
aolserver.shar (80.43 KB, text/plain)
2006-12-25 13:31 UTC, Martin Matuska
no flags Details
aolserver.diff (106.18 KB, patch)
2006-12-27 11:08 UTC, Martin Matuska
no flags Details | Diff
aolserver.diff (106.00 KB, patch)
2006-12-27 12:40 UTC, Martin Matuska
no flags Details | Diff
aolserver_ports.diff.gz (22.51 KB, application/x-gunzip)
2006-12-29 10:56 UTC, Martin Matuska
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Matuska 2006-11-23 11:00:25 UTC
This is a rewrite of the www/aolserver port, including an update to 4.5
I would like to take over maintainership, if the maintainer agrees.

All modules are now treated as separate ports.

Please see http://www.matuska.org/martin/cgi/cvsweb.cgi/ports for these ports
Or download them in .tar.gz format: http://www.matuska.org/martin/freebsd/ports/aolserverports.tar.gz

This PR supersedes ports/104353
Comment 1 Edwin Groothuis freebsd_committer 2006-11-23 11:00:56 UTC
State Changed
From-To: open->feedback

Awaiting maintainers feedback
Comment 2 Martin Matuska 2006-11-27 09:49:59 UTC
www/aolserver:
TCL_THREADED!= echo 'puts [array names tcl_platform -exact threaded]' |
${TCLSH}
to be replaced with:
TCL_THREADED!= ${ECHO_CMD} 'puts [array names tcl_platform -exact
threaded]' | ${TCLSH}

www/aolserver-nscache:
has wrong CATEGORIES, it should be only:
CATEGORIES=    www
Comment 3 Gabor Kovesdan freebsd_committer 2006-12-08 16:20:34 UTC
State Changed
From-To: feedback->open

Maintainership was already granted for the submitter in 
superseded PR ports/104353. 


Comment 4 Gabor Kovesdan freebsd_committer 2006-12-08 16:20:34 UTC
Responsible Changed
From-To: freebsd-ports-bugs->gabor

Take.
Comment 5 Gabor Kovesdan freebsd_committer 2006-12-23 11:28:46 UTC
Hi Martin,

I started to take a deeper look on these ports today, since they didn't 
compile in tinderbox and I found out that the problem is that 
www/aolserver doesn't install lang/tcl84-thread even if there's no tcl 
port installed. Please look at the output I got:

[gabor@pluto ~/patches/ports/aolserver]$ pkg_info | grep tcl
[gabor@pluto ~/patches/ports/aolserver]$ make
/usr/local/bin/tclsh8.4: not found
"Makefile", line 45: warning: "echo 'puts [array names tcl_platform 
-exact threaded]' | /usr/local/bin/tclsh8.4" returned non-zero status
===>  aolserver-4.5.0 you need Tcl with threads to use this port, please 
install Tcl from lang/tcl84-thread port and try again.
*** Error code 1

Stop in /usr/home/gabor/patches/ports/aolserver.

You should modify the port to install it if no tcl port is installed and 
only give this hint if a wrong tcl port is installed. Otherwise, the 
installation of this port would be very inconvenient and there would be 
problems with the package building as well, so it definitely can't be 
committed in this form.

And please send a unified diff (diff -Nur olddirectory newdirectory) for 
modifications on existing ports to make our work easier. In this form 
it's easier to see what have been changed. Shar archive is ok for the 
other ones.

Thanks for your effort on working on these ports.

Regards,
Gabor Kovesdan
Comment 6 Gabor Kovesdan freebsd_committer 2006-12-23 11:29:28 UTC
State Changed
From-To: open->feedback

Ask for submitter fix.
Comment 7 Martin Matuska 2006-12-25 13:31:12 UTC
I reworked the threads condition + added a mising file in pkg_plist
Comment 8 Gabor Kovesdan freebsd_committer 2006-12-26 16:40:31 UTC
Hello Martin,

the dependency handling is still wrong in www/aolserver, you can find a 
log here:
http://people.freebsd.org/~gabor/logs/aolserver-4.5.0.log

And if you submit a new fix, please don't forget what I asked in my 
previous mail and send just a unified diff against the current version 
of www/aolserver. Dealing with shell archives for existing ports makes 
our work terribly complicated.

Thanks in advance,
Gabor Kovesdan
Comment 9 Martin Matuska 2006-12-27 11:08:26 UTC
I had to remove the USE_TCL knob because bsd.tcl.sk does not understand
threads yet.
https.tcl was removed, too. A diff is included. I hope it goes well this
time.
Comment 10 Gabor Kovesdan freebsd_committer 2006-12-27 11:53:13 UTC
Well, the patch has been corrupted somehow, it's almost good but the 
Makefile part doesn't apply:

|diff -Nbur www/aolserver.orig/Makefile www/aolserver/Makefile
|--- www/aolserver.orig/Makefile  Mon Oct  2 12:08:01 2006
|+++ www/aolserver/Makefile       Wed Dec 27 11:22:28 2006
--------------------------
Patching file Makefile using Plan A...
Hunk #1 failed at 2.
1 out of 1 hunks failed--saving rejects to Makefile.rej
Hmm...  The next patch looks like a unified diff to me...


The other files are patched well. Sometimes patches get corrupted due to 
the e-mail client. Could you check it locally, if your patch applies to 
the current version of www/aolserver in the ports tree and if so, upload 
it somewhere or try to send it in a gzipped tarball. If it fails 
locally, you will need to investigate why it has been generated weirdly.

Thanks for your work,
Gabor
Comment 11 Martin Matuska 2006-12-27 12:40:11 UTC
Problem was not in the mail client - the CVS-Id $FreeBSD$ line should
not be patched at all.
Here is an updated patch. Thanks.
Comment 12 Gabor Kovesdan freebsd_committer 2006-12-27 18:36:23 UTC
State Changed
From-To: feedback->open

Good patch received for www/aolserver via private mail. Please 
keep CC'ing bug-followup@freebsd.org next time so that your replies 
get recorded into the audit trail.
Comment 13 Gabor Kovesdan freebsd_committer 2006-12-28 17:48:34 UTC
State Changed
From-To: open->feedback

The packing lists are wrong for all of these port, except www/aolserver. 
Could you fix them please and send the fix in a unified diff so that I can 
easily track your changes? 

Thanks, 
Gabor
Comment 14 Martin Matuska 2006-12-29 10:56:40 UTC
aolserver-nszlib was missing BUILD_DEPENDS.
I improved the other Makefiles to have less portlint complaints, too.
A gzipped diff with all ports is attached.
Comment 15 Gabor Kovesdan freebsd_committer 2007-01-04 14:52:29 UTC
Martin Matuska schrieb:
> I hope it goes well this time ... Here is a copy to your (private) mail.
>   
Oh, ok, I can see the patch now, but I didn't mean this. I meant a patch 
against the previous versions of these ports, which you sent compressed 
into this PR and I have extracted in my test machine. It's a real 
headache to deal with this patch in this way and I have no time for 
this. If you can send the "incremental" patch I asked for, we can 
continue to getting these into the repo. Btw, www/aolserver patch is ok 
now, please don't send further patches for that, I have the good patch 
but I'm waiting for the others, since these should be committed together.

Regards,
Gabor
Comment 16 Gabor Kovesdan freebsd_committer 2007-01-04 22:16:38 UTC
Ok, the way you sent the patches is ok, but it doesn't fixes the issues 
I told you, it even makes more, so you should just drop them and start 
from those one that are available in the PR in shar files.

While you take one more look at these ports, please also check them with 
sysutils/portlint and try to fix the problems it lists. Note that WARN 
messages are not mandatory to be fixed, but if they can be fixed with a 
small effort, like whitespace fixes, they should be fixed. I usually do 
this myself before committing, but as you still work on these and as a 
maintainer you will be supposed to use portlint in the future as well, 
please do it for me. More info about testing here:
http://www.freebsd.org/doc/en_US.ISO8859-1/books/porters-handbook/porting-testing.html
http://www.freebsd.org/doc/en_US.ISO8859-1/books/porters-handbook/testing-portlint.html

Besides, there is a very good tool that we use for testing, it is called 
tinderbox, you can check it her:
http://tinderbox.marcuscom.com/
It is also available as a port under misc/tinderbox. It is not mandatory 
for you to check them with it, but it is a very good tool and if you 
want to keep working on ports, it's worth to use, it makes your work 
much more easier, you might find the setup a bit complicates at the 
first time.

So, back for the problem. The packing list is the list of files that are 
installed by the specific port and it must contain all the files the 
port install and no more. There are two ways of defining the packing list:
- using the file pkg-plist
- using PLIST_FILES and PLIST_DIRS in Makefile
You can find thorough descriptions about plists here:
http://www.freebsd.org/doc/en_US.ISO8859-1/books/porters-handbook/porting-desc.html#AEN97
http://www.freebsd.org/doc/en_US.ISO8859-1/books/porters-handbook/plist.html

Here's a build log for aolserver-nscache for an example, this log was 
produces by tinderbox:
http://people.freebsd.org/~gabor/logs/aolserver-nscache-1.5.log

You can see here:
tar: aolserver/lib/libnscache.a: Cannot stat: No such file or directory
tar: aolserver/lib/libnscache.so: Cannot stat: No such file or directory

These messages show up after this:
===>  Installing for aolserver-nscache-1.5

For these, we can find out that these files are not actually installed, 
but they are probed to include when the package is generated, so they 
are listed in the packing list, but not actually installed, so they have 
to be removed. After that we can try again to see if package generation 
succeeds.

I hope I could give you enogh information this time. Good luck!

Regards,
Gabor
Comment 17 Martin Matuska 2007-01-31 12:22:29 UTC
bsd.tcl.mk has changed so I changed the www/aolserver port, too - this
reduces Makefile overhead
Another change I made was moving man3, mann and mlinks into port
Makefile, there should be no more shell problems

Files:

Patch against current FreeBSD ports-tree:
http://www.matuska.org/martin/freebsd/ports/patches/www_aolserver.patch

Shar file:
http://www.matuska.org/martin/freebsd/ports/patches/www_aolserver.shar

.tar.gz file:
http://www.matuska.org/martin/freebsd/ports/patches/www_aolserver.tar.gz

Changes can be viewed in SVN (revision 24):
http://www.matuska.org/martin/cgi/viewvc.cgi/ports/www/aolserver/?pathrev=24

Portlint says: looks fine.
Tinderbox is green, log:
http://tinderbox.vx.sk/logs/6.2-FreeBSD-amd64/aolserver-4.5.0.log

I hope at least the master port can be commited soon, I want to post
updated openacs and dotlrn as soon as possible.
Comment 18 Gabor Kovesdan freebsd_committer 2007-02-01 19:40:38 UTC
Hello Martin,

good news that I've tested all of your ports and all are ok, except 
aolserver-nszlib. I have to commit them at once, so this is the last 
barrier. I don't know what's wrong with it, since I see you could 
compile it. Here's a log:
http://people.freebsd.org/~gabor/aolserver-nszlib-1.1.log
Maybe the PR is holding an older version? Could you re-send just this 
one in private mail?

Do you have any idea about this?
I also sent a private mail to you, but hasn't got a response. It would 
be nice if you could write an UPDATING entry about this change stating 
that some Makefile knobs are going away and separate ports can be used 
instead. You can include everthing you consider important about this 
update. I could write this myself, but you know more about these ports, 
so you might be able to tell more.

Regards,
Gabor
Comment 19 dfilter service freebsd_committer 2007-02-02 13:54:01 UTC
gabor       2007-02-02 13:53:51 UTC

  FreeBSD ports repository

  Modified files:
    www                  Makefile 
  Added files:
    www/aolserver-nscache Makefile distinfo pkg-descr pkg-plist 
  Log:
  Tcl interface to AOLserver's caching API
  
  AOLserver implements a C API for caching arbitrary data. This module provides
  a Tcl API on top of the C API. The module is only compatible with AOLserver 3.x
  using nsd8x, or AOLserver 4.x.
  
  WWW: http://www.aolserver.com/
  
  - Martin Matuska
  martin@matuska.org
  
  PR:             ports/105781
  Submitted by:   Martin Matuska <martin@matuska.org>
  Approved by:    erwin (mentor)
  
  Revision  Changes    Path
  1.1698    +1 -0      ports/www/Makefile
  1.1       +45 -0     ports/www/aolserver-nscache/Makefile (new)
  1.1       +3 -0      ports/www/aolserver-nscache/distinfo (new)
  1.1       +10 -0     ports/www/aolserver-nscache/pkg-descr (new)
  1.1       +3 -0      ports/www/aolserver-nscache/pkg-plist (new)
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"
Comment 20 dfilter service freebsd_committer 2007-02-02 13:57:32 UTC
gabor       2007-02-02 13:57:29 UTC

  FreeBSD ports repository

  Modified files:
    security             Makefile 
  Added files:
    security/aolserver-nsencrypt Makefile distinfo pkg-descr 
                                 pkg-plist 
  Log:
  This module Uses OpenSSL to encrypt using the
  AES, Blowfish, Cast5, IDEA and DES cyphers.
  
  WWW: http://www.aolserver.com/
  
  - Martin Matuska
  martin@matuska.org
  
  PR:             ports/105781
  Submitted by:   Martin Matuska <martin@matuska.org>
  Approved by:    erwin (mentor)
  
  Revision  Changes    Path
  1.852     +1 -0      ports/security/Makefile
  1.1       +43 -0     ports/security/aolserver-nsencrypt/Makefile (new)
  1.1       +3 -0      ports/security/aolserver-nsencrypt/distinfo (new)
  1.1       +7 -0      ports/security/aolserver-nsencrypt/pkg-descr (new)
  1.1       +3 -0      ports/security/aolserver-nsencrypt/pkg-plist (new)
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"
Comment 21 dfilter service freebsd_committer 2007-02-02 14:02:59 UTC
gabor       2007-02-02 14:02:42 UTC

  FreeBSD ports repository

  Modified files:
    security             Makefile 
  Added files:
    security/aolserver-nsmcrypt Makefile distinfo pkg-descr 
                                pkg-plist 
  Log:
  AOLserver interface to mcrypt library
  
  WWW: http://www.aolserver.cz/
  
  - Martin Matuska
  martin@matuska.org
  
  PR:             ports/105781
  Submitted by:   Martin Matuska <martin@matuska.org>
  Approved by:    erwin (mentor)
  
  Revision  Changes    Path
  1.853     +1 -0      ports/security/Makefile
  1.1       +49 -0     ports/security/aolserver-nsmcrypt/Makefile (new)
  1.1       +3 -0      ports/security/aolserver-nsmcrypt/distinfo (new)
  1.1       +6 -0      ports/security/aolserver-nsmcrypt/pkg-descr (new)
  1.1       +3 -0      ports/security/aolserver-nsmcrypt/pkg-plist (new)
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"
Comment 22 dfilter service freebsd_committer 2007-02-02 14:06:06 UTC
gabor       2007-02-02 14:06:03 UTC

  FreeBSD ports repository

  Modified files:
    security             Makefile 
  Added files:
    security/aolserver-nsmhash Makefile distinfo pkg-descr 
                               pkg-plist 
  Log:
  AOLserver interface to mhash library
  
  WWW: http://www.aolserver.cz/
  
  - Martin Matuska
  martin@matuska.org
  
  PR:             ports/105781
  Submitted by:   Martin Matuska <martin@matuska.org>
  Approved by:    erwin (mentor)
  
  Revision  Changes    Path
  1.854     +1 -0      ports/security/Makefile
  1.1       +49 -0     ports/security/aolserver-nsmhash/Makefile (new)
  1.1       +3 -0      ports/security/aolserver-nsmhash/distinfo (new)
  1.1       +6 -0      ports/security/aolserver-nsmhash/pkg-descr (new)
  1.1       +3 -0      ports/security/aolserver-nsmhash/pkg-plist (new)
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"
Comment 23 dfilter service freebsd_committer 2007-02-02 14:09:44 UTC
gabor       2007-02-02 14:09:36 UTC

  FreeBSD ports repository

  Modified files:
    security             Makefile 
  Added files:
    security/aolserver-nsopenssl Makefile distinfo pkg-descr 
                                 pkg-plist 
  Log:
  An AOLserver socket driver module which implements SSL/TLS encryption on
  incomming sockets, and also adds an https client API.
  
  WWW: http://www.aolserver.com/
  
  - Martin Matuska
  martin@matuska.org
  
  PR:             ports/105781
  Submitted by:   Martin Matuska <martin@matuska.org>
  Approved by:    erwin (mentor)
  
  Revision  Changes    Path
  1.855     +1 -0      ports/security/Makefile
  1.1       +43 -0     ports/security/aolserver-nsopenssl/Makefile (new)
  1.1       +3 -0      ports/security/aolserver-nsopenssl/distinfo (new)
  1.1       +7 -0      ports/security/aolserver-nsopenssl/pkg-descr (new)
  1.1       +4 -0      ports/security/aolserver-nsopenssl/pkg-plist (new)
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"
Comment 24 dfilter service freebsd_committer 2007-02-02 14:13:18 UTC
gabor       2007-02-02 14:13:13 UTC

  FreeBSD ports repository

  Modified files:
    security             Makefile 
  Added files:
    security/aolserver-nssha1 Makefile distinfo pkg-descr 
                              pkg-plist 
    security/aolserver-nssha1/files patch-nssha1-nssha1.c 
  Log:
  This AOLserver module performs SHA1 hashes.
  
  WWW: http://www.aolserver.com/
  
  - Martin Matuska
  martin@matuska.org
  
  PR:             ports/105781
  Submitted by:   Martin Matuska <martin@matuska.org>
  Approved by:    erwin (mentor)
  
  Revision  Changes    Path
  1.856     +1 -0      ports/security/Makefile
  1.1       +45 -0     ports/security/aolserver-nssha1/Makefile (new)
  1.1       +3 -0      ports/security/aolserver-nssha1/distinfo (new)
  1.1       +12 -0     ports/security/aolserver-nssha1/files/patch-nssha1-nssha1.c (new)
  1.1       +6 -0      ports/security/aolserver-nssha1/pkg-descr (new)
  1.1       +3 -0      ports/security/aolserver-nssha1/pkg-plist (new)
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"
Comment 25 dfilter service freebsd_committer 2007-02-02 14:16:33 UTC
gabor       2007-02-02 14:16:28 UTC

  FreeBSD ports repository

  Modified files:
    graphics             Makefile 
  Added files:
    graphics/aolserver-nsgd Makefile distinfo pkg-descr pkg-plist 
  Log:
  Graphics module for aolserver (3.x,4.x)
  
  WWW: http://www.aolserver.cz/
  
  - Martin Matuska
  martin@matuska.org
  
  PR:             ports/105781
  Submitted by:   Martin Matuska <martin@matuska.org>
  Approved by:    erwin (mentor)
  
  Revision  Changes    Path
  1.1034    +1 -0      ports/graphics/Makefile
  1.1       +47 -0     ports/graphics/aolserver-nsgd/Makefile (new)
  1.1       +3 -0      ports/graphics/aolserver-nsgd/distinfo (new)
  1.1       +6 -0      ports/graphics/aolserver-nsgd/pkg-descr (new)
  1.1       +3 -0      ports/graphics/aolserver-nsgd/pkg-plist (new)
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"
Comment 26 dfilter service freebsd_committer 2007-02-02 14:19:43 UTC
gabor       2007-02-02 14:19:31 UTC

  FreeBSD ports repository

  Modified files:
    databases            Makefile 
  Added files:
    databases/aolserver-nsmysql Makefile distinfo pkg-descr 
                                pkg-plist 
  Log:
  nsmysql is an internal MySQL database driver for AOLserver 3.x and 4.x, by
  Panoptic Computer Network.
  
  WWW: http://www.aolserver.com/
  
  - Martin Matuska
  martin@matuska.org
  
  PR:             ports/105781
  Submitted by:   Martin Matuska <martin@matuska.org>
  Approved by:    erwin (mentor)
  
  Revision  Changes    Path
  1.576     +1 -0      ports/databases/Makefile
  1.1       +46 -0     ports/databases/aolserver-nsmysql/Makefile (new)
  1.1       +3 -0      ports/databases/aolserver-nsmysql/distinfo (new)
  1.1       +7 -0      ports/databases/aolserver-nsmysql/pkg-descr (new)
  1.1       +3 -0      ports/databases/aolserver-nsmysql/pkg-plist (new)
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"
Comment 27 dfilter service freebsd_committer 2007-02-02 14:23:20 UTC
gabor       2007-02-02 14:23:11 UTC

  FreeBSD ports repository

  Modified files:
    databases            Makefile 
  Added files:
    databases/aolserver-nspostgres Makefile distinfo pkg-descr 
                                   pkg-plist 
  Log:
  nspostgres is an internal PostgreSQL database driver for AOLserver 3.x and 4.x.
  
  WWW: http://www.aolserver.com/
  
  - Martin Matuska
  martin@matuska.org
  
  PR:             ports/105781
  Submitted by:   Martin Matuska <martin@matuska.org>
  Approved by:    erwin (mentor)
  
  Revision  Changes    Path
  1.577     +1 -0      ports/databases/Makefile
  1.1       +46 -0     ports/databases/aolserver-nspostgres/Makefile (new)
  1.1       +3 -0      ports/databases/aolserver-nspostgres/distinfo (new)
  1.1       +6 -0      ports/databases/aolserver-nspostgres/pkg-descr (new)
  1.1       +3 -0      ports/databases/aolserver-nspostgres/pkg-plist (new)
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"
Comment 28 dfilter service freebsd_committer 2007-02-02 14:26:37 UTC
gabor       2007-02-02 14:26:28 UTC

  FreeBSD ports repository

  Modified files:
    archivers            Makefile 
  Added files:
    archivers/aolserver-nszlib Makefile distinfo pkg-descr 
                               pkg-plist 
  Log:
  AOLserver interface to zlib library
  
  WWW: http://www.crystalballinc.com/vlad/software/
  
  - Martin Matuska
  martin@matuska.org
  
  PR:             ports/105781
  Submitted by:   Martin Matuska <martin@matuska.org>
  Approved by:    erwin (mentor)
  
  Revision  Changes    Path
  1.173     +1 -0      ports/archivers/Makefile
  1.1       +44 -0     ports/archivers/aolserver-nszlib/Makefile (new)
  1.1       +3 -0      ports/archivers/aolserver-nszlib/distinfo (new)
  1.1       +6 -0      ports/archivers/aolserver-nszlib/pkg-descr (new)
  1.1       +3 -0      ports/archivers/aolserver-nszlib/pkg-plist (new)
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"
Comment 29 dfilter service freebsd_committer 2007-02-02 14:40:25 UTC
gabor       2007-02-02 14:39:51 UTC

  FreeBSD ports repository

  Modified files:
    .                    modules 
  Log:
  aolserver-nscache --> ports/www/aolserver-nscache
  aolserver-nsencrypt --> ports/security/aolserver-nsencrypt
  aolserver-nsgd --> ports/graphics/aolserver-nsgd
  aolserver-nsmcrypt --> ports/security/aolserver-nsmcrypt
  aolserver-nsmhash --> ports/security/aolserver-nsmhash
  aolserver-nsmysql --> ports/databases/aolserver-nsmysql
  aolserver-nsopenssl --> ports/security/aolserver-nsopenssl
  aolserver-nspostgres --> ports/databases/aolserver-nspostgres
  aolserver-nssha1 --> ports/security/aolserver-nssha1
  aolserver-nszlib --> ports/archivers/aolserver-nszlib
  
  PR:             ports/105781
  Submitted by:   Martin Matuska <martin@matuska.org>
  Approved by:    erwin (mentor)
  
  Revision  Changes    Path
  1.17281   +10 -0     CVSROOT/modules
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"
Comment 30 dfilter service freebsd_committer 2007-02-02 14:47:02 UTC
gabor       2007-02-02 14:46:50 UTC

  FreeBSD ports repository

  Modified files:
    www/aolserver        Makefile distinfo pkg-plist 
    www/aolserver/files  pkg-install.in pkg-message.in 
  Added files:
    www/aolserver/files  aolserver.in patch-Makefile 
                         pkg-deinstall.in 
  Removed files:
    www/aolserver        pkg-deinstall 
    www/aolserver/files  aolserver.sh.in patch-nssha1-nssha1.c 
  Log:
  - Update to 4.5.0
  - Move out modules into separate ports
  - Rename rc.d script
  - Pass maintainership to submitter
  
  PR:             ports/105781
  Submitted by:   Martin Matuska <martin@matuska.org>
  Approved by:    aldert@nooitgedagt.net (maintainer),
                  erwin (mentor)
  
  Revision  Changes    Path
  1.23      +668 -318  ports/www/aolserver/Makefile
  1.13      +3 -15     ports/www/aolserver/distinfo
  1.1       +47 -0     ports/www/aolserver/files/aolserver.in (new)
  1.5       +0 -49     ports/www/aolserver/files/aolserver.sh.in (dead)
  1.1       +15 -0     ports/www/aolserver/files/patch-Makefile (new)
  1.2       +0 -12     ports/www/aolserver/files/patch-nssha1-nssha1.c (dead)
  1.1       +23 -0     ports/www/aolserver/files/pkg-deinstall.in (new)
  1.2       +8 -25     ports/www/aolserver/files/pkg-install.in
  1.3       +8 -24     ports/www/aolserver/files/pkg-message.in
  1.2       +0 -20     ports/www/aolserver/pkg-deinstall (dead)
  1.10      +879 -127  ports/www/aolserver/pkg-plist
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"
Comment 31 dfilter service freebsd_committer 2007-02-02 14:50:23 UTC
gabor       2007-02-02 14:50:16 UTC

  FreeBSD ports repository

  Modified files:
    .                    UPDATING 
  Log:
  - Add note about recent www/aolserver change
  
  PR:             ports/105781
  Submitted by:   Martin Matuska <martin@matuska.org>
  Approved by:    erwin (mentor)
  
  Revision  Changes    Path
  1.453     +24 -1     ports/UPDATING
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"
Comment 32 Gabor Kovesdan freebsd_committer 2007-02-02 14:53:37 UTC
State Changed
From-To: feedback->closed

Thanks for the tremendous work you invested into these ports! 
I committed all of them.