Bug 106571 - Unable to install jackit-0.102.20_1
Summary: Unable to install jackit-0.102.20_1
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: freebsd-multimedia (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-12-10 20:10 UTC by Gerard Seibert
Modified: 2006-12-10 22:41 UTC (History)
0 users

See Also:


Attachments
file.txt (28.57 KB, text/plain)
2006-12-10 20:10 UTC, Gerard Seibert
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gerard Seibert 2006-12-10 20:10:07 UTC
I am unable to build jackit-0.102.20_1 on my PC. I have the older version install, but I cannot update it. Finally, in what was probably a stupid move, I deinstalled the older version and tried again. Again it failed. Now I have no version installed.

I have tried both the 'make install' method, then I used 'portmanager' and finally 'portupgrade'. Nothing works. I cannot even get the old package version to install.

The log file of the build attempt is attached. For the record, I have been at this for three days now. I ran 'portsclean' to make sure everything was fresh and then 'portsnap' to insure a fresh ports collection. I even rebooted the system thinking that something there might be broken. Unfortunately, no success.

Fix: Patch attached with submission follows:
How-To-Repeat: Just try to install the port.
Comment 1 Edwin Groothuis freebsd_committer 2006-12-10 20:48:44 UTC
Responsible Changed
From-To: freebsd-ports-bugs->freebsd-multimedia

Over to maintainer
Comment 2 Jeremy Messenger freebsd_committer 2006-12-10 21:57:14 UTC
State Changed
From-To: open->feedback

Can you test this patch? Put this file[1] in audio/jack/files/ and try it 
again. I personal don't understand why this is problem on your system. Maybe, 
it is because of no -O in CFLAGS? or else that I am not sure as I am not 
skill at C but the code looks fine to me. I might be wrong. 

[1] http://people.freebsd.org/~mezz/diff/patch-drivers_dummy_dummy_driver.c
Comment 3 Jeremy Messenger freebsd_committer 2006-12-10 22:39:45 UTC
State Changed
From-To: feedback->closed

I was right about no -O in CFLAGS has caused this problem as I can reproduce 
it. marcus has reviewed and helped me to change a bit in patch, so I have 
tested and it fixed this problem. Wait for CVSup mirror to catch up. Thanks 
for report!