Bug 107689 - mail/thunderbird - drag and drop of messages to folders fails
Summary: mail/thunderbird - drag and drop of messages to folders fails
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: freebsd-gnome (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-01-08 19:20 UTC by Daniel Kauffman
Modified: 2007-01-25 17:00 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Daniel Kauffman 2007-01-08 19:20:22 UTC
Quoting Charles Bailey from https://bugzilla.mozilla.org/show_bug.cgi?id=355248

Moving of messages by dragging the header line from the message "catalog" pane onto a folder icon in the mailbox listing has broken between the Sep 26 nightly
and the Oct 01 nightly.  The drag appears to start normally (message header
line higlights, and outline deags) but the folders do not act as targets (i.e.
do not highlight when dragged over).  Moving messages via main or context menu
commands works fine.

Reproducible: Always

Steps to Reproduce:
1. Open mailbox
2. Select message from listing of mailbox contents
3. Attempt to drag onto another folder

Actual Results:  
As above

Expected Results:  
Target folder highlights, and releasing mouse while hovering over target folder
causes message to be moved.

Fix: 

Work-around is to revert gtk+ 2.10.7 to 2.8.20

Possibly consider making mail/thunderbird dependent on gtk version <= 2.8.20 until this is fixed.

See notes on https://bugzilla.mozilla.org/show_bug.cgi?id=355248
How-To-Repeat: Quoting Charles Bailey from https://bugzilla.mozilla.org/show_bug.cgi?id=355248

1. Open mailbox
2. Select message from listing of mailbox contents
3. Attempt to drag onto another folder
Comment 1 Edwin Groothuis freebsd_committer 2007-01-08 19:20:49 UTC
Responsible Changed
From-To: freebsd-ports-bugs->gnome

Over to maintainer
Comment 2 Tony Maher 2007-01-17 04:45:57 UTC
Reverting to gtk-2.10.6_3 fixes the problem with mozilla-1.7.13_1,2.
-- 
Tony Maher
Comment 3 Tony Maher 2007-01-18 09:50:26 UTC
Just tried gtk 2.10.8 as suggested by Jeremy M. but it also has
drag and drop problem. Staying with 2.10.6_3 for now.

-- 
Tony Maher
Comment 4 Jeremy Messenger freebsd_committer 2007-01-18 22:37:16 UTC
State Changed
From-To: open->closed

I have committed Matthias Clasen's patch version from in 
https://bugzilla.mozilla.org/show_bug.cgi?id=367203 ... Thanks for report!
Comment 5 dfilter service freebsd_committer 2007-01-18 22:37:19 UTC
mezz        2007-01-18 22:37:11 UTC

  FreeBSD ports repository

  Modified files:
    www/firefox          Makefile 
    www/nvu              Makefile 
    www/seamonkey        Makefile 
    mail/thunderbird     Makefile 
    www/xulrunner        Makefile 
    sysutils/flock       Makefile 
    www/firefox15        Makefile 
    www/mozilla          Makefile 
  Added files:
    www/firefox/files    patch-widget_src_gtk2_nsDragService.cpp 
    www/nvu/files        patch-widget_src_gtk2_nsDragService.cpp 
    www/seamonkey/files  patch-widget_src_gtk2_nsDragService.cpp 
    mail/thunderbird/files patch-widget_src_gtk2_nsDragService.cpp 
    www/xulrunner/files  patch-widget_src_gtk2_nsDragService.cpp 
    sysutils/flock/files patch-widget_src_gtk2_nsDragService.cpp 
    www/firefox15/files  patch-widget_src_gtk2_nsDragService.cpp 
    www/mozilla/files    patch-widget_src_gtk2_nsDragService.cpp 
  Log:
  Fix the gtk2 dnd implementation broken, see more details in the bugzilla. This
  patch[1] was created by Matthias Clasen <mclasen@redhat.com>. This bug was
  started to reproduce with least 2.10.7 version of gtk2.
  
  PR:             ports/107689
  Reported by:    a few users
  Bugzilla:       https://bugzilla.mozilla.org/show_bug.cgi?id=355248
                  https://bugzilla.mozilla.org/show_bug.cgi?id=367203 [1]
                  http://bugzilla.gnome.org/show_bug.cgi?id=394525
  
  Revision  Changes    Path
  1.74      +1 -0      ports/mail/thunderbird/Makefile
  1.1       +18 -0     ports/mail/thunderbird/files/patch-widget_src_gtk2_nsDragService.cpp (new)
  1.7       +1 -0      ports/sysutils/flock/Makefile
  1.1       +18 -0     ports/sysutils/flock/files/patch-widget_src_gtk2_nsDragService.cpp (new)
  1.172     +2 -0      ports/www/firefox/Makefile
  1.1       +18 -0     ports/www/firefox/files/patch-widget_src_gtk2_nsDragService.cpp (new)
  1.168     +2 -1      ports/www/firefox15/Makefile
  1.1       +18 -0     ports/www/firefox15/files/patch-widget_src_gtk2_nsDragService.cpp (new)
  1.216     +2 -1      ports/www/mozilla/Makefile
  1.1       +18 -0     ports/www/mozilla/files/patch-widget_src_gtk2_nsDragService.cpp (new)
  1.28      +2 -1      ports/www/nvu/Makefile
  1.1       +18 -0     ports/www/nvu/files/patch-widget_src_gtk2_nsDragService.cpp (new)
  1.259     +1 -0      ports/www/seamonkey/Makefile
  1.1       +18 -0     ports/www/seamonkey/files/patch-widget_src_gtk2_nsDragService.cpp (new)
  1.8       +2 -1      ports/www/xulrunner/Makefile
  1.1       +18 -0     ports/www/xulrunner/files/patch-widget_src_gtk2_nsDragService.cpp (new)
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"
Comment 6 dfilter service freebsd_committer 2007-01-18 22:53:18 UTC
mezz        2007-01-18 22:53:12 UTC

  FreeBSD ports repository

  Modified files:
    www/flock            Makefile 
  Added files:
    www/flock/files      patch-widget_src_gtk2_nsDragService.cpp 
  Log:
  Fix the gtk2 dnd implementation broken, see more details in the bugzilla. This
  patch[1] was created by Matthias Clasen <mclasen@redhat.com>. This bug was
  started to reproduce with least 2.10.7 version of gtk2. Bump the PORTREVISION.
  
  PR:             ports/107689
  Reported by:    a few users
  Bugzilla:       https://bugzilla.mozilla.org/show_bug.cgi?id=355248
                  https://bugzilla.mozilla.org/show_bug.cgi?id=367203 [1]
                  http://bugzilla.gnome.org/show_bug.cgi?id=394525
  
  Revision  Changes    Path
  1.163     +1 -1      ports/www/flock/Makefile
  1.1       +18 -0     ports/www/flock/files/patch-widget_src_gtk2_nsDragService.cpp (new)
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"
Comment 7 Bruce M Simpson 2007-01-25 16:59:28 UTC
I can confirm that the fix in this PR works for me as described, and 
that the drag and drop problem definitely exists.