Bug 107944 - [wi] [patch] Forget to unlock mutex-locks
Summary: [wi] [patch] Forget to unlock mutex-locks
Status: Open
Alias: None
Product: Base System
Classification: Unclassified
Component: kern (show other bugs)
Version: unspecified
Hardware: Any Any
: Normal Affects Only Me
Assignee: freebsd-bugs mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-01-15 08:40 UTC by Beyond Luo
Modified: 2018-01-03 05:16 UTC (History)
0 users

See Also:


Attachments
file.diff (1.02 KB, patch)
2007-01-15 08:40 UTC, Beyond Luo
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Beyond Luo 2007-01-15 08:40:16 UTC
These two bugs, exiting with mutex-lock holded, are detected by a static analyzer we are developing.
One of them are caused by GOTO statement.

Fix: Patch attached with submission follows:
Comment 1 Remko Lodder freebsd_committer 2007-01-15 08:42:20 UTC
State Changed
From-To: open->closed

duplicate of i386/107943
Comment 2 Ed Maste freebsd_committer 2007-08-22 15:50:03 UTC
State Changed
From-To: closed->open

Not actually a dupe; i386/107943 mentions two bugs but includes 
only one patch.  The patch in i386/107943 has been applied to 
aac_cam.c, while the patch to if_wi.c which exists only in this 
PR has not been applied.
Comment 3 Ed Maste freebsd_committer 2007-08-22 15:54:47 UTC
Responsible Changed
From-To: freebsd-i386->freebsd-bugs

Not i386 specific.
Comment 4 K. Macy freebsd_committer 2007-11-16 09:42:27 UTC
Responsible Changed
From-To: freebsd-bugs->kmacy


I'll take a look at the wi patch.
Comment 5 K. Macy freebsd_committer 2007-11-16 20:41:15 UTC
Responsible Changed
From-To: kmacy->rink


rink said he would be willing to test the patch against wi
Comment 6 Rink Springer freebsd_committer 2008-01-30 13:40:45 UTC
Responsible Changed
From-To: rink->freebsd-bugs

My wi(4) appears to be broken - with or without this patch, I don't even see 
any SSID's :-(. Can someone with working hardware check this?
Comment 7 Mark Linimon freebsd_committer freebsd_triage 2008-09-28 03:50:27 UTC
Responsible Changed
From-To: freebsd-bugs->freebsd-net

reclassify.
Comment 8 Eitan Adler freebsd_committer freebsd_triage 2017-12-31 08:01:34 UTC
For bugs matching the following criteria:

Status: In Progress Changed: (is less than) 2014-06-01

Reset to default assignee and clear in-progress tags.

Mail being skipped