Bug 108222 - x11-themes/gtk-qt-engine: fix/tidy up
Summary: x11-themes/gtk-qt-engine: fix/tidy up
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Martin Wilke
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-01-22 21:40 UTC by Danny Pansters
Modified: 2007-02-08 22:40 UTC (History)
1 user (show)

See Also:


Attachments
x11-themes::gtk-qt-engine.diff (2.78 KB, patch)
2007-01-22 21:40 UTC, Danny Pansters
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Danny Pansters 2007-01-22 21:40:19 UTC
	- No longer need to use X11BASE or partly install to it (because of GTK location)
	- Use REINPLACE on Makefile.in at pre-configure stage, not on Makefile post-configure
	- Remove unneeded PLIST vars, use only %%GTK2_VERSION%% as intended
	- Adapt pkg-plist
	- Port is finally PREFIX-safe
	- Bump revision
	- Set myself as MAINTAINER, this supersedes ports/108165
Comment 1 Martin Wilke freebsd_committer 2007-01-22 21:42:29 UTC
Responsible Changed
From-To: freebsd-ports-bugs->miwi

I'll take it.
Comment 2 Martin Wilke freebsd_committer 2007-01-23 09:19:25 UTC
State Changed
From-To: open->feedback

Ask for maintainer fix.
Comment 3 dfilter service freebsd_committer 2007-02-08 22:32:02 UTC
miwi        2007-02-08 22:31:56 UTC

  FreeBSD ports repository

  Modified files:
    x11-themes/gtk-qt-engine Makefile pkg-descr pkg-plist 
  Log:
  - No longer need to use X11BASE or partly install to it (because of GTK location)
  - Use REINPLACE on Makefile.in at pre-configure stage, not on Makefile post-configure
  - Remove unneeded PLIST vars, use only %%GTK2_VERSION%% as intended
  - Adapt pkg-plist
  - Port is finally PREFIX-safe
  - Bump revision
  - Pass maintainership to submitter
  
  PR:             108222
  Submitted by:   Danny Pansters <danny@ricin.com>
  
  Revision  Changes    Path
  1.25      +18 -15    ports/x11-themes/gtk-qt-engine/Makefile
  1.3       +1 -1      ports/x11-themes/gtk-qt-engine/pkg-descr
  1.8       +4 -5      ports/x11-themes/gtk-qt-engine/pkg-plist
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"
Comment 4 Martin Wilke freebsd_committer 2007-02-08 22:32:51 UTC
State Changed
From-To: feedback->closed

Committed. Thanks!