Bug 108844 - [PATCH] upgrade emulators/kqemu-kmod to 1.3.0pre10
Summary: [PATCH] upgrade emulators/kqemu-kmod to 1.3.0pre10
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Juergen Lock
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-02-06 19:50 UTC by Stefan Sperling
Modified: 2007-02-06 20:56 UTC (History)
0 users

See Also:


Attachments
file.diff (1.72 KB, patch)
2007-02-06 19:50 UTC, Stefan Sperling
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Stefan Sperling 2007-02-06 19:50:17 UTC
	

	This patch updates the emulators/kqemu-kmod port to
	version 1.3.0pre10.

	The special thing about this release is that the module
	is now released under the GPL, so it can be built from
	source and does not constitute a binary blob anymore.
	This is what motivated me to update this port.
	
	Since the modules is GPL licensed, FreeBSD kernels
	linked with this module may not be distributed.

	-- NOTE: --
	After making this patch, I've briefly tested the module by
	booting a Linux and a FreeBSD guest, but sadly qemu segfaults
	fairly quickly after start up while booting either of them.

	I've decided to submit this anyway in case it is of any use.
	The segfault problem should be looked into before comitting
	this patch though. If you have trouble reproducing this,
	I will gladly provide backtraces.
Comment 1 Edwin Groothuis freebsd_committer 2007-02-06 19:50:35 UTC
Responsible Changed
From-To: freebsd-ports-bugs->nox

Over to maintainer
Comment 2 Juergen Lock freebsd_committer 2007-02-06 20:56:28 UTC
State Changed
From-To: open->closed

Committed, with minor changes. Thanks!