Bug 110513 - audio/vorbis-tools - Installation fails
Summary: audio/vorbis-tools - Installation fails
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Christian Weisgerber
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-03-19 12:30 UTC by Herbert J. Skuhra
Modified: 2007-03-20 15:10 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Herbert J. Skuhra 2007-03-19 12:30:05 UTC
Installation of audio/vorbis-tools fails with the below error message:

===>  Checking if audio/vorbis-tools already installed
Making install in po
/bin/sh @MKINSTALLDIRS@ /usr/local/share
@MKINSTALLDIRS@: Can't open @MKINSTALLDIRS@: No such file or directory
*** Error code 2

Stop in /usr/ports/audio/vorbis-tools/work/vorbis-tools-1.1.1/po.
*** Error code 1

Stop in /usr/ports/audio/vorbis-tools/work/vorbis-tools-1.1.1.
*** Error code 1

Stop in /usr/ports/audio/vorbis-tools.

This is probably caused by the recent gettext update.

I tried

% sudo pkg_delete -fa
% sudo rm -rf /usr/local
% sudo rm -rf /usr/X11R6
% rm -f /var/db/pkg/pkgdb.db
% portupgrade -N audio/vorbis-tools

But the installation of audio/vorbis-tools still fails with the same error.

The full build log is available from:

http://norway.ath.cx/temp/log_vorbis_tools.txt

Fix: 

Sorry, no idea so far.
Comment 1 Edwin Groothuis freebsd_committer 2007-03-19 12:30:14 UTC
Responsible Changed
From-To: freebsd-ports-bugs->naddy

Over to maintainer
Comment 2 dfilter service freebsd_committer 2007-03-20 15:00:16 UTC
naddy       2007-03-20 15:00:00 UTC

  FreeBSD ports repository

  Modified files:
    audio/vorbis-tools   Makefile 
  Log:
  Pull in new po/Makefile.in.in since the new gettext autoconf macros don't
  perform all substitutions required by the old one.
  
  PR:             110513
  
  Revision  Changes    Path
  1.43      +5 -0      ports/audio/vorbis-tools/Makefile
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"
Comment 3 Christian Weisgerber freebsd_committer 2007-03-20 15:00:17 UTC
State Changed
From-To: open->closed

Fixed.