Bug 112299 - Dvbcut and make patch errors
Summary: Dvbcut and make patch errors
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Stefan Esser
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-05-01 14:00 UTC by ganael.laplanche
Modified: 2007-06-26 23:04 UTC (History)
0 users

See Also:


Attachments
file.shar (2.64 KB, text/plain)
2007-05-01 14:00 UTC, ganael.laplanche
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description ganael.laplanche 2007-05-01 14:00:12 UTC
Dvbcut patches fail to apply cleanly on dvbcut-0.5.4 because some of the patches seem to have been included in the main code.

Fix: Use the attached shar file for the 'files' directory of the dvbcut port

Patch attached with submission follows:
How-To-Repeat: cd /usr/ports/multimedia/dvbcut && make patch
Comment 1 Edwin Groothuis freebsd_committer 2007-05-01 14:04:47 UTC
Responsible Changed
From-To: freebsd-ports-bugs->se

Over to maintainer
Comment 2 ganael.laplanche 2007-05-01 14:38:03 UTC
BTW, I get a lot of build errors because INT64_C is not defined. I can define it
manually by adding :

#ifndef INT64_C
#define INT64_C(c) (c ## L)
#endif

before :

#include <ffmpeg/avformat.h>

in each of these files :

src/lavfmuxer.cpp
src/lavfmuxer.h
src/main.cpp
src/streamdata.h

The compilation continues, but finally stops with this error :

src/psfile.cpp: In constructor `psfile::psfile(const std::string&, inbuffer&, int)':
src/psfile.cpp:103: error: `ac3_decoder' was not declared in this scope
scons: *** [src/psfile.o] Error 1
scons: building terminated because of errors.
gmake: *** [build] Error 2
*** Error code 2

Stop in /usr/ports/multimedia/dvbcut.

Ganaël LAPLANCHE
ganael.laplanche@martymac.com
http://www.martymac.com
Comment 3 ganael.laplanche 2007-05-01 17:30:49 UTC
On Tue, 01 May 2007 17:11:36 +0200, Stefan Esser wrote

Hi Stefan,

I've cvsup'ed to the latest revision of the port. The patches now apply properly.

> you have to #define __STDC_LIMIT_MACROS before this file is read to get them.
(The easiest way is to define it via CFLAGS.)
> But this should have been fixed with the upgrade to 0.5.4.

Unfortunately, I've got the same error :

In file included from src/lavfmuxer.h:22,
                 from src/dvbcut.cpp:52:
/usr/local/include/ffmpeg/avformat.h: In function `void av_init_packet(AVPacket*)':
/usr/local/include/ffmpeg/avformat.h:66: error: `INT64_C' was not declared in
this scope
/usr/local/include/ffmpeg/avformat.h: At global scope:
/usr/local/include/ffmpeg/avformat.h:292: warning: `AVFrac' is deprecated
(declared at /usr/local/include/ffmpeg/avformat.h:118)
scons: *** [src/dvbcut.o] Error 1
scons: building terminated because of errors.
gmake: *** [build] Error 2
*** Error code 2

Stop in /usr/ports/multimedia/dvbcut.

Thank you very much,
Best regards,

Ganaël LAPLANCHE
ganael.laplanche@martymac.com
http://www.martymac.com
Comment 4 pav freebsd_committer 2007-06-26 23:04:28 UTC
State Changed
From-To: open->closed

Can't reproduce - dvbcut patches fine.