Bug 112876 - audio/xmcd - compile problems after xorg 7.2 upgrade (might be not related)
Summary: audio/xmcd - compile problems after xorg 7.2 upgrade (might be not related)
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Stefan Walter
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-05-23 01:10 UTC by edwin
Modified: 2007-09-30 13:00 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description edwin 2007-05-23 01:10:03 UTC
Found this due to the forced update of audio/xmcd with the xorg
upgrade last weekend:

[....]
rm -f xmcd
cc -o xmcd     -pthread  -L/usr/local/lib   callback.o  cdfunc.o        command.o       dbprog.o        geom.o  help.o  hotkey.o        main.o  userreg.o      widget.o         wwwwarp.o       ../labelh_d/libLabelH.a         ../cdinfo_d/libcdinfo.a         ../cddb_d/libcddbkey.a  ../libdi_d/libdi.a      ../cdda_d/libcdda.a     ../common_d/libutil.a -L/usr/local/lib -lXm -lXp -lXaw -lXmu -lXt -lSM -lICE -lXpm -lXp -lXext -lX11 -lcam   -L../cddb_d -lcddb -L/usr/freeware/lib32 -L/usr/local/lib -lFLAC -lvorbisenc -lvorbis -logg -lm   -Wl,-rpath,/usr/local/lib
../cdinfo_d/libcdinfo.a(cdinfo_i.o)(.text+0x4f6): In function `cdinfo_set_errstr':
: undefined reference to `CddbGetErrorString'
../cdinfo_d/libcdinfo.a(cdinfo_i.o)(.text+0x5436): In function `cdinfo_get_fullname':
: undefined reference to `CddbFullName_GetName'
../cdinfo_d/libcdinfo.a(cdinfo_i.o)(.text+0x5453): In function `cdinfo_get_fullname':
: undefined reference to `CddbFullName_GetLastName'
../cdinfo_d/libcdinfo.a(cdinfo_i.o)(.text+0x5472): In function `cdinfo_get_fullname':
: undefined reference to `CddbFullName_GetFirstName'
Comment 1 Edwin Groothuis freebsd_committer 2007-05-23 01:10:09 UTC
State Changed
From-To: open->feedback

Awaiting maintainers feedback
Comment 2 TsurutaniNaoki 2007-05-31 06:24:37 UTC
Hi,

  I came across the same problem.

  I think this is caused by the duplicated library installed by audio/libcddb.
Before Xorg 7.2, xmcd was installed with the X11BASE prefix.
Now, it is installed under /usr/local, and library search path while building
is set to the PREFIX/lib.
  Therefore, linker delect /usr/local/lib/libcddb.a in linking xmcd and other tools,
and fails to find symbols.

  I do not know how to fix this in a adequate manner, but I have one solution;
renaming local libcdda.a to another. Here is a patch:

--- files/patch-aa.orig     Fri Jan 10 11:50:37 2003
+++ files/patch-aa    Thu May 31 12:56:28 2007
@@ -1,5 +1,14 @@
 --- xmcd_d/Imakefile.orig      Mon Nov  4 06:44:44 2002
 +++ xmcd_d/Imakefile   Mon Nov  4 04:44:28 2002
+@@ -44,7 +44,7 @@
+  * #include "Motif.rules"
+  */
+
+-CDDBLIB= -L../cddb_d -lcddb
++CDDBLIB= -L../cddb_d -lcddblocal
+ LOCAL_LIBDIR= -L/usr/freeware/lib32 -L/usr/local/lib
+ VORBLIB= -lvorbisenc -lvorbis -logg
+ FLACLIB= -lFLAC
 @@ -82,7 +82,7 @@
  #endif        /* OSF1 */
  #endif        /* Linux */


--- files/patch-ac.orig     Fri Feb  9 06:01:18 2007
+++ files/patch-ac    Thu May 31 12:57:09 2007
@@ -1,5 +1,14 @@
 --- cda_d/Imakefile.orig       Thu Apr 22 03:27:23 2004
 +++ cda_d/Imakefile    Fri Feb  2 04:44:17 2007
+@@ -145,7 +145,7 @@
+ /*
+  * Add needed libraries
+  */
+-CDDBLIB= -L../cddb_d -lcddb
++CDDBLIB= -L../cddb_d -lcddblocal
+ LOCAL_LIBDIR= -L/usr/freeware/lib32 -L/usr/local/lib
+ VORBLIB= -lvorbisenc -lvorbis -logg
+ FLACLIB= -lFLAC
 @@ -193,7 +193,7 @@
  LOCAL_LIBRARIES=-lncurses
  #else


--- /dev/null   Thu May 31 13:00:26 2007
+++ patch-aj    Thu May 31 12:58:25 2007
@@ -0,0 +1,11 @@
+--- cddb_d/Imakefile.orig      Thu May 31 12:53:57 2007
++++ cddb_d/Imakefile   Thu May 31 12:53:00 2007
+@@ -225,7 +225,7 @@
+ /*
+  * Build rule for the CD Information Library
+  */
+-NormalLibraryTarget(cddb,$(OBJS))
++NormalLibraryTarget(cddblocal,$(OBJS))
+ NormalLibraryTarget(cddbkey1,$(KOBJ))
+ DependTarget()
+

---
Tsurutani Naoki
turutani@scphys.kyoto-u.ac.jp
Comment 3 TsurutaniNaoki 2007-06-06 05:31:30 UTC
I'm very sorry, for the patch i sent was wrong in the path of the last file.
Add "files/" at the top.

---
Tsurutani Naoki
turutani@scphys.kyoto-u.ac.jp
Comment 4 Stefan Walter freebsd_committer 2007-09-30 12:46:46 UTC
Responsible Changed
From-To: freebsd-ports-bugs->stefan

Take.
Comment 5 dfilter service freebsd_committer 2007-09-30 12:53:06 UTC
stefan      2007-09-30 11:53:01 UTC

  FreeBSD ports repository

  Modified files:
    audio/xmcd/files     patch-aa patch-ac 
  Added files:
    audio/xmcd/files     patch-aj 
  Log:
  Fix build with xorg >=7.2 by renaming the included libcddb.
  
  PR:             112876
  Submitted by:   edwin
  Patch by:       Tsurutani Naoki <turutani@scphys.kyoto-u.ac.jp>
  Approved by:    maintainer timeout (4 months)
  
  Revision  Changes    Path
  1.8       +9 -0      ports/audio/xmcd/files/patch-aa
  1.5       +9 -0      ports/audio/xmcd/files/patch-ac
  1.1       +11 -0     ports/audio/xmcd/files/patch-aj (new)
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"
Comment 6 Stefan Walter freebsd_committer 2007-09-30 12:53:08 UTC
State Changed
From-To: feedback->closed

Patch committed, thanks!