Bug 112942 - repocopy: move net/rrdtool to databases/rrdtool
repocopy: move net/rrdtool to databases/rrdtool
Status: Closed FIXED
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s)
Latest
Any Any
: Normal Affects Only Me
Assigned To: Edwin Groothuis
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-24 14:50 UTC by edwin
Modified: 2007-07-05 07:54 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description edwin 2007-05-24 14:50:02 UTC
It's an itch which needs to be scratched: net/rrdtool came from
net/mrtg, which was a good location for it. net/mrtg has later been
moved to net-mgmt/mrtg. net/rrdtool is "Round Robin Database Tools",
therefor it's better if it moves to databases/rrdtool. Same with
net/rrdtool10.

Fix: 

Repocopy:
		net/rrdtool	-> databases/rrdtool
		net/rrdtool10	-> databases/rrdtool10

Change CATEGORIES:
		net		-> databases graphics

Affected ports:
		databases/mysqlard
		devel/p5-RRDTool-OO
		devel/p5-SVN-Statistics
		graphics/orca
		mail/couriergraph
		mail/mailgraph
		net/cacti
		net/happystats
		net/jffnms
		net/jrobin
		net/p5-POE-Component-RRDTool
		net/p5-RRD-Simple
		net/php4-rrdtool
		net/php5-rrdtool
		net/py-rrdpipe
		net/py-rrdtool_lgpl
		net/rrdtool
		net/rrdtool10
		net/smokeping
		net-mgmt/bigsister
		net-mgmt/cricket
		net-mgmt/flowscan
		net-mgmt/ifgraph
		net-mgmt/junipoll
		net-mgmt/nagiosgraph
		net-mgmt/nagiostat
		net-mgmt/nav
		net-mgmt/nfsen
		net-mgmt/nrg
		net-mgmt/ourmon
		net-mgmt/torrus
		security/amavis-stats
		sysutils/dtc
		sysutils/dtc-toaster
		sysutils/munin-main
		sysutils/symon
		www/drraw

I volunteer to do the changes in the above mentioned ports.
Comment 1 Edwin Groothuis freebsd_committer 2007-05-24 14:50:09 UTC
Responsible Changed
From-To: freebsd-ports-bugs->demon

Over to maintainer
Comment 2 Edwin Groothuis freebsd_committer 2007-06-08 22:23:28 UTC
State Changed
From-To: open->repocopy

over to portmgr for requested repocopy. 


Comment 3 Edwin Groothuis freebsd_committer 2007-06-08 22:23:28 UTC
Responsible Changed
From-To: demon->portmgr

over to portmgr for requested repocopy.
Comment 4 Dmitry Sivachenko freebsd_committer 2007-06-09 08:32:46 UTC
State Changed
From-To: repocopy->feedback

I dunno why you ignored my private e-mail about this PR so i repeat it 
there. 

I think rrdtool should stay in the same category as mrtg, so proper 
category for it is net-mgmt. 

rrdtool is close to net-mgmt rather than database. 

So i have nothing agains repo-copy to net-mgmt, but i think 
databases category is bad choice. 


Comment 5 Dmitry Sivachenko freebsd_committer 2007-06-09 08:32:46 UTC
Responsible Changed
From-To: portmgr->demon

I dunno why you ignored my private e-mail about this PR so i repeat it 
there. 

I think rrdtool should stay in the same category as mrtg, so proper 
category for it is net-mgmt. 

rrdtool is close to net-mgmt rather than database. 

So i have nothing agains repo-copy to net-mgmt, but i think 
databases category is bad choice.
Comment 6 Edwin Groothuis freebsd_committer 2007-06-09 13:04:21 UTC
State Changed
From-To: feedback->open

> I dunno why you ignored my private e-mail about this PR so i repeat it 
> there. 

Please send me the message-id of the email and I'll see if I have 
received it. As far as I can see, I didn't receive it. 

> I think rrdtool should stay in the same category as mrtg, so proper 
> category for it is net-mgmt. 
> rrdtool is close to net-mgmt rather than database. 

As where MRTG was intended for all aspects of network device 
monitoring (polling of devices, storage of data, graphing of data), 

RRDTool is "nothing more" than a database layer and grapher of data. 
If you look at the programs supplied with it, it doesn't even have 
anything which can be used for gathering the information from remote 
devices. The only tool, related to RRDTool, which I know which has 
to live in net-mgmt is cacti, because that one is actually providing 
a network management feature. They even say of their product: "Cacti 
is a complete network graphing solution designed to harness the 
power of RRDTool's data storage and graphing functionality.". Nothing 
which states that RRDTool is anything but data storage and graphing. 

NetBSD has located it under databases instead of under net. 
Fedora Core has located it under databases instead of under net. 
Suse has located it under Science / Math instead of under Network. 
Ubuntu has located it under Utilities instead of under network. 

That's why I submitted this PR.
Comment 7 Edwin Groothuis freebsd_committer 2007-06-20 03:45:52 UTC
Hello Dmitry,

We're close to getting a maintainer timeout on this PR again, and
I would like you not to get angry again because of this.

I didn't get your first email, I didn't get a reply to my reply to
you. Nothing is noted in GNATS.

On saturday morning, if a maintainer timeout occurs, I'll be setting
this one again to repocopy and assign it to portmgr for it.

Just a heads up.

Edwin

-- 
Edwin Groothuis
edwin@freebsd.org
http://www.mavetju.org
Comment 8 Dmitry Sivachenko freebsd_committer 2007-06-20 08:45:49 UTC
On Wed, Jun 20, 2007 at 02:50:07AM +0000, Edwin Groothuis wrote:
>  Hello Dmitry,
>  
>  We're close to getting a maintainer timeout on this PR again, and
>  I would like you not to get angry again because of this.
>  
>  I didn't get your first email, I didn't get a reply to my reply to
>  you. Nothing is noted in GNATS.
>  
>  On saturday morning, if a maintainer timeout occurs, I'll be setting
>  this one again to repocopy and assign it to portmgr for it.
>  
>  Just a heads up.
>  
>  Edwin
>  

Yes, you are right.  Sorry for the delay.  I was busy at work.

I still feel uncomfortable with databases category, despite NetBSD
and Fedora Core went this way.  And i still think that most users of
rrdtool assosiate is with network management, and would first search for it
in net-mgmt category.

If you have strong desire to move it to databases, please do. Also 
change MAINTAINER to either ports@ or someone else.

Thanks for your work.
Comment 9 Edwin Groothuis freebsd_committer 2007-06-22 23:19:15 UTC
State Changed
From-To: open->repocopy

Over to portmgr for repocopy. 


Comment 10 Edwin Groothuis freebsd_committer 2007-06-22 23:19:15 UTC
Responsible Changed
From-To: demon->portmgr

Over to portmgr for repocopy. 

Despite your request, I'm not going to reassign maintainership. 
That is outside the scope of this PR, and probably unnecessary.
Comment 11 Joe Marcus Clarke freebsd_committer 2007-07-03 22:10:10 UTC
State Changed
From-To: repocopy->open

Repocopy complete. 


Comment 12 Joe Marcus Clarke freebsd_committer 2007-07-03 22:10:10 UTC
Responsible Changed
From-To: portmgr->edwin

Repocopy complete.
Comment 13 dfilter freebsd_committer 2007-07-05 07:19:57 UTC
edwin       2007-07-05 06:19:49 UTC

  FreeBSD ports repository

  Modified files:
    .                    MOVED 
    databases            Makefile 
    databases/mysqlard   Makefile 
    databases/rrdtool    Makefile 
    devel/p5-RRDTool-OO  Makefile 
    graphics/orca        Makefile 
    mail/couriergraph    Makefile 
    mail/mailgraph       Makefile 
    net                  Makefile 
    net/p5-POE-Component-RRDTool Makefile 
    net/p5-RRD-Simple    Makefile 
    net/php4-rrdtool     Makefile 
    net/php5-rrdtool     Makefile 
    net/py-rrdpipe       Makefile 
    net/py-rrdtool_lgpl  Makefile 
    net/rrdman           Makefile 
    net/rubygem-rrdtool  Makefile 
    net/smokeping        Makefile 
    net-mgmt/bigsister   Makefile 
    net-mgmt/cacti       Makefile 
    net-mgmt/cricket     Makefile 
    net-mgmt/flowscan    Makefile 
    net-mgmt/ifgraph     Makefile 
    net-mgmt/junipoll    Makefile 
    net-mgmt/nagiosgraph Makefile 
    net-mgmt/nagiostat   Makefile 
    net-mgmt/nfdump-devel Makefile 
    net-mgmt/nfsen       Makefile 
    net-mgmt/nfsen-devel Makefile 
    net-mgmt/nrg         Makefile 
    net-mgmt/ourmon      Makefile 
    net-mgmt/torrus      Makefile 
    security/amavis-stats Makefile 
    sysutils/dtc         Makefile 
    sysutils/ganglia-monitor-core Makefile 
    sysutils/munin-main  Makefile 
    sysutils/symon       Makefile 
    www/drraw            Makefile 
  Removed files:
    net/rrdtool          Makefile distinfo pkg-descr pkg-plist 
    net/rrdtool/files    patch-bindings-Makefile.in 
                         patch-doc-Makefile.in 
                         patch-examples-Makefile.in 
  Log:
  First steps in a big migration:
  
      Move net/rrdtool to databases/rrdtool.
  
      It's an itch which needs to be scratched: net/rrdtool came from
      net/mrtg, which was a good location for it. net/mrtg has later
      been moved to net-mgmt/mrtg. net/rrdtool is "Round Robin Database
      Tools", therefor it's better if it moves to databases/rrdtool.
      Same with net/rrdtool10.
  
  PR:             ports/112942
  Submitted by:   Edwin Groothuis <edwin@mavetju.org>
  
  Revision  Changes    Path
  1.1410    +2 -1      ports/MOVED
  1.618     +1 -0      ports/databases/Makefile
  1.2       +1 -1      ports/databases/mysqlard/Makefile
  1.68      +1 -1      ports/databases/rrdtool/Makefile
  1.7       +1 -1      ports/devel/p5-RRDTool-OO/Makefile
  1.4       +1 -1      ports/graphics/orca/Makefile
  1.4       +1 -1      ports/mail/couriergraph/Makefile
  1.32      +1 -1      ports/mail/mailgraph/Makefile
  1.10      +1 -1      ports/net-mgmt/bigsister/Makefile
  1.36      +1 -1      ports/net-mgmt/cacti/Makefile
  1.29      +1 -1      ports/net-mgmt/cricket/Makefile
  1.26      +1 -1      ports/net-mgmt/flowscan/Makefile
  1.7       +1 -1      ports/net-mgmt/ifgraph/Makefile
  1.9       +1 -1      ports/net-mgmt/junipoll/Makefile
  1.5       +1 -1      ports/net-mgmt/nagiosgraph/Makefile
  1.6       +1 -1      ports/net-mgmt/nagiostat/Makefile
  1.13      +1 -1      ports/net-mgmt/nfdump-devel/Makefile
  1.8       +1 -1      ports/net-mgmt/nfsen-devel/Makefile
  1.8       +1 -1      ports/net-mgmt/nfsen/Makefile
  1.6       +1 -1      ports/net-mgmt/nrg/Makefile
  1.4       +1 -1      ports/net-mgmt/ourmon/Makefile
  1.3       +1 -1      ports/net-mgmt/torrus/Makefile
  1.1887    +0 -1      ports/net/Makefile
  1.7       +1 -1      ports/net/p5-POE-Component-RRDTool/Makefile
  1.7       +1 -1      ports/net/p5-RRD-Simple/Makefile
  1.3       +1 -1      ports/net/php4-rrdtool/Makefile
  1.2       +1 -1      ports/net/php5-rrdtool/Makefile
  1.8       +1 -1      ports/net/py-rrdpipe/Makefile
  1.7       +1 -1      ports/net/py-rrdtool_lgpl/Makefile
  1.2       +1 -1      ports/net/rrdman/Makefile
  1.68      +0 -82     ports/net/rrdtool/Makefile (dead)
  1.32      +0 -3      ports/net/rrdtool/distinfo (dead)
  1.7       +0 -26     ports/net/rrdtool/files/patch-bindings-Makefile.in (dead)
  1.5       +0 -14     ports/net/rrdtool/files/patch-doc-Makefile.in (dead)
  1.6       +0 -11     ports/net/rrdtool/files/patch-examples-Makefile.in (dead)
  1.4       +0 -10     ports/net/rrdtool/pkg-descr (dead)
  1.22      +0 -119    ports/net/rrdtool/pkg-plist (dead)
  1.3       +1 -1      ports/net/rubygem-rrdtool/Makefile
  1.40      +1 -1      ports/net/smokeping/Makefile
  1.4       +1 -1      ports/security/amavis-stats/Makefile
  1.17      +1 -1      ports/sysutils/dtc/Makefile
  1.21      +1 -1      ports/sysutils/ganglia-monitor-core/Makefile
  1.13      +1 -1      ports/sysutils/munin-main/Makefile
  1.13      +1 -1      ports/sysutils/symon/Makefile
  1.4       +1 -1      ports/www/drraw/Makefile
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"
Comment 14 Edwin Groothuis freebsd_committer 2007-07-05 07:54:24 UTC
State Changed
From-To: open->closed

Committed, thanks!