Bug 113685 - [patch] devel/subversion: install broken
Summary: [patch] devel/subversion: install broken
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Lev A. Serebryakov
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-06-14 18:40 UTC by Dominic Fandrey
Modified: 2008-01-29 12:18 UTC (History)
0 users

See Also:


Attachments
file.diff (305 bytes, patch)
2007-06-14 18:40 UTC, Dominic Fandrey
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Dominic Fandrey 2007-06-14 18:40:04 UTC
The installation of devel/subversion is broken on my system.

Adding USE_GMAKE=yes to the Makefile solves this for me.

===>  Installing for subversion-1.4.3_2
===>   subversion-1.4.3_2 depends on shared library: expat.6 - found
===>   subversion-1.4.3_2 depends on shared library: neon.26 - found
===>   subversion-1.4.3_2 depends on shared library: apr-1.2 - found
===>   subversion-1.4.3_2 depends on shared library: intl - found
===>   Generating temporary packing list
subversion/svnversion/svnversion . /repos/svn/trunk >
/usr/local/include/subversion-1/svn-revision.txt
cannot create /usr/local/include/subversion-1/svn-revision.txt: No such file or
directory
*** Error code 2
1 error
*** Error code 2

Stop in /usr/ports/devel/subversion.
*** Error code 1

Stop in /usr/ports/devel/subversion.

How-To-Repeat: # cd /usr/ports/devel/subversion
# make install
Comment 1 Edwin Groothuis freebsd_committer 2007-06-14 18:40:14 UTC
Responsible Changed
From-To: freebsd-ports-bugs->lev

Over to maintainer
Comment 2 Lev A. Serebryakov freebsd_committer 2007-07-18 09:07:57 UTC
  Can you reproduce this problem with new 1.4.4?
Comment 3 Lev A. Serebryakov freebsd_committer 2007-07-18 09:08:17 UTC
State Changed
From-To: open->feedback

Can you reproduce this problem with new 1.4.4?
Comment 4 Dominic Fandrey 2007-07-18 21:19:40 UTC
lev@FreeBSD.org wrote:
> Synopsis: [patch] devel/subversion: install broken
>
> State-Changed-From-To: open->feedback
> State-Changed-By: lev
> State-Changed-When: Wed Jul 18 08:08:17 UTC 2007
> State-Changed-Why:
> Can you reproduce this problem with new 1.4.4?
>
> http://www.freebsd.org/cgi/query-pr.cgi?pr=113685
>

The problem persists with version 1.4.4:

# make install
===>  Installing for subversion-1.4.4
===>   subversion-1.4.4 depends on shared library: expat.6 - found
===>   subversion-1.4.4 depends on shared library: neon.26 - found
===>   subversion-1.4.4 depends on shared library: apr-1.2 - found
===>   subversion-1.4.4 depends on shared library: intl - found
===>   Generating temporary packing list
===>  Checking if devel/subversion already installed
subversion/svnversion/svnversion . /repos/svn/trunk >
/usr/local/include/subversion-1/svn-revision.txt
cannot create /usr/local/include/subversion-1/svn-revision.txt: No such file or
directory
*** Error code 2
1 error
*** Error code 2

Stop in /usr/ports/devel/subversion.


USE_GMAKE still solves it for me:

# make install -DUSE_GMAKE
===>  Installing for subversion-1.4.4
===>   subversion-1.4.4 depends on shared library: expat.6 - found
===>   subversion-1.4.4 depends on shared library: neon.26 - found
===>   subversion-1.4.4 depends on shared library: apr-1.2 - found
===>   subversion-1.4.4 depends on shared library: intl - found
===>   Generating temporary packing list
===>  Checking if devel/subversion already installed
/usr/bin/install -c -o root -g wheel -d /usr/local/lib
cd subversion/libsvn_subr ; /usr/local/bin/libtool --mode=install
/usr/bin/install -c -o root -g wheel libsvn_subr-1.la
/usr/local/lib/libsvn_subr-1.la
/usr/bin/install -c -o root -g wheel .libs/libsvn_subr-1.so.0
/usr/local/lib/libsvn_subr-1.so.0
(cd /usr/local/lib && { ln -s -f libsvn_subr-1.so.0 libsvn_subr-1.so || { rm -f
libsvn_subr-1.so && ln -s libsvn_subr-1.so.0 libsvn_subr-1.so; }; })
(cd /usr/local/lib && { ln -s -f libsvn_subr-1.so.0 libsvn_subr-1.so || { rm -f
libsvn_subr-1.so && ln -s libsvn_subr-1.so.0 libsvn_subr-1.so; }; })
/usr/bin/install -c -o root -g wheel .libs/libsvn_subr-1.lai
/usr/local/lib/libsvn_subr-1.la

...

/bin/mkdir -p /usr/local/share/doc/subversion
for f in BUGS CHANGES COMMITTERS COPYING HACKING INSTALL README; do  install
-o root -g wheel -m 444
/usr/obj/mobileKamikaze.norad/usr/ports/devel/subversion/work/subversion-1.4.4/$f
/usr/local/share/doc/subversion;  done
===> Installing rc.d startup script(s)
===>   Compressing manual pages for subversion-1.4.4
===>   Running ldconfig
/sbin/ldconfig -m /usr/local/lib
===>   Registering installation for subversion-1.4.4
Comment 5 Lev A. Serebryakov freebsd_committer 2007-07-28 19:28:27 UTC
Hello bug-followup,

  Did you have `/usr/local' as symlink? Or something other non-standard in your tree?
  I can not reproduce this one, and I don't like `magic fix' without understanding of problem...

-- 
Best regards,
 Lev                          mailto:lev@FreeBSD.org
Comment 6 Dominic Fandrey 2007-07-28 19:55:42 UTC
Lev Serebryakov wrote:
> Hello bug-followup,
> 
>   Did you have `/usr/local' as symlink? Or something other non-standard in your tree?
>   I can not reproduce this one, and I don't like `magic fix' without understanding of problem...
> 

No, I don't have any such thing. The problem is that the subversion makefiles
are written for GNU Make and at least on my system without USE_GMAKE the
default make /usr/bin/make is used.

I don't know why it seems to work with USE_GMAKE for others, it really
shouldn't the way I see it.
Comment 7 Dominic Fandrey 2007-07-28 20:25:08 UTC
[LoN]Kamikaze wrote:
> Lev Serebryakov wrote:
>> Hello bug-followup,
>>
>>   Did you have `/usr/local' as symlink? Or something other non-standard in your tree?
>>   I can not reproduce this one, and I don't like `magic fix' without understanding of problem...
>>
> 
> No, I don't have any such thing. The problem is that the subversion makefiles
> are written for GNU Make and at least on my system without USE_GMAKE the
> default make /usr/bin/make is used.
> 
> I don't know why it seems to work with USE_GMAKE for others, it really
> shouldn't the way I see it.

s/work with/work without/1
Comment 8 Pav Lucistnik freebsd_committer 2007-12-14 16:19:29 UTC
State Changed
From-To: feedback->open

Feedback received
Comment 9 Lev A. Serebryakov freebsd_committer 2008-01-29 12:17:40 UTC
State Changed
From-To: open->closed

Can not reproduce with new 1.4.6