Bug 113894 - x11/xdm clobbers config files
Summary: x11/xdm clobbers config files
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: freebsd-x11 (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-06-21 03:40 UTC by Stephen Hurd
Modified: 2007-07-02 19:23 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Stephen Hurd freebsd_committer 2007-06-21 03:40:01 UTC
x11/xdm upgrade clobbers configuration files in lib/X11/xdm

Fix: 

Handle according to guidlines at http://www.freebsd.org/doc/en_US.ISO8859-1/books/porters-handbook/plist-config.html

(xfs may do the same thing)
How-To-Repeat: Hand craft some xdm config files.
portupgrade adm
Comment 1 Edwin Groothuis freebsd_committer 2007-06-21 03:40:10 UTC
Responsible Changed
From-To: freebsd-ports-bugs->freebsd-x11

Over to maintainer
Comment 2 dfilter service freebsd_committer 2007-07-02 18:35:19 UTC
lesi        2007-07-02 17:35:13 UTC

  FreeBSD ports repository

  Modified files:
    x11/xdm              Makefile pkg-plist 
  Added files:
    x11/xdm/files        patch-config_Makefile.in 
  Log:
  Replace placeholder XDMCONFIGDIR with proper value in Xreset and Xstartup
  scripts [1].
  Don't clobber user modifiable config files and scripts [2].
  
  PR:             [1] ports/113029 (REINPLACE instead of patch), [2] ports/113894
  
  Revision  Changes    Path
  1.3       +13 -1     ports/x11/xdm/Makefile
  1.1       +68 -0     ports/x11/xdm/files/patch-config_Makefile.in (new)
  1.3       +38 -14    ports/x11/xdm/pkg-plist
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"
Comment 3 lesi freebsd_committer 2007-07-02 19:22:21 UTC
State Changed
From-To: open->closed

Sorry, this got lost somehow in modular split. Should be fixed now. Thanks!