Bug 114100 - OpenOffice 2.2.1 dies in building gcc-ooo on FreeBSD 7.0-CURRENT/i386
Summary: OpenOffice 2.2.1 dies in building gcc-ooo on FreeBSD 7.0-CURRENT/i386
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: freebsd-openoffice (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-06-28 17:50 UTC by O. Hartmann
Modified: 2007-10-03 01:30 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description O. Hartmann 2007-06-28 17:50:02 UTC
On a recently fresh installed FreeBSD 7.0-CURRENT/i386 box the compilation of the most recent OpenOffice 2.2.1-port dies in building gcc-ooo.

Trying to build the gcc-ooo-port separately also fails in the same error:


checking whether build environment is sane... yes
checking for gawk... no
checking for mawk... no
checking for nawk... nawk
checking whether gmake sets $(MAKE)... yes
checking for i386-portbld-freebsd7.0-gcc... /usr/ports/lang/gcc-ooo/work/build/gcc/xgcc -B/usr/ports/lang/gcc-ooo/work/build/gcc/ -B/usr/local/i386-portbld-freebsd7.0/bin/ -B/usr/local/i386-portbld-freebsd7.0/lib/ -isystem /usr/local/i386-portbld-freebsd7.0/include -isystem /usr/local/i386-portbld-freebsd7.0/sys-include
checking for suffix of object files... configure: error: cannot compute suffix of object files: cannot compile
See `config.log' for more details.
gmake[1]: *** [configure-target-libstdc++-v3] Error 1
gmake[1]: Leaving directory `/usr/ports/lang/gcc-ooo/work/build'
gmake: *** [bootstrap-lean] Error 2
*** Error code 2

How-To-Repeat: Try building OpenOffice on i386 with most recent FreeBSD 7.0-CURRENT and Xorg 7.2 (most recent port build).
Comment 1 Mark Linimon freebsd_committer freebsd_triage 2007-06-28 18:13:49 UTC
Responsible Changed
From-To: freebsd-ports-bugs->openoffice

Over to maintainer(s).
Comment 2 blackdragon 2007-07-17 20:55:26 UTC
Hi,

I had the same problem.  With exactly the same error message.  I found that 
when gcc-ooo receives an argument that it does not recognise, it fails.  This 
is a problem since I am using gcc4 with -O2 and appropriate flags to work 
around bugs (one flag is specific to gcc4).  The following are the compiler 
flags that I have:

CFLAGS= -O2 -fno-strict-aliasing -fno-tree-vrp -pipe
CXXFLAGS+= -fconserve-space
CPUTYPE=i686

The specific flag to gcc4 is "-fno-tree-vrp" so I changed CFLAGS to:

CFLAGS= -O2 -fno-strict-aliasing -pipe

And OpenOffice compiled without a problem.  (I have another problem with 
OpenOffice and saving .odt files but I have not determined where the problem 
lies).  I recommend changing the OpenOffice port to check that when compiling 
with gcc-ooo no gcc 4 specific flags are included.  

Wishing you the best of luck.  

David
Comment 3 Maho Nakata freebsd_committer 2007-10-03 01:29:07 UTC
State Changed
From-To: open->closed

Now it is updated to 2.3.0 and it uses gcc4.2. 
Using gcc4.2, this problem should go away. 

Thanks for your report.