Bug 114306 - [PATCH] Fix build of mail/mutt-ng when sane-backends is installed
Summary: [PATCH] Fix build of mail/mutt-ng when sane-backends is installed
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: freebsd-ports-bugs (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-07-05 00:20 UTC by Christoph Moench-Tegeder
Modified: 2007-07-10 09:10 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Christoph Moench-Tegeder freebsd_committer 2007-07-05 00:20:05 UTC
Build of mail/mutt-ng fails when sane-backends is installed: muttng ships
with a component called libsane (build in muttng-20061125/lib) which is needed
for linking muttng. Because of the linker search path, libsane from
sane-backends hides this library, so linking muttng fails with numerous
unresolved references.

Fix: Force mutt-ng/work/muttng-20061125/lib to the beginning of the linker
search path.
If the patch is botched by mail wrangling, grab it here:
http://www.burggraben.net/~cmt/tmp/patch_muttng



Regards
Christoph

-- 
Spare Space--dA4TgcTE6L7GxA03uL3Hg0538uJXgSZPgjMaH9mBxBmfJ5nr
Content-Type: text/plain; name="file.diff"
Content-Transfer-Encoding: 7bit
Content-Disposition: attachment; filename="file.diff"

--- files/patch-Makefile.in.orig	Thu Jul  5 00:25:02 2007
+++ files/patch-Makefile.in	Thu Jul  5 00:20:19 2007
@@ -18,6 +18,15 @@
  am_makedoc_OBJECTS = makedoc.$(OBJEXT)
  makedoc_OBJECTS = $(am_makedoc_OBJECTS)
  am__objects_1 = patchlist.$(OBJEXT)
+@@ -267,7 +269,7 @@
+ INTL_LIBTOOL_SUFFIX_PREFIX = @INTL_LIBTOOL_SUFFIX_PREFIX@
+ ISPELL = @ISPELL@
+ KRB5CFGPATH = @KRB5CFGPATH@
+-LDFLAGS = @LDFLAGS@
++LDFLAGS = -Llib @LDFLAGS@
+ LIBGNUTLS_CFLAGS = @LIBGNUTLS_CFLAGS@
+ LIBGNUTLS_CONFIG = @LIBGNUTLS_CONFIG@
+ LIBGNUTLS_LIBS = @LIBGNUTLS_LIBS@
 @@ -467,7 +469,6 @@
  	@rm -f stamp-h1
  	cd $(top_builddir) && $(SHELL) ./config.status config.h
How-To-Repeat: Install sane-backends, try to compile muttng.
Comment 1 Edwin Groothuis freebsd_committer 2007-07-05 00:20:12 UTC
State Changed
From-To: open->feedback

Awaiting maintainers feedback
Comment 2 Josh Paetzel <josh@tcbug.org> 2007-07-05 01:32:31 UTC
On Wednesday 04 July 2007, Edwin Groothuis wrote:
> Maintainer of mail/mutt-ng,
>
> Please note that PR ports/114306 has just been submitted.
>
> If it contains a patch for an upgrade, an enhancement or a bug fix
> you agree on, reply to this email stating that you approve the
> patch and a committer will take care of it.
>
> The full text of the PR can be found at:
>     http://www.freebsd.org/cgi/query-pr.cgi?pr=ports/114306


I've been unable to dupliate this bug, there's another PR open on it 
as well, ports/112074

But in looking at this PR I did a fresh install of 6.2-R on a scratch 
box and tried to duplicate it and was able to duplicate it this time, 
as well as confirm the patch resolves it.

Please commit the patch and close ports/112074

Thanks for the fix.

-- 
Thanks,

Josh Paetzel
Comment 3 Christoph Moench-Tegeder freebsd_committer 2007-07-05 13:00:20 UTC
## Josh Paetzel (josh@tcbug.org):

> I've been unable to dupliate this bug, there's another PR open on it 
> as well, ports/112074


Sorry, I missed that one, that's an exact duplicate of mine. So 112074
and 114306 are resolved.

Regards
Christoph

-- 
Spare Space
Comment 4 Mark Linimon freebsd_committer freebsd_triage 2007-07-05 21:09:48 UTC
State Changed
From-To: feedback->closed

Submitter notes that this one can be closed.
Comment 5 Mark Linimon freebsd_committer freebsd_triage 2007-07-05 22:31:31 UTC
State Changed
From-To: closed->open

Closed by mistake.
Comment 6 dfilter service freebsd_committer 2007-07-10 09:05:42 UTC
miwi        2007-07-10 08:05:37 UTC

  FreeBSD ports repository

  Modified files:
    mail/mutt-ng/files   patch-Makefile.in 
  Log:
  - Fix build with sane-backends
  
  PR:             114306
  Submitted by:   Christoph Moench-Tegeder <cmt@burggraben.net>
  Approved by:    maintainer
  
  Revision  Changes    Path
  1.3       +9 -0      ports/mail/mutt-ng/files/patch-Makefile.in
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"
Comment 7 Martin Wilke freebsd_committer 2007-07-10 09:05:43 UTC
State Changed
From-To: open->closed

Committed. Thanks!